h264parse: ignore GST_H264_PARSER_NO_NAL return when last nal type is GST_H264_NAL_SE...
[platform/upstream/gstreamer.git] / packaging / gst-plugins-bad.spec
index 6cdbde8..8b4da0b 100644 (file)
@@ -4,7 +4,7 @@
 
 Name:           gst-plugins-bad
 Version:        1.16.2
-Release:        1
+Release:        5
 Summary:        GStreamer Streaming-Media Framework Plug-Ins
 License:        LGPL-2.0+
 Group:          Multimedia/Framework
@@ -31,6 +31,11 @@ BuildRequires:  pkgconfig(soundtouch) > 1.4
 BuildRequires:  pkgconfig(nice)
 BuildRequires:  pkgconfig(usrsctp)
 BuildRequires:  pkgconfig(libsrtp2) >= 2.1.0
+BuildRequires:  pkgconfig(opus)
+%if 0%{?webrtctest:1}
+BuildRequires:  pkgconfig(json-glib-1.0)
+BuildRequires:  pkgconfig(libsoup-2.4)
+%endif
 %if %{with wayland}
 %if 0%{?enable_gl:1}
 BuildRequires:  pkgconfig(gles20)
@@ -78,6 +83,8 @@ export CFLAGS+=" -Wall -g -fPIC\
   -DTIZEN_FEATURE_ADAPTIVE_MODIFICATION\
   -DTIZEN_FEATURE_TSDEMUX_MODIFICATION\
   -DTIZEN_FEATURE_OALSINK_MODIFICATION\
+  -DTIZEN_FEATURE_MPEGDEMUX_MODIFICATION\
+  -DTIZEN_FEATURE_H264PARSE_MODIFICATION\
   -DTIZEN_FEATURE_UPSTREAM\
   -fstack-protector-strong\
   -Wl,-z,relro\
@@ -100,7 +107,6 @@ export LDFLAGS+=" -pthread "
        --disable-jpegformat\
        --disable-mpegdemux\
        --disable-smoothstreaming\
-       --disable-coloreffects\
        --disable-rtp\
        --disable-gl\
 %endif
@@ -110,7 +116,6 @@ export LDFLAGS+=" -pthread "
        --disable-decklink\
        --disable-dvb\
        --disable-fieldanalysis\
-       --disable-gdp\
        --disable-ivtc\
        --disable-rawparse\
        --disable-videofilters\
@@ -131,7 +136,6 @@ export LDFLAGS+=" -pthread "
        --disable-festival\
        --disable-freeverb\
        --disable-frei0r\
-       --disable-gaudieffects\
        --disable-geometrictransform\
        --disable-inter\
        --disable-interlace\
@@ -154,6 +158,9 @@ export LDFLAGS+=" -pthread "
        --enable-egl=yes\
        --enable-gles2=yes\
 %endif
+%if 0%{?webrtctest:1}
+       --enable-webrtctest\
+%endif
        --enable-wayland=yes\
        --enable-openal=yes\
        --disable-sndfile\
@@ -185,7 +192,6 @@ rm -rf $RPM_BUILD_ROOT
 %if "%{tizen_profile_name}" != "tv"
 %{_libdir}/gstreamer-%{gst_branch}/libgstautoconvert.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstcamerabin.so
-%{_libdir}/gstreamer-%{gst_branch}/libgstcoloreffects.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstid3tag.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstjpegformat.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegpsdemux.so
@@ -205,6 +211,7 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %{_libdir}/libgstisoff-%{gst_branch}.so.0*
 %endif
+%{_libdir}/gstreamer-%{gst_branch}/libgstgdp.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstdebugutilsbad.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsdemux.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsmux.so
@@ -227,12 +234,18 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/gstreamer-%{gst_branch}/libgstsctp.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstsrtp.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstopusparse.so
+%{_libdir}/gstreamer-%{gst_branch}/libgstgaudieffects.so
+%{_libdir}/gstreamer-%{gst_branch}/libgstcoloreffects.so
+
 %{_libdir}/libgstsctp-%{gst_branch}.so.0*
 %{_libdir}/libgstwebrtc-%{gst_branch}.so.0*
 %{_libdir}/libgstcodecparsers-%{gst_branch}.so.0*
 %{_libdir}/libgstmpegts-%{gst_branch}.so.0*
 %{_libdir}/libgstbadaudio-%{gst_branch}.so.0*
 %{_libdir}/libgstplayer-%{gst_branch}.so.0*
+%if 0%{?webrtctest:1}
+%{_bindir}/webrtc*
+%endif
 
 %files devel
 %manifest %{name}.manifest