Merge branch 'upstream/1.16' into tizen_gst_1.16.2
[platform/upstream/gstreamer.git] / libs / gst / helpers / Makefile.am
index 8b181be..276b406 100644 (file)
@@ -1,14 +1,3 @@
-if ENABLE_BASH_COMPLETION
-bin_PROGRAMS = gst-completion-helper-@GST_API_VERSION@
-
-gst_completion_helper_@GST_API_VERSION@_SOURCES = gst-completion-helper.c
-gst_completion_helper_@GST_API_VERSION@_CFLAGS = $(GST_OBJ_CFLAGS)
-gst_completion_helper_@GST_API_VERSION@_LDADD = $(GST_OBJ_LIBS)
-
-bashhelpersdir = $(BASH_HELPERS_DIR)
-dist_bashhelpers_DATA = gst
-endif
-
 helpers_PROGRAMS = gst-plugin-scanner
 helpersdir=$(libexecdir)/gstreamer-$(GST_API_VERSION)
 
@@ -17,6 +6,13 @@ gst_plugin_scanner_CFLAGS = $(GST_OBJ_CFLAGS) -fPIE
 gst_plugin_scanner_LDADD = $(GST_OBJ_LIBS)
 gst_plugin_scanner_LDFLAGS = -pie
 
+if ENABLE_BASH_COMPLETION
+helpers_PROGRAMS += gst-completion-helper
+gst_completion_helper_SOURCES = gst-completion-helper.c
+gst_completion_helper_CFLAGS = $(GST_OBJ_CFLAGS)
+gst_completion_helper_LDADD = $(GST_OBJ_LIBS)
+endif
+
 if HAVE_PTP
 helpers_PROGRAMS += gst-ptp-helper
 gst_ptp_helper_SOURCES = gst-ptp-helper.c
@@ -25,7 +21,7 @@ gst_ptp_helper_LDADD = $(GST_OBJ_LIBS) $(GIO_LIBS) $(CAP_LIBS)
 gst_ptp_helper_LDFLAGS = -pie
 endif
 
-install-exec-hook: install-helpersPROGRAMS
+install-data-hook:
 if HAVE_PTP
 if HAVE_PTP_HELPER_SETUID
        - chown root $(DESTDIR)$(helpersdir)/gst-ptp-helper
@@ -35,21 +31,18 @@ if HAVE_PTP_HELPER_CAPABILITIES
        - $(SETCAP) cap_net_bind_service,cap_net_admin+ep $(DESTDIR)$(helpersdir)/gst-ptp-helper
 endif
 endif
-if ENABLE_BASH_COMPLETION
-       $(MKDIR_P) $(DESTDIR)$(BASH_HELPERS_DIR) && \
-       cd $(DESTDIR)$(bindir) && \
-       $(INSTALL) `echo "gst-completion-helper-" | sed '$(transform)'`@GST_API_VERSION@$(EXEEXT) \
-        $(DESTDIR)$(BASH_HELPERS_DIR)/gst-completion-helper-@GST_API_VERSION@$(EXEEXT) && \
-       rm `echo "gst-completion-helper-" | sed '$(transform)'`@GST_API_VERSION@$(EXEEXT)
 
-uninstall-hook:
-       rm -f $(DESTDIR)$(BASH_HELPERS_DIR)/gst-completion-helper-@GST_API_VERSION@$(EXEEXT)
-endif
+EXTRA_DIST = ptp_helper_post_install.sh
 
-# clean out the old one to make sure everything is udpated correctly
-# remove again after release
-CLEANFILES = plugin-scanner
+DISTCLEANFILES = libgstreamer-gdb.py
 
-if ENABLE_BASH_COMPLETION
-CLEANFILES += gst-completion-helper-@GST_API_VERSION@
-endif
+# install gdb scripts
+gdbdir = $(datadir)/gstreamer-@GST_API_VERSION@/gdb
+dist_gdb_DATA = gst_gdb.py glib_gobject_helper.py
+
+install-data-hook:
+       $(INSTALL) -d $(DESTDIR)$(datadir)/gdb/auto-load$(libdir)
+       $(INSTALL) $(builddir)/libgstreamer-gdb.py $(DESTDIR)$(datadir)/gdb/auto-load$(libdir)/libgstreamer-@GST_API_VERSION@.so.0.$(GST_CURRENT).$(GST_REVISION)-gdb.py
+
+uninstall-hook:
+       rm -f "$(DESTDIR)$(datadir)/gdb/auto-load$(libdir)/libgstreamer-@GST_API_VERSION@.so.0.$(GST_CURRENT).$(GST_REVISION)-gdb.py"