Merge branch 'upstream/1.16' into tizen_gst_1.16.2
[platform/upstream/gstreamer.git] / libs / gst / helpers / Makefile.am
index 534ac51..276b406 100644 (file)
@@ -32,10 +32,17 @@ if HAVE_PTP_HELPER_CAPABILITIES
 endif
 endif
 
-# clean out the old one to make sure everything is udpated correctly
-# remove again after release
-CLEANFILES = plugin-scanner
+EXTRA_DIST = ptp_helper_post_install.sh
 
-if ENABLE_BASH_COMPLETION
-CLEANFILES += gst-completion-helper-@GST_API_VERSION@
-endif
+DISTCLEANFILES = libgstreamer-gdb.py
+
+# install gdb scripts
+gdbdir = $(datadir)/gstreamer-@GST_API_VERSION@/gdb
+dist_gdb_DATA = gst_gdb.py glib_gobject_helper.py
+
+install-data-hook:
+       $(INSTALL) -d $(DESTDIR)$(datadir)/gdb/auto-load$(libdir)
+       $(INSTALL) $(builddir)/libgstreamer-gdb.py $(DESTDIR)$(datadir)/gdb/auto-load$(libdir)/libgstreamer-@GST_API_VERSION@.so.0.$(GST_CURRENT).$(GST_REVISION)-gdb.py
+
+uninstall-hook:
+       rm -f "$(DESTDIR)$(datadir)/gdb/auto-load$(libdir)/libgstreamer-@GST_API_VERSION@.so.0.$(GST_CURRENT).$(GST_REVISION)-gdb.py"