Merge branch 'upstream/1.16' into tizen_gst_1.16.2
[platform/upstream/gstreamer.git] / libs / gst / helpers / Makefile.am
index 2047580..276b406 100644 (file)
@@ -2,8 +2,9 @@ helpers_PROGRAMS = gst-plugin-scanner
 helpersdir=$(libexecdir)/gstreamer-$(GST_API_VERSION)
 
 gst_plugin_scanner_SOURCES = gst-plugin-scanner.c
-gst_plugin_scanner_CFLAGS = $(GST_OBJ_CFLAGS)
+gst_plugin_scanner_CFLAGS = $(GST_OBJ_CFLAGS) -fPIE
 gst_plugin_scanner_LDADD = $(GST_OBJ_LIBS)
+gst_plugin_scanner_LDFLAGS = -pie
 
 if ENABLE_BASH_COMPLETION
 helpers_PROGRAMS += gst-completion-helper
@@ -15,8 +16,9 @@ endif
 if HAVE_PTP
 helpers_PROGRAMS += gst-ptp-helper
 gst_ptp_helper_SOURCES = gst-ptp-helper.c
-gst_ptp_helper_CFLAGS = $(GST_OBJ_CFLAGS) $(GIO_CFLAGS)
+gst_ptp_helper_CFLAGS = $(GST_OBJ_CFLAGS) $(GIO_CFLAGS) -fPIE
 gst_ptp_helper_LDADD = $(GST_OBJ_LIBS) $(GIO_LIBS) $(CAP_LIBS)
+gst_ptp_helper_LDFLAGS = -pie
 endif
 
 install-data-hook:
@@ -39,7 +41,8 @@ gdbdir = $(datadir)/gstreamer-@GST_API_VERSION@/gdb
 dist_gdb_DATA = gst_gdb.py glib_gobject_helper.py
 
 install-data-hook:
-       $(INSTALL) -D $(builddir)/libgstreamer-gdb.py $(DESTDIR)$(datadir)/gdb/auto-load$(libdir)/libgstreamer-@GST_API_VERSION@.so.0.$(GST_CURRENT).$(GST_REVISION)-gdb.py
+       $(INSTALL) -d $(DESTDIR)$(datadir)/gdb/auto-load$(libdir)
+       $(INSTALL) $(builddir)/libgstreamer-gdb.py $(DESTDIR)$(datadir)/gdb/auto-load$(libdir)/libgstreamer-@GST_API_VERSION@.so.0.$(GST_CURRENT).$(GST_REVISION)-gdb.py
 
 uninstall-hook:
        rm -f "$(DESTDIR)$(datadir)/gdb/auto-load$(libdir)/libgstreamer-@GST_API_VERSION@.so.0.$(GST_CURRENT).$(GST_REVISION)-gdb.py"