packaging: changelog: update to 0.5.8 version
[platform/upstream/gstreamer-vaapi.git] / packaging / gstreamer-vaapi.spec
1 %bcond_with x
2
3 Name:       gstreamer-vaapi
4 Version:    0.5.8
5 Release:    0
6 Summary:    VA-API based plugins for GStreamer and helper libraries
7 Group:      Multimedia/Multimedia Framework
8 License:    LGPL-2.1+ and GPL-2.0+
9 URL:        http://gitorious.org/vaapi/gstreamer-vaapi
10 Source0:    %{name}-%{version}.tar.bz2
11 Source1001: gstreamer-vaapi.manifest
12 Source2001: codecparsers.tar.bz2
13 Source2002: videoutils.tar.bz2
14 %if %{with x}
15 BuildRequires:  pkgconfig(x11)
16 %endif
17
18 BuildRequires:  pkgconfig(libva)
19 BuildRequires:  pkgconfig(gstreamer-1.0)
20 BuildRequires:  pkgconfig(gstreamer-basevideo-1.0)
21 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
22 BuildRequires:  pkgconfig(libdrm)
23 BuildRequires:  which
24 BuildRequires:  git
25 ExclusiveArch:  %{ix86} x86_64
26
27 %description
28 Gstreamer-vaapi is a collection of VA-API based plugins for GStreamer
29 and helper libraries. vaapidecode is used to decode MPEG-2, MPEG-4,
30 H.264, VC-1, WMV3 videos to video/x-vaapi-surface surfaces, depending
31 on the underlying HW capabilities. vaapiconvert is used to convert from
32 video/x-raw-yuv pixels to video/x-vaapi-surface surfaces. vaapisink is
33 used to display video/x-vaapi-surface surfaces to the screen.
34
35 %package devel
36 Summary:    Development files for gstreamer-vaapi
37 Group:      Development/Libraries
38 Requires:   %{name} = %{version}
39 Requires:   pkgconfig
40
41 %description devel
42 The %{name}-devel package contains libraries and header files for
43 developing applications that use %{name}.
44
45 %prep
46 %setup -q 
47 %setup -q -T -D -a 2001
48 %setup -q -T -D -a 2002
49
50
51 %build
52 cp %{SOURCE1001} .
53
54 %autogen --with-gstreamer-api=1.0 --enable-encoders
55 make %{?_smp_mflags}
56
57 %install
58 %make_install
59
60 %post -p /sbin/ldconfig
61
62 %postun -p /sbin/ldconfig
63
64 %files
65 %manifest %{name}.manifest
66 %license COPYING.LIB
67 %{_libdir}/*.so.*
68 %{_libdir}/gstreamer-1.0/*.so
69
70 %files devel
71 %manifest %{name}.manifest
72 %license COPYING.LIB
73 %dir %{_includedir}/gstreamer-1.0/gst/vaapi
74 %{_includedir}/gstreamer-1.0/gst/vaapi/*.h
75 %{_libdir}/*.so
76 %{_libdir}/pkgconfig/%{name}*.pc