add buildrequire of gl
[platform/upstream/gstreamer-vaapi.git] / packaging / gstreamer-vaapi.spec
1 %bcond_with x
2
3 Name:       gstreamer-vaapi
4 Version:    0.5.9
5 Release:    0
6 Summary:    VA-API based plugins for GStreamer and helper libraries
7 Group:      Multimedia/Multimedia Framework
8 License:    LGPL-2.1+ and GPL-2.0+
9 URL:        http://gitorious.org/vaapi/gstreamer-vaapi
10 Source0:    %{name}-%{version}.tar.bz2
11 Source1001: gstreamer-vaapi.manifest
12 Source2001: codecparsers.tar.bz2
13 Source2002: videoutils.tar.bz2
14 Source2003: upstream.tar.bz2
15 %if %{with x}
16 BuildRequires:  pkgconfig(x11)
17 %endif
18
19 BuildRequires:  pkgconfig(libva)
20 BuildRequires:  pkgconfig(gstreamer-1.0)
21 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
22 BuildRequires:  pkgconfig(libdrm)
23 BuildRequires:  pkgconfig(gles20)
24 BuildRequires:  yasm
25 BuildRequires:  which
26 BuildRequires:  git
27 ExclusiveArch:  %{ix86} x86_64
28
29 %description
30 Gstreamer-vaapi is a collection of VA-API based plugins for GStreamer
31 and helper libraries. vaapidecode is used to decode MPEG-2, MPEG-4,
32 H.264, VC-1, WMV3 videos to video/x-vaapi-surface surfaces, depending
33 on the underlying HW capabilities. vaapiconvert is used to convert from
34 video/x-raw-yuv pixels to video/x-vaapi-surface surfaces. vaapisink is
35 used to display video/x-vaapi-surface surfaces to the screen.
36
37 %package devel
38 Summary:    Development files for gstreamer-vaapi
39 Group:      Development/Libraries
40 Requires:   %{name} = %{version}
41 Requires:   pkgconfig
42
43 %description devel
44 The %{name}-devel package contains libraries and header files for
45 developing applications that use %{name}.
46
47 %prep
48 %setup -q
49 %setup -q -T -D -a 2001
50 %setup -q -T -D -a 2002
51 %setup -q -T -D -a 2003
52
53
54 %build
55 cp %{SOURCE1001} .
56
57 %autogen \
58     --with-gstreamer-api=1.2 \
59     --enable-encoders
60
61 %__make %{?_smp_mflags} V=1
62
63 %install
64 %make_install
65
66 %post -p /sbin/ldconfig
67
68 %postun -p /sbin/ldconfig
69
70 %files
71 %manifest %{name}.manifest
72 %license COPYING.LIB
73 %{_libdir}/*.so.*
74 %{_libdir}/gstreamer-1.0/*.so
75
76 %files devel
77 %manifest %{name}.manifest
78 %license COPYING.LIB
79 %dir %{_includedir}/gstreamer-*/gst/vaapi
80 %{_includedir}/gstreamer-*/gst/vaapi/*.h
81 %{_libdir}/*.so
82 %{_libdir}/pkgconfig/%{name}*.pc