[effectv] Enable effectv for Media Editing FW
[platform/upstream/gst-plugins-good.git] / packaging / gst-plugins-good.spec
1 %bcond_with x
2 %define gst_branch 1.0
3
4 Name:           gst-plugins-good
5 Version:        1.16.2
6 Release:        31
7 License:        LGPL-2.1+
8 Summary:        GStreamer Streaming-Media Framework Plug-Ins
9 Url:            http://gstreamer.freedesktop.org/
10 Group:          Multimedia/Framework
11 Source:         http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-%{version}.tar.xz
12 Source100:      common.tar.gz
13 BuildRequires:  gcc-c++
14 BuildRequires:  gettext-tools
15 BuildRequires:  pkgconfig(glib-2.0) >= 2.32
16 BuildRequires:  pkgconfig(gstreamer-1.0)
17 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  orc >= 0.4.16
20 BuildRequires:  python
21 BuildRequires:  xsltproc
22 BuildRequires:  pkgconfig(bzip2)
23 BuildRequires:  pkgconfig(libpng) >= 1.2
24 BuildRequires:  pkgconfig(libpulse) >= 1.0
25 BuildRequires:  pkgconfig(libsoup-2.4)
26 BuildRequires:  pkgconfig(libxml-2.0) >= 2.4.9
27 # TODO find where process.h comes from, not kernel-devel and not wxWidgets so far.
28 %if %{with x}
29 BuildRequires:  pkgconfig(ice)
30 BuildRequires:  pkgconfig(sm)
31 BuildRequires:  pkgconfig(xdamage)
32 BuildRequires:  pkgconfig(xfixes)
33 # used by libgstvideo4linux2.so
34 BuildRequires:  pkgconfig(xv)
35 %endif
36
37 BuildRequires:  pkgconfig(vpx)
38 BuildRequires:  pkgconfig(zlib)
39 %if "%{tizen_profile_name}" != "tv"
40 BuildRequires:  pkgconfig(libv4l2)
41 %endif
42 BuildRequires:  pkgconfig(vconf)
43 BuildRequires:  pkgconfig(gio-2.0)
44 BuildRequires:  pkgconfig(libtbm)
45 Requires:       gst-plugins-base >= 1.0.0
46 Requires:       gstreamer >= 1.0.5
47
48 %description
49 GStreamer is a streaming media framework based on graphs of filters
50 that operate on media data. Applications using this library can do
51 anything media-related, from real-time sound processing to playing
52 videos. Its plug-in-based architecture means that new data types or
53 processing capabilities can be added simply by installing new plug-ins.
54
55 %package extra
56 Summary:        Complementary plugins for %{name}
57 Group:          Productivity/Multimedia/Other
58 Requires:       %{name} = %{version}
59 Enhances:       gst-plugins-good
60
61 %description extra
62 This package provides complementary plugins for %{name} and
63 plugins not included in official Tizen images, which may be used for development / experimental purposes.
64
65 %prep
66 %setup -q -n gst-plugins-good-%{version}
67 %setup -q -T -D -a 100
68
69 %build
70 # FIXME:
71 # warning: failed to load external entity "xml/element-v4l2src-details.xml"
72 # warning: failed to load external entity "xml/plugin-video4linux2.xml"
73 export V=1
74 NOCONFIGURE=1 ./autogen.sh
75 export CFLAGS+=" \
76         -DTIZEN_FEATURE_V4L2SRC_AUTO_SCAN_DEVICE_NODE\
77         -DTIZEN_FEATURE_V4L2SRC_SUPPORT_CAMERA_ID\
78         -DTIZEN_FEATURE_V4L2VIDEO_ADJ_RANK\
79         -DTIZEN_FEATURE_WAVPARSE_MODIFICATION\
80         -DTIZEN_FEATURE_MP3PARSE_MODIFICATION\
81         -DTIZEN_FEATURE_AACPARSE_MODIFICATION\
82         -DTIZEN_FEATURE_QTDEMUX_MODIFICATION\
83         -DTIZEN_FEATURE_FLVDEMUX_MODIFICATION\
84         -DTIZEN_FEATURE_GST_UPSTREAM_AVOID_BUILD_BREAK\
85         -DTIZEN_FEATURE_RTSP_MODIFICATION\
86         -DTIZEN_FEATURE_GST_MUX_ENHANCEMENT\
87         -DTIZEN_FEATURE_SOUP_MODIFICATION\
88         -DTIZEN_FEATURE_RGVOLUME_MODIFICATION\
89         -DTIZEN_FEATURE_DISABLE_V4L2_DEPENDENCY\
90         -DTIZEN_FEATURE_AVIDEMUX_MODIFICATION\
91         -DTIZEN_FEATURE_USE_LIBV4L2\
92         -DTIZEN_FEATURE_V4L2_ADDITIONAL_CID_SUPPORT\
93         -DTIZEN_FEATURE_V4L2_TBM_SUPPORT\
94         -D__TIZEN__\
95         -fstack-protector-strong\
96         -Wl,-z,relro\
97         -D_FORTIFY_SOURCE=2"
98 %configure\
99 %if ! 0%{?ENABLE_AALIB}
100         --disable-aalib\
101 %endif
102 %if "%{tizen_profile_name}" != "tv"
103         --with-libv4l2 \
104 %endif
105         --enable-v4l2-probe\
106         --disable-gtk-doc\
107         --with-gtk=3.0\
108         --disable-monoscope\
109         --disable-y4m\
110         --disable-taglib\
111         --disable-wavpack\
112         --enable-experimental\
113         --disable-equalizer\
114 %if "%{tizen_profile_name}" == "tv"
115         --disable-flv\
116         --disable-videobox\
117         --disable-videomixer\
118 %endif
119         --disable-alpha\
120         --disable-auparse\
121         --disable-flx\
122         --disable-goom\
123         --disable-goom2k1\
124         --disable-level\
125         --disable-multipart\
126         --disable-spectrum\
127         --disable-cutter\
128         --disable-dtmf\
129         --disable-oss4\
130         --disable-oss\
131         --disable-shapewipe
132
133 make %{?_smp_mflags} CFLAGS+="-Wno-error" CXXFLAGS+="-Wno-error"
134
135 %install
136 %make_install
137 %find_lang %{name}-%{gst_branch}
138
139 %lang_package -f %{name}-%{gst_branch}
140
141 %files
142 %manifest %{name}.manifest
143 %defattr(-, root, root)
144 %license COPYING
145 %{_libdir}/gstreamer-%{gst_branch}/libgstalaw.so
146 #%{_libdir}/gstreamer-%{gst_branch}/libgstalpha.so
147 #%{_libdir}/gstreamer-%{gst_branch}/libgstalphacolor.so
148 %{_libdir}/gstreamer-%{gst_branch}/libgstapetag.so
149 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiofx.so
150 %{_libdir}/gstreamer-%{gst_branch}/libgstaudioparsers.so
151 #%{_libdir}/gstreamer-%{gst_branch}/libgstauparse.so
152 %{_libdir}/gstreamer-%{gst_branch}/libgstautodetect.so
153 %{_libdir}/gstreamer-%{gst_branch}/libgstavi.so
154 # Not yet ported
155 #%{_libdir}/gstreamer-%{gst_branch}/libgstcutter.so
156 %{_libdir}/gstreamer-%{gst_branch}/libgstdebug.so
157 # Not yet ported
158 %{_libdir}/gstreamer-%{gst_branch}/libgstdeinterlace.so
159 %{_libdir}/gstreamer-%{gst_branch}/libgsteffectv.so
160
161 #%{_datadir}/gstreamer-%{gst_branch}/presets/GstVP8Enc.prs
162
163 #%{_libdir}/gstreamer-%{gst_branch}/libgstflxdec.so
164 #%{_libdir}/gstreamer-%{gst_branch}/libgstgoom.so
165 #%{_libdir}/gstreamer-%{gst_branch}/libgstgoom2k1.so
166 %{_libdir}/gstreamer-%{gst_branch}/libgsticydemux.so
167 %{_libdir}/gstreamer-%{gst_branch}/libgstid3demux.so
168 %{_libdir}/gstreamer-%{gst_branch}/libgstinterleave.so
169 %{_libdir}/gstreamer-%{gst_branch}/libgstisomp4.so
170 %{_libdir}/gstreamer-%{gst_branch}/libgstjpeg.so
171 #%{_libdir}/gstreamer-%{gst_branch}/libgstlevel.so
172 %{_libdir}/gstreamer-%{gst_branch}/libgstmatroska.so
173 #%{_libdir}/gstreamer-%{gst_branch}/libgstmonoscope.so
174 %{_libdir}/gstreamer-%{gst_branch}/libgstmulaw.so
175 %{_libdir}/gstreamer-%{gst_branch}/libgstmultifile.so
176 #%{_libdir}/gstreamer-%{gst_branch}/libgstmultipart.so
177 %{_libdir}/gstreamer-%{gst_branch}/libgstnavigationtest.so
178 #%{_libdir}/gstreamer-%{gst_branch}/libgstoss4audio.so
179 #%{_libdir}/gstreamer-%{gst_branch}/libgstossaudio.so
180 %{_libdir}/gstreamer-%{gst_branch}/libgstpulseaudio.so
181 %{_libdir}/gstreamer-%{gst_branch}/libgstreplaygain.so
182 %{_libdir}/gstreamer-%{gst_branch}/libgstrtp.so
183 %{_libdir}/gstreamer-%{gst_branch}/libgstrtpmanager.so
184 %{_libdir}/gstreamer-%{gst_branch}/libgstrtsp.so
185 #%{_libdir}/gstreamer-%{gst_branch}/libgstshapewipe.so
186 %{_libdir}/gstreamer-%{gst_branch}/libgstsmpte.so
187 #%{_libdir}/gstreamer-%{gst_branch}/libgstspectrum.so
188 #%{_libdir}/gstreamer-%{gst_branch}/libgstspeex.so
189 %{_libdir}/gstreamer-%{gst_branch}/libgstudp.so
190 %{_libdir}/gstreamer-%{gst_branch}/libgstvideo4linux2.so
191
192 %{_libdir}/gstreamer-%{gst_branch}/libgstvideocrop.so
193 %{_libdir}/gstreamer-%{gst_branch}/libgstvideofilter.so
194 %if "%{tizen_profile_name}" != "tv"
195 %{_libdir}/gstreamer-%{gst_branch}/libgstflv.so
196 #%{_libdir}/gstreamer-%{gst_branch}/libgstequalizer.so
197 #%{_datadir}/gstreamer-%{gst_branch}/presets/GstIirEqualizer10Bands.prs
198 #%{_datadir}/gstreamer-%{gst_branch}/presets/GstIirEqualizer3Bands.prs
199 %{_datadir}/gstreamer-%{gst_branch}/presets/GstQTMux.prs
200 %{_libdir}/gstreamer-%{gst_branch}/libgstvideobox.so
201 %{_libdir}/gstreamer-%{gst_branch}/libgstvideomixer.so
202 %endif
203 %{_libdir}/gstreamer-%{gst_branch}/libgstwavenc.so
204 %{_libdir}/gstreamer-%{gst_branch}/libgstwavparse.so
205 %if %{with x}
206 %{_libdir}/gstreamer-%{gst_branch}/libgstximagesrc.so
207 %endif
208 #%{_libdir}/gstreamer-%{gst_branch}/libgsty4menc.so
209 #%{_libdir}/gstreamer-%{gst_branch}/libgstcairo.so
210 %{_libdir}/gstreamer-%{gst_branch}/libgstsoup.so
211 #%{_libdir}/gstreamer-%{gst_branch}/libgstflac.so
212 %{_libdir}/gstreamer-%{gst_branch}/libgstvpx.so
213 %{_datadir}/gstreamer-%{gst_branch}/presets/GstVP8Enc.prs
214 #%{_libdir}/gstreamer-%{gst_branch}/libgstdtmf.so
215 %{_libdir}/gstreamer-%{gst_branch}/libgstimagefreeze.so
216
217
218 %files extra
219 %manifest %{name}.manifest
220 %defattr(-, root, root)
221 %if 0%{?ENABLE_AALIB}
222 %{_libdir}/gstreamer-%{gst_branch}/libgstaasink.so
223 %endif
224 %{_libdir}/gstreamer-%{gst_branch}/libgstpng.so
225 %{_libdir}/gstreamer-%{gst_branch}/libgstimagefreeze.so