3bd4bcce8d100969f0188d8216368504b4e7c4ab
[platform/upstream/gst-plugins-good.git] / packaging / gst-plugins-good.spec
1 %bcond_with x
2 %define gst_branch 1.0
3
4 Name:           gst-plugins-good
5 Version:        1.16.2
6 Release:        32
7 License:        LGPL-2.1+
8 Summary:        GStreamer Streaming-Media Framework Plug-Ins
9 Url:            http://gstreamer.freedesktop.org/
10 Group:          Multimedia/Framework
11 Source:         http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-%{version}.tar.xz
12 Source100:      common.tar.gz
13 BuildRequires:  gcc-c++
14 BuildRequires:  gettext-tools
15 BuildRequires:  pkgconfig(glib-2.0) >= 2.32
16 BuildRequires:  pkgconfig(gstreamer-1.0)
17 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  orc >= 0.4.16
20 BuildRequires:  python
21 BuildRequires:  xsltproc
22 BuildRequires:  pkgconfig(bzip2)
23 BuildRequires:  pkgconfig(libpng) >= 1.2
24 BuildRequires:  pkgconfig(libpulse) >= 1.0
25 BuildRequires:  pkgconfig(libsoup-2.4)
26 BuildRequires:  pkgconfig(libxml-2.0) >= 2.4.9
27 # TODO find where process.h comes from, not kernel-devel and not wxWidgets so far.
28 %if %{with x}
29 BuildRequires:  pkgconfig(ice)
30 BuildRequires:  pkgconfig(sm)
31 BuildRequires:  pkgconfig(xdamage)
32 BuildRequires:  pkgconfig(xfixes)
33 # used by libgstvideo4linux2.so
34 BuildRequires:  pkgconfig(xv)
35 %endif
36
37 BuildRequires:  pkgconfig(vpx)
38 BuildRequires:  pkgconfig(zlib)
39 %if "%{tizen_profile_name}" != "tv"
40 BuildRequires:  pkgconfig(libv4l2)
41 %endif
42 BuildRequires:  pkgconfig(vconf)
43 BuildRequires:  pkgconfig(gio-2.0)
44 BuildRequires:  pkgconfig(libtbm)
45 BuildRequires:  pkgconfig(cairo)
46 BuildRequires:  pkgconfig(cairo-gobject)
47 Requires:       gst-plugins-base >= 1.0.0
48 Requires:       gstreamer >= 1.0.5
49
50 %description
51 GStreamer is a streaming media framework based on graphs of filters
52 that operate on media data. Applications using this library can do
53 anything media-related, from real-time sound processing to playing
54 videos. Its plug-in-based architecture means that new data types or
55 processing capabilities can be added simply by installing new plug-ins.
56
57 %package extra
58 Summary:        Complementary plugins for %{name}
59 Group:          Productivity/Multimedia/Other
60 Requires:       %{name} = %{version}
61 Enhances:       gst-plugins-good
62
63 %description extra
64 This package provides complementary plugins for %{name} and
65 plugins not included in official Tizen images, which may be used for development / experimental purposes.
66
67 %prep
68 %setup -q -n gst-plugins-good-%{version}
69 %setup -q -T -D -a 100
70
71 %build
72 # FIXME:
73 # warning: failed to load external entity "xml/element-v4l2src-details.xml"
74 # warning: failed to load external entity "xml/plugin-video4linux2.xml"
75 export V=1
76 NOCONFIGURE=1 ./autogen.sh
77 export CFLAGS+=" \
78         -DTIZEN_FEATURE_V4L2SRC_AUTO_SCAN_DEVICE_NODE\
79         -DTIZEN_FEATURE_V4L2SRC_SUPPORT_CAMERA_ID\
80         -DTIZEN_FEATURE_V4L2VIDEO_ADJ_RANK\
81         -DTIZEN_FEATURE_WAVPARSE_MODIFICATION\
82         -DTIZEN_FEATURE_MP3PARSE_MODIFICATION\
83         -DTIZEN_FEATURE_AACPARSE_MODIFICATION\
84         -DTIZEN_FEATURE_QTDEMUX_MODIFICATION\
85         -DTIZEN_FEATURE_QTDEMUX_DURATION\
86         -DTIZEN_FEATURE_FLVDEMUX_MODIFICATION\
87         -DTIZEN_FEATURE_GST_UPSTREAM_AVOID_BUILD_BREAK\
88         -DTIZEN_FEATURE_RTSP_MODIFICATION\
89         -DTIZEN_FEATURE_GST_MUX_ENHANCEMENT\
90         -DTIZEN_FEATURE_SOUP_MODIFICATION\
91         -DTIZEN_FEATURE_RGVOLUME_MODIFICATION\
92         -DTIZEN_FEATURE_DISABLE_V4L2_DEPENDENCY\
93         -DTIZEN_FEATURE_AVIDEMUX_MODIFICATION\
94         -DTIZEN_FEATURE_USE_LIBV4L2\
95         -DTIZEN_FEATURE_V4L2_ADDITIONAL_CID_SUPPORT\
96         -DTIZEN_FEATURE_V4L2_TBM_SUPPORT\
97         -D__TIZEN__\
98         -fstack-protector-strong\
99         -Wl,-z,relro\
100         -D_FORTIFY_SOURCE=2"
101 %configure\
102 %if ! 0%{?ENABLE_AALIB}
103         --disable-aalib\
104 %endif
105 %if "%{tizen_profile_name}" != "tv"
106         --with-libv4l2 \
107 %endif
108         --enable-v4l2-probe\
109         --disable-gtk-doc\
110         --with-gtk=3.0\
111         --disable-monoscope\
112         --disable-y4m\
113         --disable-taglib\
114         --disable-wavpack\
115         --enable-experimental\
116         --disable-equalizer\
117 %if "%{tizen_profile_name}" == "tv"
118         --disable-flv\
119         --disable-videobox\
120         --disable-videomixer\
121 %endif
122         --disable-alpha\
123         --disable-auparse\
124         --disable-flx\
125         --disable-goom\
126         --disable-goom2k1\
127         --disable-level\
128         --disable-multipart\
129         --disable-spectrum\
130         --disable-cutter\
131         --disable-dtmf\
132         --disable-oss4\
133         --disable-oss\
134         --disable-shapewipe
135
136 make %{?_smp_mflags} CFLAGS+="-Wno-error" CXXFLAGS+="-Wno-error"
137
138 %install
139 %make_install
140 %find_lang %{name}-%{gst_branch}
141
142 %lang_package -f %{name}-%{gst_branch}
143
144 %files
145 %manifest %{name}.manifest
146 %defattr(-, root, root)
147 %license COPYING
148 %{_libdir}/gstreamer-%{gst_branch}/libgstalaw.so
149 #%{_libdir}/gstreamer-%{gst_branch}/libgstalpha.so
150 #%{_libdir}/gstreamer-%{gst_branch}/libgstalphacolor.so
151 %{_libdir}/gstreamer-%{gst_branch}/libgstapetag.so
152 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiofx.so
153 %{_libdir}/gstreamer-%{gst_branch}/libgstaudioparsers.so
154 #%{_libdir}/gstreamer-%{gst_branch}/libgstauparse.so
155 %{_libdir}/gstreamer-%{gst_branch}/libgstautodetect.so
156 %{_libdir}/gstreamer-%{gst_branch}/libgstavi.so
157 # Not yet ported
158 #%{_libdir}/gstreamer-%{gst_branch}/libgstcutter.so
159 %{_libdir}/gstreamer-%{gst_branch}/libgstdebug.so
160 # Not yet ported
161 %{_libdir}/gstreamer-%{gst_branch}/libgstdeinterlace.so
162 %{_libdir}/gstreamer-%{gst_branch}/libgsteffectv.so
163
164 #%{_datadir}/gstreamer-%{gst_branch}/presets/GstVP8Enc.prs
165
166 #%{_libdir}/gstreamer-%{gst_branch}/libgstflxdec.so
167 #%{_libdir}/gstreamer-%{gst_branch}/libgstgoom.so
168 #%{_libdir}/gstreamer-%{gst_branch}/libgstgoom2k1.so
169 %{_libdir}/gstreamer-%{gst_branch}/libgsticydemux.so
170 %{_libdir}/gstreamer-%{gst_branch}/libgstid3demux.so
171 %{_libdir}/gstreamer-%{gst_branch}/libgstinterleave.so
172 %{_libdir}/gstreamer-%{gst_branch}/libgstisomp4.so
173 %{_libdir}/gstreamer-%{gst_branch}/libgstjpeg.so
174 #%{_libdir}/gstreamer-%{gst_branch}/libgstlevel.so
175 %{_libdir}/gstreamer-%{gst_branch}/libgstmatroska.so
176 #%{_libdir}/gstreamer-%{gst_branch}/libgstmonoscope.so
177 %{_libdir}/gstreamer-%{gst_branch}/libgstmulaw.so
178 %{_libdir}/gstreamer-%{gst_branch}/libgstmultifile.so
179 #%{_libdir}/gstreamer-%{gst_branch}/libgstmultipart.so
180 %{_libdir}/gstreamer-%{gst_branch}/libgstnavigationtest.so
181 #%{_libdir}/gstreamer-%{gst_branch}/libgstoss4audio.so
182 #%{_libdir}/gstreamer-%{gst_branch}/libgstossaudio.so
183 %{_libdir}/gstreamer-%{gst_branch}/libgstpulseaudio.so
184 %{_libdir}/gstreamer-%{gst_branch}/libgstreplaygain.so
185 %{_libdir}/gstreamer-%{gst_branch}/libgstrtp.so
186 %{_libdir}/gstreamer-%{gst_branch}/libgstrtpmanager.so
187 %{_libdir}/gstreamer-%{gst_branch}/libgstrtsp.so
188 #%{_libdir}/gstreamer-%{gst_branch}/libgstshapewipe.so
189 %{_libdir}/gstreamer-%{gst_branch}/libgstsmpte.so
190 #%{_libdir}/gstreamer-%{gst_branch}/libgstspectrum.so
191 #%{_libdir}/gstreamer-%{gst_branch}/libgstspeex.so
192 %{_libdir}/gstreamer-%{gst_branch}/libgstudp.so
193 %{_libdir}/gstreamer-%{gst_branch}/libgstvideo4linux2.so
194
195 %{_libdir}/gstreamer-%{gst_branch}/libgstvideocrop.so
196 %{_libdir}/gstreamer-%{gst_branch}/libgstvideofilter.so
197 %if "%{tizen_profile_name}" != "tv"
198 %{_libdir}/gstreamer-%{gst_branch}/libgstflv.so
199 #%{_libdir}/gstreamer-%{gst_branch}/libgstequalizer.so
200 #%{_datadir}/gstreamer-%{gst_branch}/presets/GstIirEqualizer10Bands.prs
201 #%{_datadir}/gstreamer-%{gst_branch}/presets/GstIirEqualizer3Bands.prs
202 %{_datadir}/gstreamer-%{gst_branch}/presets/GstQTMux.prs
203 %{_libdir}/gstreamer-%{gst_branch}/libgstvideobox.so
204 %{_libdir}/gstreamer-%{gst_branch}/libgstvideomixer.so
205 %endif
206 %{_libdir}/gstreamer-%{gst_branch}/libgstwavenc.so
207 %{_libdir}/gstreamer-%{gst_branch}/libgstwavparse.so
208 %if %{with x}
209 %{_libdir}/gstreamer-%{gst_branch}/libgstximagesrc.so
210 %endif
211 #%{_libdir}/gstreamer-%{gst_branch}/libgsty4menc.so
212 %{_libdir}/gstreamer-%{gst_branch}/libgstcairo.so
213 %{_libdir}/gstreamer-%{gst_branch}/libgstsoup.so
214 #%{_libdir}/gstreamer-%{gst_branch}/libgstflac.so
215 %{_libdir}/gstreamer-%{gst_branch}/libgstvpx.so
216 %{_datadir}/gstreamer-%{gst_branch}/presets/GstVP8Enc.prs
217 #%{_libdir}/gstreamer-%{gst_branch}/libgstdtmf.so
218 %{_libdir}/gstreamer-%{gst_branch}/libgstimagefreeze.so
219
220
221 %files extra
222 %manifest %{name}.manifest
223 %defattr(-, root, root)
224 %if 0%{?ENABLE_AALIB}
225 %{_libdir}/gstreamer-%{gst_branch}/libgstaasink.so
226 %endif
227 %{_libdir}/gstreamer-%{gst_branch}/libgstpng.so
228 %{_libdir}/gstreamer-%{gst_branch}/libgstimagefreeze.so