Update to gnutls 3.0.30 from 3.0.21 to address CVE-2013-1619.
[platform/upstream/gnutls.git] / packaging / gnutls.spec
1 %define gnutls_sover 28
2 %define gnutlsxx_sover 28
3 %define gnutls_ossl_sover 27
4
5 Name:           gnutls
6 Version:        3.0.30
7 Release:        0
8 Summary:        The GNU Transport Layer Security Library
9 License:        LGPL-3.0+ and GPL-3.0+
10 Group:          Security/Crypto Libraries
11 Url:            http://www.gnutls.org/
12 Source0:        http://ftp.gnu.org/gnu/gnutls/%{name}-%{version}.tar.xz
13 Source1:        baselibs.conf
14 Source1001:     gnutls.manifest
15 BuildRequires:  automake
16 BuildRequires:  gcc-c++
17 BuildRequires:  libidn-devel
18 BuildRequires:  pkgconfig(nettle) 
19 BuildRequires:  libtasn1-devel
20 BuildRequires:  gettext-tools
21 BuildRequires:  libtool
22 BuildRequires:  p11-kit-devel >= 0.11
23 BuildRequires:  pkg-config
24 BuildRequires:  xz
25 BuildRequires:  zlib-devel
26
27 %description
28 The GnuTLS project aims to develop a library that provides a secure
29 layer over a reliable transport layer. Currently the GnuTLS library
30 implements the proposed standards of the IETF's TLS working group.
31
32 %package -n libgnutls
33 Summary:        The GNU Transport Layer Security Library
34 License:        LGPL-3.0+
35 Group:          Security/Crypto Libraries
36
37 %description -n libgnutls
38 The GnuTLS project aims to develop a library that provides a secure
39 layer over a reliable transport layer. Currently the GnuTLS library
40 implements the proposed standards of the IETF's TLS working group.
41
42 %package -n libgnutlsxx
43 Summary:        The GNU Transport Layer Security Library
44 License:        LGPL-3.0+
45 Group:          Security/Crypto Libraries
46
47 %description -n libgnutlsxx
48 The GnuTLS project aims to develop a library that provides a secure
49 layer over a reliable transport layer. Currently the GnuTLS library
50 implements the proposed standards of the IETF's TLS working group.
51
52
53 %package -n libgnutls-openssl
54 Summary:        The GNU Transport Layer Security Library
55 License:        GPL-3.0+
56 Group:          Security/Crypto Libraries
57
58 %description -n libgnutls-openssl
59 The GnuTLS project aims to develop a library that provides a secure
60 layer over a reliable transport layer. Currently the GnuTLS library
61 implements the proposed standards of the IETF's TLS working group.
62
63
64 %package -n libgnutls-devel
65 Summary:        Development package for gnutls
66 License:        LGPL-3.0+
67 Group:          Development/Libraries
68 Requires:       glibc-devel
69 Requires:       libgnutls = %{version}
70 Provides:       gnutls-devel = %{version}-%{release}
71
72 %description -n libgnutls-devel
73 Files needed for software development using gnutls.
74
75 %package -n libgnutlsxx-devel
76 Summary:        Development package for gnutls
77 License:        LGPL-3.0+
78 Group:          Development/Libraries
79 Requires:       libgnutls-devel = %{version}
80 Requires:       libgnutlsxx = %{version}
81 Requires:       libstdc++-devel
82
83 %description -n libgnutlsxx-devel
84 Files needed for software development using gnutls.
85
86
87 %package -n libgnutls-openssl-devel
88 Summary:        Development package for gnutls
89 License:        GPL-3.0+
90 Group:          Development/Libraries
91 Requires:       libgnutls-devel = %{version}
92 Requires:       libgnutls-openssl = %{version}
93
94 %description -n libgnutls-openssl-devel
95 Files needed for software development using gnutls.
96
97
98 %prep
99 %setup -q
100 cp %{SOURCE1001} .
101 echo %{_includedir}/%{name}/abstract.h
102
103 %build
104 autoreconf -if
105 %configure \
106         --disable-static \
107         --with-pic \
108         --disable-rpath \
109         --disable-silent-rules \
110         --with-default-trust-store-dir=/etc/ssl/certs \
111         --with-sysroot=/%{?_sysroot}
112 make %{?_smp_mflags}
113
114 # 17-ago-2011, Test suite passes in factory, just not
115 #in the build system due to some broken code requiring both networking
116 #and fixes.
117 #make check
118
119 %install
120 %make_install
121 rm -rf doc/examples/.deps doc/examples/.libs doc/examples/*.{o,lo,la} doc/examples/Makefile{,.in}
122 find doc/examples -perm -111 -exec rm {} \;
123 rm -rf %{buildroot}%{_datadir}/locale/en@{,bold}quot
124 # Do not package static libs and libtool files
125 rm -f %{buildroot}%{_libdir}/*.la
126 %find_lang libgnutls --all-name
127
128 %post -n libgnutls -p /sbin/ldconfig
129
130 %postun -n libgnutls -p /sbin/ldconfig
131
132 %post -n libgnutlsxx -p /sbin/ldconfig
133
134 %postun -n libgnutlsxx -p /sbin/ldconfig
135
136 %post -n libgnutls-openssl -p /sbin/ldconfig
137
138 %postun -n libgnutls-openssl -p /sbin/ldconfig
139
140 %files -f libgnutls.lang
141 %manifest %{name}.manifest
142 %defattr(-, root, root)
143 %license COPYING
144 %{_bindir}/certtool
145 %{_bindir}/crywrap
146 %{_bindir}/gnutls-cli
147 %{_bindir}/gnutls-cli-debug
148 %{_bindir}/gnutls-serv
149 %{_bindir}/ocsptool
150 %{_bindir}/psktool
151 %{_bindir}/p11tool
152 %{_bindir}/srptool
153 %{_mandir}/man1/*
154
155 %files -n libgnutls
156 %manifest %{name}.manifest
157 %defattr(-,root,root)
158 %{_libdir}/libgnutls.so.*
159
160 %files -n libgnutls-openssl
161 %manifest %{name}.manifest
162 %defattr(-,root,root)
163 %{_libdir}/libgnutls-openssl.so.*
164
165 %files -n libgnutlsxx
166 %manifest %{name}.manifest
167 %defattr(-,root,root)
168 %{_libdir}/libgnutlsxx.so.*
169
170 %files -n libgnutls-devel
171 %manifest %{name}.manifest
172 %defattr(-, root, root)
173 %dir %{_includedir}/%{name}
174 %{_includedir}/%{name}/abstract.h
175 %{_includedir}/%{name}/crypto.h
176 %{_includedir}/%{name}/compat.h
177 %{_includedir}/%{name}/dtls.h
178 %{_includedir}/%{name}/gnutls.h
179 %{_includedir}/%{name}/openpgp.h
180 %{_includedir}/%{name}/ocsp.h
181 %{_includedir}/%{name}/pkcs11.h
182 %{_includedir}/%{name}/pkcs12.h
183 %{_includedir}/%{name}/x509.h
184 %{_libdir}/libgnutls.so
185 %{_libdir}/pkgconfig/gnutls.pc
186 %{_mandir}/man3/*
187 %{_infodir}/*.*
188 %doc doc/examples doc/gnutls.html doc/*.png doc/gnutls.pdf doc/reference/html/*
189
190 %files -n libgnutlsxx-devel
191 %manifest %{name}.manifest
192 %defattr(-, root, root)
193 %{_libdir}/libgnutlsxx.so
194 %dir %{_includedir}/%{name}
195 %{_includedir}/%{name}/gnutlsxx.h
196
197 %files -n libgnutls-openssl-devel
198 %manifest %{name}.manifest
199 %defattr(-, root, root)
200 %{_libdir}/libgnutls-openssl.so
201 %dir %{_includedir}/%{name}
202 %{_includedir}/%{name}/openssl.h
203
204 %changelog