Fixed package group
[platform/upstream/gnutls.git] / packaging / gnutls.spec
1 %define gnutls_sover 28
2 %define gnutlsxx_sover 28
3 %define gnutls_ossl_sover 27
4
5 Name:           gnutls
6 Version:        3.0.21
7 Release:        0
8 Summary:        The GNU Transport Layer Security Library
9 License:        LGPL-3.0+ and GPL-3.0+
10 Group:          Security/Crypto Libraries
11 Url:            http://www.gnutls.org/
12 Source0:        http://ftp.gnu.org/gnu/gnutls/%{name}-%{version}.tar.xz
13 Source1:        baselibs.conf
14 BuildRequires:  automake
15 BuildRequires:  gcc-c++
16 BuildRequires:  libidn-devel
17 BuildRequires:  pkgconfig(nettle) 
18 BuildRequires:  libtasn1-devel
19 BuildRequires:  gettext-tools
20 BuildRequires:  libtool
21 BuildRequires:  p11-kit-devel >= 0.11
22 BuildRequires:  pkg-config
23 BuildRequires:  xz
24 BuildRequires:  zlib-devel
25
26 %description
27 The GnuTLS project aims to develop a library that provides a secure
28 layer over a reliable transport layer. Currently the GnuTLS library
29 implements the proposed standards of the IETF's TLS working group.
30
31 %package -n libgnutls
32 Summary:        The GNU Transport Layer Security Library
33 License:        LGPL-3.0+
34 Group:          Security/Crypto Libraries
35
36 %description -n libgnutls
37 The GnuTLS project aims to develop a library that provides a secure
38 layer over a reliable transport layer. Currently the GnuTLS library
39 implements the proposed standards of the IETF's TLS working group.
40
41 %package -n libgnutlsxx
42 Summary:        The GNU Transport Layer Security Library
43 License:        LGPL-3.0+
44 Group:          Security/Crypto Libraries
45
46 %description -n libgnutlsxx
47 The GnuTLS project aims to develop a library that provides a secure
48 layer over a reliable transport layer. Currently the GnuTLS library
49 implements the proposed standards of the IETF's TLS working group.
50
51
52 %package -n libgnutls-openssl
53 Summary:        The GNU Transport Layer Security Library
54 License:        GPL-3.0+
55 Group:          Security/Crypto Libraries
56
57 %description -n libgnutls-openssl
58 The GnuTLS project aims to develop a library that provides a secure
59 layer over a reliable transport layer. Currently the GnuTLS library
60 implements the proposed standards of the IETF's TLS working group.
61
62
63 %package -n libgnutls-devel
64 Summary:        Development package for gnutls
65 License:        LGPL-3.0+
66 Group:          Development/Libraries
67 Requires:       glibc-devel
68 Requires:       libgnutls = %{version}
69 Provides:       gnutls-devel = %{version}-%{release}
70
71 %description -n libgnutls-devel
72 Files needed for software development using gnutls.
73
74 %package -n libgnutlsxx-devel
75 Summary:        Development package for gnutls
76 License:        LGPL-3.0+
77 Group:          Development/Libraries
78 Requires:       libgnutls-devel = %{version}
79 Requires:       libgnutlsxx = %{version}
80 Requires:       libstdc++-devel
81
82 %description -n libgnutlsxx-devel
83 Files needed for software development using gnutls.
84
85
86 %package -n libgnutls-openssl-devel
87 Summary:        Development package for gnutls
88 License:        GPL-3.0+
89 Group:          Development/Libraries
90 Requires:       libgnutls-devel = %{version}
91 Requires:       libgnutls-openssl = %{version}
92
93 %description -n libgnutls-openssl-devel
94 Files needed for software development using gnutls.
95
96
97 %prep
98 %setup -q
99 echo %{_includedir}/%{name}/abstract.h
100
101 %build
102 autoreconf -if
103 %configure \
104         --disable-static \
105         --with-pic \
106         --disable-rpath \
107         --disable-silent-rules \
108         --with-default-trust-store-dir=/etc/ssl/certs \
109         --with-sysroot=/%{?_sysroot}
110 make %{?_smp_mflags}
111
112 # 17-ago-2011, Test suite passes in factory, just not
113 #in the build system due to some broken code requiring both networking
114 #and fixes.
115 #make check
116
117 %install
118 %make_install
119 rm -rf doc/examples/.deps doc/examples/.libs doc/examples/*.{o,lo,la} doc/examples/Makefile{,.in}
120 find doc/examples -perm -111 -exec rm {} \;
121 rm -rf %{buildroot}%{_datadir}/locale/en@{,bold}quot
122 # Do not package static libs and libtool files
123 rm -f %{buildroot}%{_libdir}/*.la
124 %find_lang libgnutls --all-name
125
126 %post -n libgnutls -p /sbin/ldconfig
127
128 %postun -n libgnutls -p /sbin/ldconfig
129
130 %post -n libgnutlsxx -p /sbin/ldconfig
131
132 %postun -n libgnutlsxx -p /sbin/ldconfig
133
134 %post -n libgnutls-openssl -p /sbin/ldconfig
135
136 %postun -n libgnutls-openssl -p /sbin/ldconfig
137
138 %files -f libgnutls.lang
139 %defattr(-, root, root)
140 %license COPYING
141 %{_bindir}/certtool
142 %{_bindir}/crywrap
143 %{_bindir}/gnutls-cli
144 %{_bindir}/gnutls-cli-debug
145 %{_bindir}/gnutls-serv
146 %{_bindir}/ocsptool
147 %{_bindir}/psktool
148 %{_bindir}/p11tool
149 %{_bindir}/srptool
150 %{_mandir}/man1/*
151
152 %files -n libgnutls
153 %defattr(-,root,root)
154 %{_libdir}/libgnutls.so.*
155
156 %files -n libgnutls-openssl
157 %defattr(-,root,root)
158 %{_libdir}/libgnutls-openssl.so.*
159
160 %files -n libgnutlsxx
161 %defattr(-,root,root)
162 %{_libdir}/libgnutlsxx.so.*
163
164 %files -n libgnutls-devel
165 %defattr(-, root, root)
166 %dir %{_includedir}/%{name}
167 %{_includedir}/%{name}/abstract.h
168 %{_includedir}/%{name}/crypto.h
169 %{_includedir}/%{name}/compat.h
170 %{_includedir}/%{name}/dtls.h
171 %{_includedir}/%{name}/gnutls.h
172 %{_includedir}/%{name}/openpgp.h
173 %{_includedir}/%{name}/ocsp.h
174 %{_includedir}/%{name}/pkcs11.h
175 %{_includedir}/%{name}/pkcs12.h
176 %{_includedir}/%{name}/x509.h
177 %{_libdir}/libgnutls.so
178 %{_libdir}/pkgconfig/gnutls.pc
179 %{_mandir}/man3/*
180 %{_infodir}/*.*
181 %doc doc/examples doc/gnutls.html doc/*.png doc/gnutls.pdf doc/reference/html/*
182
183 %files -n libgnutlsxx-devel
184 %defattr(-, root, root)
185 %{_libdir}/libgnutlsxx.so
186 %dir %{_includedir}/%{name}
187 %{_includedir}/%{name}/gnutlsxx.h
188
189 %files -n libgnutls-openssl-devel
190 %defattr(-, root, root)
191 %{_libdir}/libgnutls-openssl.so
192 %dir %{_includedir}/%{name}
193 %{_includedir}/%{name}/openssl.h
194
195 %changelog