remove .la files
[platform/upstream/gmp.git] / packaging / gmp.spec
1 Name:           gmp
2 Version:        5.0.5
3 Release:        0
4 License:        GPL-3.0+ ; LGPL-3.0+
5 Summary:        The GNU MP Library
6 Url:            http://gmplib.org/
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Source2:        baselibs.conf
10 BuildRequires:  gcc-c++
11
12 %description
13 A library for calculating huge numbers (integer and floating point).
14
15 %package -n libgmp
16 Summary:        Shared library for the GNU MP Library
17 Group:          System/Libraries
18
19 %description -n libgmp
20 Shared library for the GNU MP Library.
21
22 %package -n libgmpxx
23 Summary:        C++ bindings for the GNU MP Library
24 Group:          System/Libraries
25 Requires:       libgmp = %{version}
26
27 %description -n libgmpxx
28 C++ bindings for the GNU MP Library.
29
30 %package -n libmp
31 Summary:        BSD libmp bindings for the GNU MP Library
32 Group:          System/Libraries
33 Requires:       libgmp = %{version}
34
35 %description -n libmp
36 BSD libmp bindings for the GNU MP Library.
37
38 %package devel
39 Summary:        Include Files and Libraries for Development with the GNU MP Library
40 Group:          Development/Languages/C and C++
41 Requires:       libgmp = %{version}
42 Requires:       libgmpxx = %{version}
43 Requires:       libmp = %{version}
44
45 %description devel
46 These libraries are needed to develop programs which calculate with
47 huge numbers (integer and floating point).
48
49 %prep
50 %setup -q
51
52 %build
53 export CFLAGS="%{optflags} -fexceptions";
54 ./configure --build=%{_build} --host=%{_host} \
55          --program-prefix=%{?_program_prefix} \
56          --prefix=%{_prefix} \
57          --exec-prefix=%{_exec_prefix} \
58          --bindir=%{_bindir} \
59          --sbindir=%{_sbindir} \
60          --sysconfdir=%{_sysconfdir} \
61          --datadir=%{_datadir} \
62          --includedir=%{_includedir} \
63          --libdir=%{_libdir} \
64          --libexecdir=%{_libexecdir} \
65          --localstatedir=%{_localstatedir} \
66          --sharedstatedir=%{_sharedstatedir} \
67          --mandir=%{_mandir} \
68          --infodir=%{_infodir} \
69          --enable-mpbsd --enable-cxx
70 make %{?_smp_mflags}
71
72 %check
73 # do not disable "make check", FIX THE BUGS!
74 make check
75
76 %install
77 %make_install
78
79 %post -n libgmp -p /sbin/ldconfig
80
81 %post -n libgmpxx -p /sbin/ldconfig
82
83 %post -n libmp -p /sbin/ldconfig
84
85
86 %postun -n libgmp -p /sbin/ldconfig
87
88 %postun -n libgmpxx -p /sbin/ldconfig
89
90 %postun -n libmp -p /sbin/ldconfig
91
92 %files
93 %doc AUTHORS README NEWS
94
95 %files -n libgmp
96 %defattr(-,root,root)
97 %{_libdir}/libgmp.so.10*
98
99 %files -n libgmpxx
100 %defattr(-,root,root)
101 %{_libdir}/libgmpxx.so.4*
102
103 %files -n libmp
104 %defattr(-,root,root)
105 %{_libdir}/libmp.so.3*
106
107 %files devel
108 %defattr(-,root,root)
109 %doc AUTHORS README NEWS
110 %doc demos
111 %doc %{_infodir}/gmp.info*.gz
112 %{_libdir}/libgmp.a
113 %{_libdir}/libgmp.so
114 %{_libdir}/libgmpxx.so
115 %{_libdir}/libmp.so
116 /usr/include/gmp.h
117 /usr/include/gmpxx.h
118 /usr/include/mp.h
119
120 %changelog