bump to v2.0.1
[platform/upstream/git.git] / packaging / git.spec
index a4562a4..b5e00eb 100644 (file)
@@ -1,12 +1,12 @@
 %define gitexecdir %{_libexecdir}/git
 
 Name:           git
-Version:        1.8.1.3
+Version:        2.0.1
 Release:        0
 License:        GPL-2.0
 Summary:        Fast, scalable, distributed revision control system
 Url:            http://git-scm.com
-Group:          Development/Tools
+Group:          Platform Development/Utilities
 Source:         %{name}-%{version}.tar.gz
 Source1001:    git.manifest
 BuildRequires:  asciidoc
@@ -34,7 +34,7 @@ CVS, and GNU arch.
 
 %package core
 Summary:        Core git tools
-Group:          Development/Tools
+Group:          Platform Development/Utilities
 Requires:       less
 Requires:       openssh
 Requires:       perl-Error
@@ -50,7 +50,7 @@ These are the core tools with minimal dependencies.
 
 %package svn
 Summary:        Git tools for importing Subversion repositories
-Group:          Development/Tools
+Group:          Platform Development/Utilities
 Requires:       git-core = %{version}
 Requires:       subversion
 Requires:       subversion-perl
@@ -61,7 +61,7 @@ system.
 
 %package cvs
 Summary:        Git tools for importing CVS repositories
-Group:          Development/Tools
+Group:          Platform Development/Utilities
 Requires:       cvs
 Requires:       cvsps
 Requires:       git-core = %{version}
@@ -72,7 +72,7 @@ Tools for importing CVS repositories to the Git version control system.
 
 %package arch
 Summary:        Git tools for importing Arch repositories
-Group:          Development/Tools
+Group:          Platform Development/Utilities
 Requires:       git-core = %{version}
 # Requires:       tla
 
@@ -82,7 +82,7 @@ system.
 
 %package email
 Summary:        Git tools for sending email
-Group:          Development/Tools
+Group:          Platform Development/Utilities
 Requires:       git-core = %{version}
 # For sending mails over secure SMTP:
 Recommends:     perl-Authen-SASL
@@ -93,7 +93,7 @@ Email interface for the GIT version control system.
 
 %package daemon
 Summary:        Simple Server for Git Repositories
-Group:          Development/Tools
+Group:          Platform Development/Utilities
 Requires(pre):  /usr/sbin/useradd
 Requires:       git-core = %{version}
 
@@ -103,7 +103,7 @@ read only access to repositories in /srv/git/ that contain the
 'git-daemon-export-ok' file.
 %package -n gitk
 Summary:        Git revision tree visualiser
-Group:          Development/Tools
+Group:          Platform Development/Utilities
 Requires:       git-core = %{version}
 Requires:       tk >= 8.4
 Supplements:    packageand(git-core:tk)
@@ -118,7 +118,7 @@ found in the package git-gui.
 
 %package gui
 Summary:        Grapical tool for common git operations
-Group:          Development/Tools
+Group:          Platform Development/Utilities
 Requires:       git-core = %{version}
 Requires:       tk >= 8.4
 Supplements:    packageand(git-core:tk)
@@ -135,7 +135,7 @@ menu actions to start a gitk session from within git-gui.
 
 %package web
 Summary:        Git Web Interface
-Group:          Development/Tools
+Group:          Platform Development/Utilities
 Requires:       git-core = %{version}
 Supplements:    packageand(git-core:apache2)
 
@@ -145,19 +145,12 @@ CGI script that allows browsing git repositories via web interface.
 The apache2 configuration contained in this package installs a virtual
 directory /git/ that calls the cgi script.
 
-%package remote-helpers
-Summary:        Python package for remote helper scripts
-Group:          Development/Tools
-Requires:       git-core = %{version}
-Requires:       python
-
-%description remote-helpers
-This package contains the building blocks for remote helpers written in Python.
 
 %prep
 %setup -q
 cp %{SOURCE1001} .
 
+
 %build
 cat > .make <<'EOF'
 #!/bin/bash
@@ -181,11 +174,12 @@ chmod 755 .make
 %check
 make %{?_smp_mflags} test
 
+
 %install
 ./.make install install-doc
 ###
-(find %{buildroot}%{_bindir} -type f | grep -vE "archimport|svn|cvs|email|gitk|daemon|gui" | sed -e s@^%{buildroot}@@)                   > bin-man-doc-files
-(find %{buildroot}%{gitexecdir} -mindepth 1 | grep -vE "archimport|svn|cvs|email|gitk|daemon|gui" | sed -e s@^%{buildroot}@@)               >> bin-man-doc-files
+(find %{buildroot}%{_bindir} -type f | grep -vE "archimport|svn|cvs|email|gitk|daemon|gui" | sed -e s@^%{buildroot}@@)                         > bin-man-doc-files
+(find %{buildroot}%{gitexecdir} -mindepth 1 | grep -vE "archimport|svn|cvs|email|gitk|daemon|gui" | sed -e s@^%{buildroot}@@)          >> bin-man-doc-files
 (find %{buildroot}%{_mandir} %{buildroot}/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|daemon|gui" | sed -e s@^%{buildroot}@@ -e 's/$/*/' ) >> bin-man-doc-files
 ( pushd perl
   perl Makefile.PL
@@ -194,9 +188,7 @@ make %{?_smp_mflags} test
 rm -rf %{buildroot}/usr/lib/perl5/site_perl
 %perl_process_packlist
 find %{buildroot}/%{_mandir} -type f -print0 | xargs -0 chmod 644
-find %{buildroot}/%python_sitelib/ -type f -name *.pyc -print0 | xargs -0 rm
 install -m 644 -D contrib/completion/git-completion.bash %{buildroot}%{_sysconfdir}/bash_completion.d/git.sh
-sed -i  "s#$RPM_BUILD_ROOT##g" %{buildroot}/%{gitexecdir}/git-remote-testgit
 %find_lang %{name}
 cat %{name}.lang >>bin-man-doc-files
 # use symlinks instead of hardlinks in sub-commands
@@ -206,7 +198,7 @@ rm -rf %{buildroot}/%{_datadir}/gitweb
 rm -rf %{buildroot}/Documentation/*.html
 rm -rf %{buildroot}/Documentation/*.txt
 
-%fdupes -s %{buildroot}
+%fdupes -s %{buildroot}/%{_prefix}
 
 
 %files
@@ -251,10 +243,6 @@ rm -rf %{buildroot}/Documentation/*.txt
 %{_datadir}/git-gui
 %{_mandir}/man1/*gui*.1*
 
-%files remote-helpers
-%manifest %{name}.manifest
-%python_sitelib/*
-
 %files core -f bin-man-doc-files
 %manifest %{name}.manifest
 %license COPYING
@@ -265,6 +253,4 @@ rm -rf %{buildroot}/Documentation/*.txt
 %{perl_vendorlib}/Git/
 %{perl_vendorlib}/Git/*.pm
 %{perl_vendorarch}/auto/Git/
-%attr(0644, root, root) %{_sysconfdir}/bash_completion.d/git.sh
-
-%changelog
+%attr(0644, root, root) %config %{_sysconfdir}/bash_completion.d/git.sh