resetting manifest requested domain to floor
[platform/upstream/gdbm.git] / packaging / gdbm.spec
index e5c79b7..350d6e2 100644 (file)
@@ -10,7 +10,7 @@ Summary:        GNU dbm key/data database
 Group:          System/Libraries
 Source:         ftp://prep.ai.mit.edu/gnu/gdbm/gdbm-%{version}.tar.gz
 Source2:        baselibs.conf
-# FIX-FOR-UPSTREAM i@marguerite.su - remove the build date from src/version.c
+Source1001:    gdbm.manifest
 BuildRequires:  libtool
 
 %description
@@ -34,7 +34,6 @@ package also provides traditional dbm and ndbm interfaces.
 License:        GPL-2.0+
 Summary:        GNU dbm key/data database
 Group:          System/Libraries
-# O/P added in 12.2
 Obsoletes:      gdbm < %{version}-%{release}
 Provides:       gdbm = %{version}-%{release}
 
@@ -68,12 +67,11 @@ to develop applications that require these.
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
-aclocal
-autoreconf --force --install
 export CFLAGS="%{optflags} -Wa,--noexecstack"
-%configure --enable-libgdbm-compat
+%configure --enable-libgdbm-compat --disable-nls
 make %{?_smp_mflags};
 
 %install
@@ -87,14 +85,12 @@ echo "/* GNU ld script
    the static library, so try that secondarily.  */
 GROUP ( %{_libdir}/libgdbm.a %{_libdir}/libgdbm_compat.a )" > %{buildroot}/%{_libdir}/libndbm.a
 
-mkdir -p %{buildroot}%{_datadir}/locale/zh_CN/LC_MESSAGES/
-cp -r %{SOURCE3} %{buildroot}%{_datadir}/locale/zh_CN/LC_MESSAGES/%{name}.mo
-%find_lang %{name}
-
 %post -n %lname -p /sbin/ldconfig
 
 %postun -n %lname -p /sbin/ldconfig
 
+%files -n  %lname
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %doc COPYING
 %{_libdir}/libgdbm.so.4
@@ -103,6 +99,7 @@ cp -r %{SOURCE3} %{buildroot}%{_datadir}/locale/zh_CN/LC_MESSAGES/%{name}.mo
 %{_libdir}/libgdbm_compat.so.4.0.0
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_bindir}/testgdbm
 %{_includedir}/dbm.h