Add baselibs to support multilib
[platform/upstream/gcr.git] / packaging / gcr.spec
1 %define baseline 3.7
2
3
4 Name:           gcr
5 Version:        3.7.5
6 Release:        0
7 Summary:        Library for Crypto UI related task
8 License:        LGPL-2.1+
9 Group:          Security/Crypto Libraries
10 Url:            http://www.gnome.org
11 Source0:        http://download.gnome.org/sources/gcr/%{baseline}/%{name}-%{version}.tar.xz
12 BuildRequires:  gnome-common
13 BuildRequires:  gpg2
14 BuildRequires:  gtk-doc
15 BuildRequires:  intltool
16 BuildRequires:  libgcrypt-devel >= 1.2.2
17 BuildRequires:  libtasn1-devel
18 BuildRequires:  shared-mime-info
19 BuildRequires:  update-desktop-files 
20 BuildRequires:  pkgconfig(dbus-1)
21 BuildRequires:  pkgconfig(gio-2.0)
22 BuildRequires:  pkgconfig(gio-unix-2.0)
23 BuildRequires:  pkgconfig(glib-2.0) >= 2.30.0
24 BuildRequires:  pkgconfig(gmodule-no-export-2.0)
25 BuildRequires:  pkgconfig(gobject-2.0)
26 BuildRequires:  pkgconfig(gobject-introspection-1.0)
27 BuildRequires:  pkgconfig(gthread-2.0)
28 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.0
29 BuildRequires:  pkgconfig(libtasn1)
30 BuildRequires:  pkgconfig(p11-kit-1) >= 0.6
31
32 %description
33 GCR is a library for displaying certificates, and crypto UI, accessing
34 key stores. It also provides the viewer for crypto files on the GNOME
35 desktop.
36
37 GCK is a library for accessing PKCS#11 modules like smart cards, in a
38 (G)object oriented way.
39
40
41 %package viewer
42 Summary:        Viewer for Crypto Files
43 Group:          Security/Certificate Management
44
45 %description viewer
46 This packages provides the viewer for crypto files on the GNOME desktop.
47
48
49 %package data
50 Summary:        Data and icon set for gcr
51 Group:          Security/Crypto Libraries
52 Requires(post): glib2-tools
53 Requires(postun): glib2-tools
54
55 %description data
56 This package provides the GSettings schemas and a collection of icons
57 needed by libgcr.
58
59
60 %package prompter
61 Summary:        Prompt dialog for Crypto UI related task
62 Group:          System/Libraries
63
64 %description prompter
65 This package provides the prompt dialog needed by libgcr.
66
67
68 %package -n libgcr
69 Summary:        Library for Crypto UI related task
70 Group:          System/Libraries
71 Requires:       %{name}-data >= %{version}
72 Requires:       %{name}-prompter >= %{version}
73
74 %description -n libgcr
75 GCR is a library for displaying certificates, and crypto UI, accessing
76 key stores.
77
78
79 %package -n typelib-Gcr
80 Summary:        Library for Crypto UI related task -- Introspection bindings
81 Group:          System/Libraries
82
83 %description -n typelib-Gcr
84 GCR is a library for displaying certificates, and crypto UI, accessing
85 key stores.
86
87 This package provides the GObject Introspection bindings for GCR.
88
89
90 %package -n libgcr-devel
91 Summary:        Library for Crypto UI related task - Development Files
92 Group:          Development/Libraries
93 Requires:       libgcr = %{version}
94 Requires:       typelib-Gcr = %{version}
95
96 %description -n libgcr-devel
97 GCR is a library for displaying certificates, and crypto UI, accessing
98 key stores.
99
100
101 %package -n libgcr-ui
102 Summary:        Library for Crypto UI related task
103 Group:          System/Libraries
104 Requires:       %{name}-data >= %{version}
105 Requires:       %{name}-prompter >= %{version}
106
107 %description -n libgcr-ui
108 GCR is a library for displaying certificates, and crypto UI, accessing
109 key stores.ey stores.
110
111
112 %package -n typelib-GcrUi
113 Summary:        Library for Crypto UI related task -- Introspection bindings
114 Group:          System/Libraries
115
116 %description -n typelib-GcrUi
117 GCR is a library for displaying certificates, and crypto UI, accessing
118 key stores.
119
120 This package provides the GObject Introspection bindings for GCR.
121
122
123 %package -n libgcr-ui-devel
124 Summary:        Library for Crypto UI related task - Development Files
125 Group:          Development/Libraries
126 Requires:       libgcr-ui = %{version}
127 Requires:       libgcr-devel = %{version}
128 Requires:       typelib-Gcr = %{version}
129
130 %description -n libgcr-ui-devel
131 GCR is a library for displaying certificates, and crypto UI, accessing
132 key stores.
133
134
135 %package -n libgck
136 Summary:        GObject library to access for PKCS#11 modules
137 Group:          System/Libraries
138 Provides:       gck = %{version}
139
140 %description -n libgck
141 GCK is a library for accessing PKCS#11 modules like smart cards, in a
142 (G)object oriented way.
143
144
145 %package -n typelib-Gck
146 Summary:        GObject library to access for PKCS#11 modules -- Introspection bindings
147 Group:          Security/Crypto Libraries
148
149 %description -n typelib-Gck
150 GCK is a library for accessing PKCS#11 modules like smart cards, in a
151 (G)object oriented way.
152
153 This package provides the GObject Introspection bindings for GCK.
154
155
156 %package -n libgck-devel
157 Summary:        GObject library to access for PKCS#11 modules - Development Files
158 Group:          Development/Libraries
159 Requires:       libgck = %{version}
160 Requires:       typelib-Gck = %{version}
161
162 %description -n libgck-devel
163 GCK is a library for accessing PKCS#11 modules like smart cards, in a
164 (G)object oriented way.
165
166 %prep
167 %setup -q
168
169 %build
170
171 %autogen \
172  --disable-gtk-doc-html
173
174 make
175
176 %install
177 %make_install
178 # Cleanup installed test modules
179 rm %{buildroot}%{_libdir}/libmock-test-module.so
180 %tizen_update_desktop_file gcr-prompter
181 %tizen_update_desktop_file gcr-viewer
182 %find_lang %{name}
183
184 %post viewer
185 %desktop_database_post
186 %mime_database_post
187
188 %postun viewer
189 %desktop_database_postun
190 %mime_database_postun
191
192 %post data
193 %glib2_gsettings_schema_post
194 %icon_theme_cache_post
195
196 %postun data
197 %glib2_gsettings_schema_postun
198 %icon_theme_cache_postun
199
200 %post -n libgcr -p /sbin/ldconfig
201
202 %postun -n libgcr -p /sbin/ldconfig
203
204 %post -n libgck -p /sbin/ldconfig
205
206 %postun -n libgck -p /sbin/ldconfig
207
208 %post -n libgcr-ui -p /sbin/ldconfig
209
210 %postun -n libgcr-ui -p /sbin/ldconfig
211
212
213 %files viewer
214 %defattr(-,root,root)
215 %license COPYING
216 %{_bindir}/gcr-viewer
217 %{_datadir}/applications/gcr-viewer.desktop
218 %{_datadir}/mime/packages/gcr-crypto-types.xml
219
220
221 %files data
222 %defattr(-, root, root)
223 %{_datadir}/icons/hicolor/*/apps/*
224 %dir %{_datadir}/GConf
225 %dir %{_datadir}/GConf/gsettings
226 %{_datadir}/GConf/gsettings/org.gnome.crypto.pgp.convert
227 %{_datadir}/GConf/gsettings/org.gnome.crypto.pgp_keyservers.convert
228 %{_datadir}/glib-2.0/schemas/org.gnome.crypto.pgp.gschema.xml
229
230
231 %files prompter
232 %defattr(-, root, root)
233 %{_libexecdir}/gcr-prompter
234 %{_datadir}/applications/gcr-prompter.desktop
235 %{_datadir}/dbus-1/services/org.gnome.keyring.PrivatePrompter.service
236 %{_datadir}/dbus-1/services/org.gnome.keyring.SystemPrompter.service
237
238
239 %files -n libgcr
240 %defattr (-, root, root)
241 %license COPYING
242 %{_libdir}/libgcr-3.so.*
243 %{_libdir}/libgcr-base-3.so.*
244 %{_datadir}/gcr-3/
245
246
247 %files -n typelib-Gcr
248 %defattr(-,root,root)
249 %{_libdir}/girepository-1.0/Gcr-3.typelib
250
251
252 %files -n libgcr-devel
253 %defattr (-, root, root)
254 %{_libdir}/libgcr-3.so
255 %{_libdir}/libgcr-base-3.so
256 %{_libdir}/pkgconfig/gcr-3.pc
257 %{_libdir}/pkgconfig/gcr-base-3.pc
258 %{_includedir}/gcr-3/
259
260
261 %files -n libgck
262 %defattr (-, root, root)
263 %license COPYING
264 %{_libdir}/libgck-1.so.*
265
266
267 %files -n typelib-Gck
268 %defattr(-,root,root)
269 %{_libdir}/girepository-1.0/Gck-1.typelib
270
271
272 %files -n libgck-devel
273 %defattr (-, root, root)
274 %{_libdir}/libgck-1.so
275 %{_libdir}/pkgconfig/gck-1.pc
276 %{_includedir}/gck-1/
277 %{_datadir}/gir-1.0/Gck-1.gir
278 %{_datadir}/gir-1.0/Gcr-3.gir
279
280
281 %files -n libgcr-ui
282 %defattr (-, root, root)
283 %license COPYING
284 %{_libdir}/libgcr-ui-3.so.1
285 %{_libdir}/libgcr-ui-3.so.1.0.0
286 %{_datadir}/gir-1.0/GcrUi-3.gir
287
288
289 %files -n typelib-GcrUi
290 %defattr(-,root,root)
291 %{_libdir}/girepository-1.0/GcrUi-3.typelib
292
293
294 %files -n libgcr-ui-devel
295 %defattr (-, root, root)
296 %{_libdir}/libgcr-ui-3.so
297 %{_libdir}/pkgconfig/gcr-ui-3.pc
298
299 %lang_package -n libgcr