Tizen 2.1 base
[platform/upstream/gcd.git] / pthread_workqueue-0.8.2 / packaging / pthread_workqueue.spec
1 #
2 # Copyright (c) 2009 Mark Heily <mark@heily.com>
3 #
4 # Permission to use, copy, modify, and distribute this software for any
5 # purpose with or without fee is hereby granted, provided that the above
6 # copyright notice and this permission notice appear in all copies.
7
8 # THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
9 # WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
10 # MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
11 # ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
12 # WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
13 # ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
14 # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
15 #
16
17 Name:       pthread_workqueue
18 Summary:    thread pool library
19 Version:    0.8.2
20 Release:    1
21 License:    LICENSE
22 Vendor:     AUTHOR
23 Group:      System Environment/Libraries
24 Source0:    %{name}-%version.tar.gz
25 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
26 Provides:   libpthread_workqueue.so.0 libpthread_workqueue.so
27
28 %description
29 thread pool library.
30
31 %package devel  
32 Summary:    thread pool library. (Development)  
33 Group:      TO_BE/FILLED_IN  
34 Requires:   %{name} = %{version}-%{release}  
35   
36 %description devel  
37 thread pool library. (DEV)  
38
39 %prep
40 %setup -q -n pthread_workqueue-0.8.2
41
42 %build
43 ./configure --prefix=/usr
44 make
45
46 %install
47 make DESTDIR=$RPM_BUILD_ROOT install
48
49 %clean
50 [ ${RPM_BUILD_ROOT} != "/" ] && rm -rf ${RPM_BUILD_ROOT}
51
52 %post
53 /sbin/ldconfig
54
55 %postun
56 /sbin/ldconfig
57
58 %files
59 %defattr(-,root,root)
60
61 /usr/lib/libpthread_workqueue.so.0
62 /usr/lib/libpthread_workqueue.so.0.0
63
64 %files devel  
65 /usr/include/pthread_workqueue.h
66 /usr/lib/libpthread_workqueue.so
67 /usr/lib/libpthread_workqueue.so.0
68 /usr/lib/libpthread_workqueue.so.0.0
69 /usr/share/man/man3/pthread_workqueue.3.gz
70
71 %changelog