Tizen 2.1 base
[platform/upstream/gcd.git] / kqueue-1.0.4 / packaging / kqueue.spec
1 #
2 # Copyright (c) 2009 Mark Heily <mark@heily.com>
3 #
4 # Permission to use, copy, modify, and distribute this software for any
5 # purpose with or without fee is hereby granted, provided that the above
6 # copyright notice and this permission notice appear in all copies.
7
8 # THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
9 # WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
10 # MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
11 # ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
12 # WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
13 # ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
14 # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
15 #
16
17 Name:       kqueue
18 Summary:    cross-platform library for kernel event notification
19 Version:    1.0.4
20 Release:    1
21 License:    LICENSE
22 Vendor:     AUTHOR
23 Group:      System Environment/Libraries
24 Source0:    %{name}-%version.tar.gz
25 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
26 Provides:   libkqueue.so.0
27
28 %description
29 cross-platform library for kernel event notification.
30
31 %package devel  
32 Summary:    cross-platform library for kernel event notification. (Development)  
33 Group:      TO_BE/FILLED_IN  
34 Requires:   %{name} = %{version}-%{release}  
35   
36 %description devel  
37 cross-platform library for kernel event notification. (DEV)  
38
39 %prep
40 %setup -q -n kqueue-1.0.4
41
42 %build
43 ./configure --prefix=/usr
44 make
45
46 %install
47 make DESTDIR=$RPM_BUILD_ROOT install
48 gzip $RPM_BUILD_ROOT/usr/share/man/man2/kqueue.2
49 gzip $RPM_BUILD_ROOT/usr/share/man/man2/kevent.2
50
51 %clean
52 [ ${RPM_BUILD_ROOT} != "/" ] && rm -rf ${RPM_BUILD_ROOT}
53
54 %post
55 /sbin/ldconfig
56
57 %postun
58 /sbin/ldconfig
59
60 %files
61 %defattr(-,root,root)
62
63 %{_libdir}/libkqueue.so.0
64 %{_libdir}/libkqueue.so.0.0
65
66 %files devel  
67 /usr/include/kqueue/sys/event.h
68 %{_libdir}/libkqueue.so
69 %{_libdir}/libkqueue.so.0
70 %{_libdir}/libkqueue.so.0.0
71 %{_libdir}/libkqueue.la
72 %{_libdir}/libkqueue.a
73 %{_libdir}/pkgconfig/libkqueue.pc
74 /usr/share/man/man2/kqueue.2.gz
75 /usr/share/man/man2/kevent.2.gz
76
77 %changelog