Adding the manifest
[platform/upstream/gcc48.git] / packaging / libffi48.spec
1 %define building_libffi 1
2 #
3 # spec file for package gcc48
4 #
5 # Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
6 #
7 # All modifications and additions to the file contributed by third parties
8 # remain the property of their copyright owners, unless otherwise agreed
9 # upon. The license for this file, and modifications and additions to the
10 # file, is the same license as for the pristine package itself (unless the
11 # license for the pristine package is not an Open Source License, in which
12 # case the license is the MIT License). An "Open Source License" is a
13 # license that conforms to the Open Source Definition (Version 1.9)
14 # published by the Open Source Initiative.
15
16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
17 #
18
19 # norootforbuild
20 # icecream 0
21
22
23 %define build_ada 0
24
25 %define quadmath_arch %ix86 x86_64 ia64
26 %define tsan_arch x86_64
27 %define asan_arch x86_64 %ix86 ppc ppc64 %arm
28 %define itm_arch x86_64 %ix86 %arm ppc ppc64
29 %define atomic_arch x86_64 %ix86 %arm ppc ppc64 s390 s390x
30
31 # We don't want to build java
32 %define build_java 0
33 %define build_libjava 0
34
35 %define build_cp 1
36 %define build_fortran 0%{?building_libjava:1}%{?building_libffi:1}
37 %define build_objc 0%{?building_libjava:1}%{?building_libffi:1}
38 %define build_objcp 0%{?building_libjava:1}%{?building_libffi:1}
39 %define build_with_mudflap 0
40
41 %if %{build_objcp}
42 %define build_cp 1
43 %define build_objc 1
44 %endif
45
46 %if %{build_libjava}
47 %define build_cp 1
48 %endif
49
50 # For optional compilers only build C, C++ and Fortran
51 %if 0%{?build_optional_compiler_languages:1}
52 %define build_ada 0
53 %define build_java 0
54 %define build_libjava 0
55 %define build_objc 0
56 %define build_objcp 0
57 %endif
58
59 # Shared library SONAME versions
60 %define libgcc_s 1
61 %define libgcj_sover %{nil}
62 %define libgcj_bc_sover %{nil}
63 %define libffi_sover %{nil}
64 %define libmudflap_sover %{nil}
65 %define libgomp_sover %{nil}
66 %define libstdcxx_sover %{nil}
67 %define libobjc_sover %{nil}
68 %define libgfortran_sover %{nil}
69 %define libquadmath_sover %{nil}
70 %define libasan_sover %{nil}
71 %define libtsan_sover %{nil}
72 %define libatomic_sover %{nil}
73 %define libitm_sover %{nil}
74
75 # Shared library package suffix
76 # This is used for the "non-standard" set of libraries, the standard
77 # being defined by %product_libs_gcc_ver, the GCC version that should
78 # provide un-suffixed shared library packages following the shared-library
79 # policy.  Even suffixed variants should provide the shared-library policy
80 # mandated names and ensure they conflict with each other.
81 # Note that on SONAME changes of any library the %product_libs_gcc_ver
82 # define needs to be either split or the newest GCC version still providing
83 # the old SONAME needs to unconditionally produce an un-suffixed library
84 # if %product_libs_gcc_ver is newer than it.  Similar the _oldest_ GCC
85 # version first providing a new SONAME needs to unconditionally produce
86 # an un-suffixed library if %product_libs_gcc_ver is lower that it.
87 %if %{!?product_libs_gcc_ver:48}%{?product_libs_gcc_ver} != 48
88 %define pne 1
89 %endif
90 %define libgcc_s_suffix %{?pne:-gcc48}
91 # libgcj SONAME changes with every GCC version
92 %define libgcj_suffix %nil
93 %define libgcj_bc_suffix %{?pne:-gcc48}
94 %define libffi_suffix %{?pne:-gcc48}
95 %define libmudflap_suffix %{?pne:-gcc48}
96 %define libgomp_suffix %{?pne:-gcc48}
97 %define libstdcxx_suffix %{?pne:-gcc48}
98 %define libobjc_suffix %{?pne:-gcc48}
99 %define libgfortran_suffix %{?pne:-gcc48}
100 %define libquadmath_suffix %{?pne:-gcc48}
101 %define libasan_suffix %{?pne:-gcc48}
102 %define libtsan_suffix %{?pne:-gcc48}
103 %define libatomic_suffix %{?pne:-gcc48}
104 %define libitm_suffix %{?pne:-gcc48}
105
106
107
108
109 Name: libffi48
110 BuildRequires: gcc-c++
111 BuildRequires: bison
112 BuildRequires: flex
113 BuildRequires: glibc-devel-32bit
114 BuildRequires: mpc-devel
115 BuildRequires: mpfr-devel
116 BuildRequires: perl
117 BuildRequires: makeinfo
118 BuildRequires: zlib-devel
119 %ifarch %ix86 x86_64 ppc ppc64 s390 s390x ia64 %sparc hppa %arm
120 BuildRequires: cloog-isl-devel
121 BuildRequires: isl-devel
122 %endif
123 %if %{build_ada}
124 %define hostsuffix -4.7
125 BuildRequires: gcc47-ada
126 %endif
127 %if 0%{?building_libjava:1}%{?building_testsuite:1}
128 BuildRequires: fastjar
129 %endif
130 %if 0%{?building_libffi:1}
131 BuildRequires: pkg-config
132 %endif
133 %ifarch ia64
134 BuildRequires: libunwind-devel
135 %endif
136 %if 0%{?run_tests:1}
137 BuildRequires: dejagnu
138 BuildRequires: expect
139 BuildRequires: gdb
140 %endif
141
142 %define separate_bi32 0
143 %define separate_bi64 0
144 %ifarch ppc sparcv9
145 # Beware, this does _not_ separate libgcj, as for that one multilibing
146 # is inactive for the time being
147 %define separate_bi64 1
148 %endif
149 %ifarch x86_64 s390x ppc64 sparc64
150 %define separate_bi32 1
151 %endif
152
153 # Define two macros to trigger -32bit or -64bit package variants
154 %define separate_biarch 0
155 %if %{separate_bi32}
156 %define separate_biarch 1
157 %define separate_biarch_suffix -32bit
158 %endif
159 %if %{separate_bi64}
160 %define separate_biarch 1
161 %define separate_biarch_suffix -64bit
162 %endif
163
164 %ifarch x86_64 ia64 s390x alpha ppc64 sparc64
165 # 64-bit is primary build target
166 %define build_primary_64bit 1
167 %else
168 %define build_primary_64bit 0
169 %endif
170
171 %define biarch_libjava 0
172
173 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
174
175 URL:          http://gcc.gnu.org/
176 Version: 4.8.2
177 Release:      1
178 %define gcc_dir_version 4.8
179 %define binsuffix -4.8
180
181 %if !0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
182 Requires: binutils glibc-devel
183 Requires: cpp48 = %{version}-%{release}
184 Requires: libgcc_s%{libgcc_s} >= %{version}-%{release}
185 Requires: libgomp%{libgomp_sover} >= %{version}-%{release}
186 %if %{build_with_mudflap}
187 Requires: libmudflap%{libmudflap_sover} >= %{version}-%{release}
188 Requires: libmudflapth%{libmudflap_sover} >= %{version}-%{release}
189 %endif
190 %ifarch %asan_arch
191 Requires: libasan%{libasan_sover} >= %{version}-%{release}
192 %endif
193 %ifarch %tsan_arch
194 Requires: libtsan%{libtsan_sover} >= %{version}-%{release}
195 %endif
196 %ifarch %atomic_arch
197 Requires: libatomic%{libatomic_sover} >= %{version}-%{release}
198 %endif
199 %ifarch %itm_arch
200 Requires: libitm%{libitm_sover} >= %{version}-%{release}
201 %endif
202 Suggests: gcc48-info gcc48-locale
203 %endif
204
205 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
206 Source:         gcc-%{version}.tar.bz2
207 Source1:        change_spec
208 Source3:        gcc48-rpmlintrc
209 Source4:        ecj.jar
210 Source6:        baselibs.conf
211 Source1001: gcc.manifest
212
213
214 Group:          Development/Toolchain
215 Summary:        The GNU C Compiler and Support Files
216 License:        GPL-3.0+
217
218 %description
219 Core package for the GNU Compiler Collection, including the C language
220 frontend.
221
222 Language frontends other than C are split to different sub-packages,
223 namely gcc-ada, gcc-c++, gcc-fortran, gcc-java, gcc-objc and
224 gcc-obj-c++.
225 %package -n libffi%{libffi_sover}%{libffi_suffix}
226 Summary:      Foreign Function Interface library
227 License:        BSD-3-Clause
228
229 %description -n libffi%{libffi_sover}%{libffi_suffix}
230 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
231
232 %post -n libffi%{libffi_sover}%{libffi_suffix}
233 /sbin/ldconfig
234
235 %postun -n libffi%{libffi_sover}%{libffi_suffix}
236 /sbin/ldconfig
237 %package -n libffi%{libffi_sover}%{libffi_suffix}-32bit
238 Summary:      Foreign Function Interface library
239 License:        BSD-3-Clause
240
241 %description -n libffi%{libffi_sover}%{libffi_suffix}-32bit
242 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
243
244 %post -n libffi%{libffi_sover}%{libffi_suffix}-32bit
245 /sbin/ldconfig
246
247 %postun -n libffi%{libffi_sover}%{libffi_suffix}-32bit
248 /sbin/ldconfig
249 %package -n libffi%{libffi_sover}%{libffi_suffix}-64bit
250 Summary:      Foreign Function Interface library
251 License:        BSD-3-Clause
252
253 %description -n libffi%{libffi_sover}%{libffi_suffix}-64bit
254 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
255
256 %post -n libffi%{libffi_sover}%{libffi_suffix}-64bit
257 /sbin/ldconfig
258
259 %postun -n libffi%{libffi_sover}%{libffi_suffix}-64bit
260 /sbin/ldconfig
261
262 %package -n libffi48-devel
263 Summary:      Foreign Function Interface library development files
264 License:        BSD 3-Clause
265 Requires: libffi%{libffi_sover} >= %{version}-%{release}
266
267 %description -n libffi48-devel
268 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
269 %package -n libffi48-devel-32bit
270 Summary:      Foreign Function Interface library development files
271 License:        BSD 3-Clause
272 Requires: libffi%{libffi_sover}-32bit >= %{version}-%{release}
273
274 %description -n libffi48-devel-32bit
275 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
276 %package -n libffi48-devel-64bit
277 Summary:      Foreign Function Interface library development files
278 License:        BSD 3-Clause
279 Requires: libffi%{libffi_sover}-64bit >= %{version}-%{release}
280
281 %description -n libffi48-devel-64bit
282 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
283
284 %package -n gcc48-testresults
285 Summary:      Testsuite results
286 License:        SUSE-Public-Domain
287
288 %description -n gcc48-testresults
289 Results from running the gcc and target library testsuites.
290
291
292
293 # Define the canonical target and host architecture
294 #   %gcc_target_arch  is supposed to be the full target triple
295 #   %TARGET_ARCH      is the canonicalized CPU part
296 #   %CONFIGURE_TARGET is the target triple used for --target=
297 %if 0%{?gcc_target_arch:1}
298 %define CONFIGURE_TARGET %{gcc_target_arch}
299 %define TARGET_ARCH %(echo %{gcc_target_arch} | cut -d - -f 1 | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
300 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "powerpc"
301 %define CONFIGURE_TARGET powerpc64-tizen-linux
302 %endif
303 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "powerpc64"
304 %define CONFIGURE_TARGET powerpc64-tizen-linux
305 %endif
306 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "i586"
307 %define CONFIGURE_TARGET i586-tizen-linux
308 %endif
309 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7l"
310 %define CONFIGURE_TARGET armv7l-tizen-linux-gnueabi
311 %endif
312 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7hl"
313 %define CONFIGURE_TARGET armv7hl-tizen-linux-gnueabi
314 %endif
315 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv5tel"
316 %define CONFIGURE_TARGET armv5tel-tizen-linux-gnueabi
317 %endif
318 %else
319 %define TARGET_ARCH %(echo %{_target_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
320 %endif
321 %define HOST_ARCH %(echo %{_host_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
322
323 %define biarch %(case " %{biarch_targets} " in (*" %{TARGET_ARCH} "*) echo 1;; (*) echo 0;; esac)
324
325 %ifarch ppc
326 %define GCCDIST powerpc64-tizen-linux
327 %else
328 %ifarch %sparc
329 %define GCCDIST sparc64-tizen-linux
330 %else
331 %ifarch %arm
332 %define GCCDIST %{HOST_ARCH}-tizen-linux-gnueabi
333 %else
334 %define GCCDIST %{HOST_ARCH}-tizen-linux
335 %endif
336 %endif
337 %endif
338
339 %define libsubdir %{_libdir}/gcc/%{GCCDIST}/%{gcc_dir_version}
340 %define gxxinclude %{_prefix}/include/c++/%{gcc_dir_version}
341
342
343 # Versionspecific directories
344 %define versmainlibdir %{libsubdir}
345 %define versmainlibdirbi32 %{libsubdir}/32
346 %define versmainlibdirbi64 %{libsubdir}/64
347 %ifarch ppc
348 %define versmainlibdirbi32 %{libsubdir}
349 %define versmainlibdirbi64 %{libsubdir}/64
350 %endif
351 %if %{build_primary_64bit}
352 %define versmainlibdirbi %{versmainlibdirbi32}
353 %else
354 %define versmainlibdirbi %{versmainlibdirbi64}
355 %endif
356
357 %define mainlibdir %{_libdir}
358 %define mainlibdirbi32 %{_prefix}/lib
359 %define mainlibdirbi64 %{_prefix}/lib64
360 %if %{build_primary_64bit}
361 %define mainlibdirbi %{mainlibdirbi32}
362 %else
363 %define mainlibdirbi %{mainlibdirbi64}
364 %endif
365
366
367 # Now define a few macros that make it easy to package libs and
368 # related files just to the right package, without caring for the
369 # exact path the files are in.
370 #   %mainlib  package X from all dirs that belong to the main package
371 #   %biarchlib   package X from all dirs that belong to the -32/64bit package
372 %define mainlib() %{mainlibdir}/%1\
373 %{nil}
374 %define biarchlib() %{nil}
375 %if %{biarch}
376 %if !%{separate_biarch}
377 %define mainlib() %{mainlibdir}/%1\
378 %{mainlibdirbi}/%1\
379 %{nil}
380 %else
381 %define biarchlib() %{mainlibdirbi}/%1\
382 %{nil}
383 %endif
384 %endif
385
386 %define versmainlib() %{versmainlibdir}/%1\
387 %{nil}
388 %define versbiarchlib() %{nil}
389 %if %{biarch}
390 %if !%{separate_biarch}
391 %define versmainlib() %{versmainlibdir}/%1\
392 %{versmainlibdirbi}/%1\
393 %{nil}
394 %else
395 %define versbiarchlib() %{versmainlibdirbi}/%1\
396 %{nil}
397 %endif
398 %endif
399
400
401
402 %prep
403 %setup -q -n gcc-%{version}
404 cp %{SOURCE1001} .
405
406
407 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
408 # the libstdc++ abi testsuite baseline files accordingly
409 %ifarch ppc
410 if [ -d libstdc++-v3/config/abi/post/powerpc64-linux-gnu ]; then
411   mkdir -p libstdc++-v3/config/abi/post/powerpc64-linux-gnu/64
412   mv libstdc++-v3/config/abi/post/powerpc64-linux-gnu/baseline_symbols.txt \
413         libstdc++-v3/config/abi/post/powerpc64-linux-gnu/64/
414   mv libstdc++-v3/config/abi/post/powerpc64-linux-gnu/32/baseline_symbols.txt \
415         libstdc++-v3/config/abi/post/powerpc64-linux-gnu/
416 fi
417 %endif
418
419 %build
420 # Avoid rebuilding of generated files
421 contrib/gcc_update --touch
422 # Avoid fucking up testsuite results with Java and indirect dispatch
423 export LD_AS_NEEDED=0
424 # Split version file into version used for directories (X.Y) and
425 # version to report with --version (X.Y.Z).
426 # See also gcc-dir-version.patch.
427 # Also decrement the patchlevel version by one
428 if test `cat gcc/DEV-PHASE` == "prerelease"; then
429   ( cat gcc/BASE-VER | cut -d '.' -f 1-2 | tr -d '\n'; echo -n .; cat gcc/BASE-VER | cut -d '.' -f 3 | tr '0123456789' '0012345678' ) > gcc/FULL-VER
430 else
431   mv gcc/BASE-VER gcc/FULL-VER
432 fi
433 cat gcc/FULL-VER | cut -d '.' -f 1-2 > gcc/BASE-VER
434
435 rm -rf obj-%{GCCDIST}
436 mkdir obj-%{GCCDIST}
437 cd obj-%{GCCDIST}
438 RPM_OPT_FLAGS="$RPM_OPT_FLAGS -U_FORTIFY_SOURCE"
439 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fno-rtti//g' -e 's/-fno-exceptions//g' -e 's/-Wmissing-format-attribute//g' -e 's/-fstack-protector//g' -e 's/-ffortify=.//g' -e 's/-Wall//g' -e 's/-m32//g' -e 's/-m64//g'`
440 %ifarch %ix86
441 # -mcpu is superceded by -mtune but -mtune is not supported by
442 # our bootstrap compiler.  -mcpu gives a warning that stops
443 # the build process, so remove it for now.  Also remove all other
444 # -march and -mtune flags.  They are superseeded by proper
445 # default compiler settings now.
446 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-mcpu=i.86//g' -e 's/-march=i.86//g' -e 's/-mtune=i.86//g'`
447 %endif
448 %ifarch s390 s390x
449 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fsigned-char//g'`
450 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-O1/-O2/g'`
451 %endif
452 %if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
453 # Kill all -march/tune/cpu because that screws building the target libs
454 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-m\(arch\|tune\|cpu\)=[^ ]*//g'`
455 %endif
456 # Replace 2 spaces by one finally
457 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/  / /g'`
458
459 languages=c
460 %if %{build_cp}
461 languages=$languages,c++
462 %endif
463 %if %{build_objc}
464 languages=$languages,objc
465 %endif
466 %if %{build_fortran}
467 languages=$languages,fortran
468 %endif
469 %if %{build_objcp}
470 languages=$languages,obj-c++
471 %endif
472 %if %{build_java}
473 languages=$languages,java
474 %endif
475 %if %{build_ada}
476 languages=$languages,ada
477 %endif
478
479 J=%{?jobs:%jobs}
480 if test -z "$J"; then
481   J=$(getconf _NPROCESSORS_CONF)
482   JL=$(($J * 2))
483 else
484   test 1 -gt "$J" && J=1
485   JL=$(($(getconf _NPROCESSORS_CONF)*2))
486 fi
487 if test "$J" == "0"; then
488   J=1
489 fi
490 if test "$JL" == "0"; then
491   JL=1
492 fi
493 PARALLEL="-j$J -l$JL"
494
495 # we don't want some miscompiles in the testsuite, or some fault in
496 # the compiler to kill the machine.  Hence we limit the amount of memory
497 # by the physical RAM plus half of swap
498 #MEM=$(free -m | awk '/^Mem:/ {print $2}')
499 #SWAP=$(free -m | awk '/^Swap:/ {print $2}')
500 #ulimit -v $(((MEM + SWAP/2)*1024))
501
502 # In general we want to ship release checking enabled compilers
503 # and run BETA with checking enabled.
504 #ENABLE_CHECKING="--enable-checking=yes"
505 ENABLE_CHECKING="--enable-checking=release"
506
507 # Work around tail/head -1 changes
508 export _POSIX2_VERSION=199209
509
510 # configure tries to parse include/features.h to detect
511 # if glibc supports SSP.  When cross compiling we would need
512 # to install a cross glibc, which we don't, or make the whole
513 # thing point to the native glibc, which is in /, hence the
514 # --with-build-sysroot=/
515
516 %if %{build_ada}
517 # Using the host gnatmake like
518 #   CC="gcc%{hostsuffix}" GNATBIND="gnatbind%{hostsuffix}"
519 #   GNATMAKE="gnatmake%{hostsuffix}"
520 # doesn't work due to PR33857, so an un-suffixed gnatmake has to be
521 # available
522 mkdir -p host-tools/bin
523 cp -a /usr/bin/gnatmake%{hostsuffix} host-tools/bin/gnatmake
524 cp -a /usr/bin/gnatlink%{hostsuffix} host-tools/bin/gnatlink
525 cp -a /usr/bin/gnatbind%{hostsuffix} host-tools/bin/gnatbind
526 cp -a /usr/bin/gcc%{hostsuffix} host-tools/bin/gcc
527 ln -sf /usr/%{_lib} host-tools/%{_lib}
528 export PATH="`pwd`/host-tools/bin:$PATH"
529 %endif
530 #%if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
531 #%else
532 #       --enable-threads=posix \
533 #%endif
534 #       --enable-shared \
535 %if "%{TARGET_ARCH}" == "armv7l" || "%{TARGET_ARCH}" == "armv7hl"
536 # temporary workaround for a miscompilation of hash functions in java code
537 GCJ_EXTRA_FLAGS="-marm"
538 %endif
539 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" XCFLAGS="$RPM_OPT_FLAGS" \
540 TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
541 ../configure \
542         --prefix=%{_prefix} \
543         --infodir=%{_infodir} \
544         --mandir=%{_mandir} \
545         --libdir=%{_libdir} \
546         --libexecdir=%{_libdir} \
547     --disable-bootstrap \
548         --enable-languages=$languages \
549         $ENABLE_CHECKING \
550         --with-gxx-include-dir=%{_prefix}/include/c++/%{gcc_dir_version} \
551         --enable-ssp \
552         --disable-libssp \
553         --disable-plugin \
554         --with-bugurl="http://bugs.tizen.org/" \
555         --with-pkgversion="Tizen" \
556 %if !%{build_fortran}
557         --disable-libquadmath \
558 %endif
559 %if !%{build_libjava}
560         --disable-libgcj \
561 %else
562         --with-java-home=%{_libdir}/jvm/java-1.5.0-gcj%{binsuffix}-1.5.0.0/jre \
563         --with-ecj-jar=%{libsubdir}/ecj.jar \
564         --disable-java-awt \
565 %if !%{biarch_libjava}
566         --disable-libjava-multilib \
567 %endif
568 %endif
569 %if !%{build_with_mudflap}
570         --disable-libmudflap \
571 %endif
572         --with-slibdir=/%{_lib} \
573         --with-system-zlib \
574         --enable-__cxa_atexit \
575         --enable-libstdcxx-allocator=new \
576         --disable-libstdcxx-pch \
577         --enable-version-specific-runtime-libs \
578         --enable-linker-build-id \
579 %if 0%{?gcc_target_arch:1}
580 %if 0%{?gcc_icecream:1}
581         --with-sysroot=/ \
582         --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/include/c++/%{gcc_dir_version} \
583         --enable-linux-futex \
584 %endif
585 %if 0%{?canonical_target:1}
586         --with-build-time-tools=/usr/%{canonical_target}-tizen-linux%{?canonical_target_abi:%canonical_target_abi}/bin \
587 %endif
588 %if 0%{?sysroot:1}
589         --with-sysroot=%sysroot \
590 %endif
591 %if 0%{?build_static:1}
592         --disable-shared \
593 %endif
594 %if "%{TARGET_ARCH}" == "spu"
595         --with-gxx-include-dir=%sysroot/include/c++/%{gcc_dir_version} \
596         --with-newlib \
597 %endif
598         --disable-nls \
599         --target=%{CONFIGURE_TARGET} \
600 %else
601         --program-suffix=%{binsuffix} \
602         --enable-linux-futex \
603 %ifarch ia64
604         --with-system-libunwind \
605 %else
606         --without-system-libunwind \
607 %endif
608 %endif
609 %if "%{TARGET_ARCH}" == "armv5tel"
610         --with-arch=armv5te \
611         --with-float=soft \
612         --with-mode=arm \
613         --with-abi=aapcs-linux \
614         --disable-sjlj-exceptions \
615 %endif
616 %if "%{TARGET_ARCH}" == "armv7l" 
617         --with-arch=armv7-a \
618         --with-tune=cortex-a8 \
619         --with-float=softfp \
620         --with-fpu=vfpv3 \
621         --with-mode=thumb \
622         --disable-sjlj-exceptions \
623 %endif
624 %if  "%{TARGET_ARCH}" == "armv7hl"
625         --with-arch=armv7-a \
626         --with-tune=cortex-a9 \
627         --with-float=hard \
628         --with-abi=aapcs-linux \
629         --with-fpu=vfpv3-d16 \
630         --disable-sjlj-exceptions \
631 %endif
632 %if "%{TARGET_ARCH}" == "powerpc" || "%{TARGET_ARCH}" == "powerpc64"
633 %if "%{TARGET_ARCH}" == "powerpc"
634         --with-cpu=default32 \
635 %endif
636         --with-cpu-64=power4 \
637         --enable-secureplt \
638         --with-long-double-128 \
639 %endif
640 %if "%{TARGET_ARCH}" == "sparc64"
641         --with-cpu=ultrasparc \
642         --with-long-double-128 \
643 %endif
644 %if "%{TARGET_ARCH}" == "sparc"
645         --with-cpu=v8 \
646         --with-long-double-128 \
647 %endif
648 %if "%{TARGET_ARCH}" == "i586"
649         --with-arch-32=i586 \
650         --with-tune=generic \
651 %endif
652 %if "%{TARGET_ARCH}" == "x86_64"
653         --with-arch-32=i586 \
654         --with-tune=generic \
655 %endif
656 %if "%{TARGET_ARCH}" == "s390"
657         --with-tune=z196 --with-arch=z10 \
658         --with-long-double-128 \
659         --enable-decimal-float \
660 %endif
661 %if "%{TARGET_ARCH}" == "s390x"
662         --with-tune=z196 --with-arch=z10 \
663         --with-long-double-128 \
664         --enable-decimal-float \
665 %endif
666         --build=%{GCCDIST}
667
668
669 %if 0%{?building_libffi:1}
670 make stage1-bubble $PARALLEL
671 make all-target-libffi $PARALLEL
672 %else
673 STAGE1_FLAGS="-g"
674 # Only run profiled bootstrap on archs where it works
675 #%ifarch %ix86 x86_64 ppc ppc64 ia64
676 #make profiledbootstrap-lean STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
677 #%else
678 #make bootstrap-lean STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
679 make STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
680 #%endif
681 #make -C gcc proto
682 make info
683 %if 0%{?run_tests:1}
684 echo "Run testsuite"
685 (make -C %{GCCDIST}/libstdc++-v3 check-abi || true)
686 mv %{GCCDIST}/libstdc++-v3/testsuite/libstdc++.log %{GCCDIST}/libstdc++-v3/testsuite/libstdc++-abi.log
687 mv %{GCCDIST}/libstdc++-v3/testsuite/libstdc++.sum %{GCCDIST}/libstdc++-v3/testsuite/libstdc++-abi.sum
688 # asan needs a whole shadow address space
689 ulimit -v unlimited || true
690 make -k check $PARALLEL || true
691 mkdir ../testresults
692 ../contrib/test_summary | tee ../testresults/test_summary.txt
693 %endif
694 %endif
695
696 %install
697 export NO_BRP_CHECK_BYTECODE_VERSION=true
698 cd obj-%{GCCDIST}
699 # Work around tail/head -1 changes
700 export _POSIX2_VERSION=199209
701 export LIBRARY_PATH=$RPM_BUILD_ROOT%{libsubdir}:$RPM_BUILD_ROOT%{mainlibdirbi}
702 %if 0%{?building_libffi:1}
703 make -C %{GCCDIST}/libffi install DESTDIR=$RPM_BUILD_ROOT
704 %else
705 %if 0%{?building_libjava:1}
706 make -C %{GCCDIST}/libjava install DESTDIR=$RPM_BUILD_ROOT
707 make -C gcc java.install-man DESTDIR=$RPM_BUILD_ROOT
708 make -C gcc java.install-common DESTDIR=$RPM_BUILD_ROOT
709 make -C gcc install-common DESTDIR=$RPM_BUILD_ROOT COMPILERS='jc1$(exeext) jvgenmain$(exeext)'
710 # install-common also installs collect2, gcov and the g++ and gfortran driver
711 %if %{build_cp}
712 rm $RPM_BUILD_ROOT%{_prefix}/bin/g++%{binsuffix}
713 %endif
714 %if %{build_fortran}
715 rm $RPM_BUILD_ROOT%{_prefix}/bin/gfortran%{binsuffix}
716 %endif
717 rm $RPM_BUILD_ROOT%{_prefix}/bin/gcov%{binsuffix}
718 rm $RPM_BUILD_ROOT%{libsubdir}/collect2
719 %else
720 make install DESTDIR=$RPM_BUILD_ROOT
721 %if %{build_java}
722 make -C gcc java.uninstall DESTDIR=$RPM_BUILD_ROOT
723 make -C gcc java.install-info DESTDIR=$RPM_BUILD_ROOT
724 rm $RPM_BUILD_ROOT%{_prefix}/bin/jcf-dump%{binsuffix}
725 rm $RPM_BUILD_ROOT%{_mandir}/man1/jcf-dump%{binsuffix}.1
726 rm $RPM_BUILD_ROOT%{libsubdir}/jc1
727 rm $RPM_BUILD_ROOT%{libsubdir}/jvgenmain
728 %endif
729 %endif
730 %endif
731
732 # Remove libffi installed files if we did not want to build it
733 %if !0%{?building_libffi:1}
734 rm -f $RPM_BUILD_ROOT%{mainlibdir}/libffi.*
735 %if %{biarch}
736   rm -f $RPM_BUILD_ROOT%{mainlibdirbi}/libffi.*
737 %endif
738 rm -f $RPM_BUILD_ROOT%{libsubdir}/include/ffi.h
739 rm -f $RPM_BUILD_ROOT%{libsubdir}/include/ffitarget.h
740 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/ffi%{binsuffix}.3*
741 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/ffi_call%{binsuffix}.3*
742 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/ffi_prep_cif%{binsuffix}.3*
743 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/ffi_prep_cif_var%{binsuffix}.3*
744 %endif
745
746 # Remove some useless .la files
747 for lib in libobjc libgfortran libgfortranbegin libquadmath libcaf_single \
748     libmudflap libmudflapth libgomp libstdc++ libsupc++ libgcj-tools libgij \
749     libasan libatomic libitm libtsan; do
750   rm -f $RPM_BUILD_ROOT%{versmainlibdir}/$lib.la
751 %if %{biarch}
752   rm -f $RPM_BUILD_ROOT%{versmainlibdirbi}/$lib.la
753 %endif
754 done
755
756 mkdir -p $RPM_BUILD_ROOT%{_libdir}
757 %if %{biarch}
758 %if %{build_primary_64bit}
759 mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib
760 %else
761 mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib64
762 %endif
763 %endif
764
765
766 %if %{build_ada}
767 mv $RPM_BUILD_ROOT%{libsubdir}/adalib/lib*-*.so $RPM_BUILD_ROOT%{_libdir}
768 ln -sf %{_libdir}/libgnarl%{binsuffix}.so $RPM_BUILD_ROOT%{libsubdir}/adalib/libgnarl.so
769 ln -sf %{_libdir}/libgnat%{binsuffix}.so $RPM_BUILD_ROOT%{libsubdir}/adalib/libgnat.so
770 chmod a+x $RPM_BUILD_ROOT%{_libdir}/libgna*-*.so
771 %if %{biarch}
772 mv $RPM_BUILD_ROOT%{versmainlibdirbi}/adalib/lib*-*.so $RPM_BUILD_ROOT%{mainlibdirbi}/
773 ln -sf %{mainlibdirbi}/libgnarl%{binsuffix}.so $RPM_BUILD_ROOT%{versmainlibdirbi}/adalib/libgnarl.so
774 ln -sf %{mainlibdirbi}/libgnat%{binsuffix}.so $RPM_BUILD_ROOT%{versmainlibdirbi}/adalib/libgnarl.so
775 chmod a+x $RPM_BUILD_ROOT%{mainlibdirbi}/libgna*-*.so
776 %endif
777 %endif
778
779 rm -f $RPM_BUILD_ROOT%{_prefix}/bin/c++%{binsuffix}
780
781 # Remove some crap from the .la files:
782 for l in `find $RPM_BUILD_ROOT -name '*.la'`; do
783   echo "changing $l"
784 # -e '/^dependency_libs/s|%{libsubdir}/\([^.]*\)\.la |%{_libdir}/\1\.la |g'
785   sed -e '/^dependency_libs/s| -L%{_builddir}/[^ ]*||g' \
786       -e '/^dependency_libs/s| -L/usr/%{GCCDIST}/bin||g' \
787       -e '/^dependency_libs/s|-lm \(-lm \)*|-lm |' \
788       -e '/^dependency_libs/s|-L[^ ]* ||g' \
789 %if %{biarch}
790 %if %{build_primary_64bit}
791       -e '/^libdir/s|%{_libdir}/32|%{_prefix}/lib|' \
792       -e '/^libdir/s|lib64/\.\./||' \
793 %else
794       -e '/^libdir/s|%{_libdir}/64|%{_prefix}/lib64|' \
795 %endif
796 %endif
797       < $l  > $l.new
798   mv $l.new $l
799 done
800
801 %if 0%{?run_tests:1} 
802 cp `find . -name "*.sum"` ../testresults/
803 cp `find . -name "*.log"  \! -name "config.log" | grep -v 'acats.\?/tests' ` ../testresults/
804 chmod 644 ../testresults/*
805 %endif
806 # Remove files that we do not need to clean up filelist
807 rm -f $RPM_BUILD_ROOT%{_prefix}/bin/%{GCCDIST}-*
808 rm -rf $RPM_BUILD_ROOT%{libsubdir}/install-tools
809 #rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libgcj%{binsuffix}.pc
810 rm -rf $RPM_BUILD_ROOT%{libsubdir}/include-fixed/root
811 rm -f $RPM_BUILD_ROOT%{libsubdir}/include-fixed/curses.h
812 rm -rf $RPM_BUILD_ROOT%{libsubdir}/include-fixed/asm-*
813 rm -rf $RPM_BUILD_ROOT%{libsubdir}/include-fixed/linux
814 rm -rf $RPM_BUILD_ROOT%{libsubdir}/include-fixed/sound
815 rm -rf $RPM_BUILD_ROOT%{libsubdir}/include-fixed/features.h
816 rm -f $RPM_BUILD_ROOT%{libsubdir}/include-fixed/ncurses.h
817 rm -f $RPM_BUILD_ROOT%{libsubdir}/include-fixed/stdio.h
818 rm -f $RPM_BUILD_ROOT%{libsubdir}/include-fixed/zutil.h
819 rm -rf $RPM_BUILD_ROOT%{libsubdir}/include-fixed/X11
820 rm -rf $RPM_BUILD_ROOT%{libsubdir}/include-fixed/bits
821 rm -f $RPM_BUILD_ROOT%{libsubdir}/include-fixed/obstack.h
822 rm -f $RPM_BUILD_ROOT%{libsubdir}/include-fixed/spe.h
823 rm -f $RPM_BUILD_ROOT%{libsubdir}/include-fixed/tgmath.h
824 rm -rf $RPM_BUILD_ROOT%{libsubdir}/include-fixed/bits
825 rm -rf $RPM_BUILD_ROOT%{libsubdir}/include-fixed/sys
826 # no plugins
827 rm -rf $RPM_BUILD_ROOT%{libsubdir}/plugin
828 rm -f  $RPM_BUILD_ROOT%{_infodir}/dir
829 rm -f  $RPM_BUILD_ROOT%{_prefix}/bin/gccbug%{binsuffix}
830
831 %if !0%{?building_libjava:1}%{?building_libffi:1}
832 # delete compile flag tracking from crt files
833 crt_list=$RPM_BUILD_ROOT%{versmainlibdir}/crt*.o
834 %if %{biarch}
835 %if %{build_primary_64bit}
836 crt32_list=$RPM_BUILD_ROOT%{versmainlibdirbi32}/crt*.o
837 %else
838 crt64_list=$RPM_BUILD_ROOT%{versmainlibdirbi64}/crt*.o
839 %endif
840 %endif
841 for o in $crt_list $crt32_list $crt64_list; do
842   objcopy -R ".comment.SUSE.OPTs" $o
843 done
844 %endif
845
846 %if 0%{?building_libjava:1}
847 # gcj -static doesn't work properly anyway, unless using --whole-archive
848 # let's save the space instead.
849 find $RPM_BUILD_ROOT -name libgcj.a \
850         -o -name libgcj-tools.a \
851         -o -name libgij.a \
852         -o -name libjvm.a \
853         -o -name libgcj_bc.a \
854   | xargs rm -f
855
856 find $RPM_BUILD_ROOT -name libgcj.spec | xargs \
857   sed -i -e 's/lib: /&%%{static:%%eJava programs cannot be linked statically}/'
858
859 # security files have broken install locations, also they cause conflicts
860 # between libgcj versions.  Simply delete them here, libgcj will use its
861 # defaults in this case (which is what these files contain anyway).
862 rm $RPM_BUILD_ROOT%{_libdir}/logging.properties
863 rm -r $RPM_BUILD_ROOT%{_libdir}/security
864 %endif
865
866 %if 0%{?building_libffi:1}
867 # Move libffi headers, remove empty libffi libtool file
868 mkdir -p $RPM_BUILD_ROOT%{_prefix}/include
869 mv $RPM_BUILD_ROOT%{libsubdir}/include/ffitarget.h $RPM_BUILD_ROOT%{_prefix}/include/
870 mv $RPM_BUILD_ROOT%{libsubdir}/include/ffi.h $RPM_BUILD_ROOT%{_prefix}/include/
871 rm -f $RPM_BUILD_ROOT%{mainlibdir}/libffi.la
872 %if %{biarch}
873 rm -f $RPM_BUILD_ROOT%{mainlibdirbi}/libffi.la
874 %endif
875 # Generate a simple pkg-config file
876 mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig
877 echo -e 'Name: libffi\nVersion: 3.0.9\nDescription: libffi\nLibs: -lffi' > $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libffi.pc
878 %endif
879
880 %if %{build_java}
881 %if !%{build_libjava}
882 rm $RPM_BUILD_ROOT%{_mandir}/man1/jv-convert%{binsuffix}.1
883 rm $RPM_BUILD_ROOT%{_mandir}/man1/gcj-dbtool%{binsuffix}.1
884 rm $RPM_BUILD_ROOT%{_mandir}/man1/gij%{binsuffix}.1
885 rm $RPM_BUILD_ROOT%{_mandir}/man1/grmic%{binsuffix}.1
886 rm $RPM_BUILD_ROOT%{_mandir}/man1/gc-analyze%{binsuffix}.1
887 rm $RPM_BUILD_ROOT%{_mandir}/man1/aot-compile%{binsuffix}.1
888 rm $RPM_BUILD_ROOT%{_mandir}/man1/rebuild-gcj-db%{binsuffix}.1
889 %endif
890 rm -f $RPM_BUILD_ROOT%{_datadir}/gcc%{binsuffix}/python/libjava/aotcompile.py
891 rm -f $RPM_BUILD_ROOT%{_datadir}/gcc%{binsuffix}/python/libjava/classfile.py
892 %endif
893 rm -f $RPM_BUILD_ROOT%{_mandir}/man7/fsf-funding.7
894 rm -f $RPM_BUILD_ROOT%{_mandir}/man7/gfdl.7
895 rm -f $RPM_BUILD_ROOT%{_mandir}/man7/gpl.7
896 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
897 %if %{biarch}
898 %if %{build_primary_64bit}
899 rm -f $RPM_BUILD_ROOT%{_prefix}/lib/libiberty.a
900 %else
901 rm -f $RPM_BUILD_ROOT%{_prefix}/lib64/libiberty.a
902 %endif
903 %endif
904 rm -f $RPM_BUILD_ROOT%{libsubdir}/liblto_plugin.a
905 rm -f $RPM_BUILD_ROOT%{libsubdir}/liblto_plugin.la
906
907
908 %if %{build_java}
909 %if 0%{?building_libffi:1}
910 %files -n libffi%{libffi_sover}%{libffi_suffix}
911 %manifest gcc.manifest
912 %defattr(-,root,root)
913 %mainlib libffi.so.%{libffi_sover}*
914
915 %if %{separate_biarch}
916 %files -n libffi%{libffi_sover}%{libffi_suffix}%{separate_biarch_suffix}
917 %manifest gcc.manifest
918 %defattr(-,root,root)
919 %biarchlib libffi.so.%{libffi_sover}*
920 %endif
921
922 %post -n libffi48-devel
923 %install_info --info-dir=%{_infodir} %{_infodir}/libffi%{binsuffix}.info.gz
924 %postun -n libffi48-devel
925 %install_info_delete --info-dir=%{_infodir} %{_infodir}/libffi%{binsuffix}.info.gz
926
927 %files -n libffi48-devel
928 %manifest gcc.manifest
929 %defattr(-,root,root)
930 %{_prefix}/include/ffi.h
931 %{_prefix}/include/ffitarget.h
932 %mainlib libffi.so
933 %mainlib libffi.a
934 %{_libdir}/pkgconfig/libffi.pc
935 %doc %{_infodir}/libffi%{binsuffix}.info.gz
936 %doc %{_mandir}/man3/ffi%{binsuffix}.3.gz
937 %doc %{_mandir}/man3/ffi_call%{binsuffix}.3.gz
938 %doc %{_mandir}/man3/ffi_prep_cif%{binsuffix}.3.gz
939 %doc %{_mandir}/man3/ffi_prep_cif_var%{binsuffix}.3.gz
940
941 %if %{separate_biarch}
942 %files -n libffi48-devel%{separate_biarch_suffix}
943 %manifest gcc.manifest
944 %defattr(-,root,root)
945 %biarchlib libffi.so
946 %biarchlib libffi.a
947 %endif
948 %endif
949 %endif
950
951 %if 0%{?run_tests:1}
952 %files -n gcc48-testresults
953 %manifest gcc.manifest
954 %defattr(-,root,root)
955 %doc testresults/test_summary.txt
956 %doc testresults/*.sum
957 %doc testresults/*.log
958 %endif
959
960
961 %changelog