edac5332abbbef9600be460c99f74ee689c14d95
[platform/upstream/gcc48.git] / packaging / gcc48-testresults.spec
1 %define building_testsuite 1
2 %define run_tests 1
3 #
4 # spec file for package gcc48
5 #
6 # Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
7 #
8 # All modifications and additions to the file contributed by third parties
9 # remain the property of their copyright owners, unless otherwise agreed
10 # upon. The license for this file, and modifications and additions to the
11 # file, is the same license as for the pristine package itself (unless the
12 # license for the pristine package is not an Open Source License, in which
13 # case the license is the MIT License). An "Open Source License" is a
14 # license that conforms to the Open Source Definition (Version 1.9)
15 # published by the Open Source Initiative.
16
17 # Please submit bugfixes or comments via http://bugs.opensuse.org/
18 #
19
20 # norootforbuild
21 # icecream 0
22
23
24 %define build_ada 0
25
26 %define quadmath_arch %ix86 x86_64 ia64
27 %define tsan_arch x86_64
28 %define asan_arch x86_64 %ix86 ppc ppc64
29 %define itm_arch x86_64 %ix86 %arm ppc ppc64
30 %define atomic_arch x86_64 %ix86 %arm ppc ppc64 s390 s390x
31
32 # We don't want to build java
33 %define build_java 0
34 %define build_libjava 0
35
36 %define build_cp 1
37 %define build_fortran !0%{?building_libjava:1}%{?building_libffi:1}
38 %define build_objc !0%{?building_libjava:1}%{?building_libffi:1}
39 %define build_objcp !0%{?building_libjava:1}%{?building_libffi:1}
40 %define build_with_mudflap 0
41
42 %if %{build_objcp}
43 %define build_cp 1
44 %define build_objc 1
45 %endif
46
47 %if %{build_libjava}
48 %define build_cp 1
49 %endif
50
51 # For optional compilers only build C, C++ and Fortran
52 %if 0%{?build_optional_compiler_languages:1}
53 %define build_ada 0
54 %define build_java 0
55 %define build_libjava 0
56 %define build_objc 0
57 %define build_objcp 0
58 %endif
59
60 # Shared library SONAME versions
61 %define libgcc_s 1
62 %define libgcj_sover %{nil}
63 %define libgcj_bc_sover %{nil}
64 %define libffi_sover %{nil}
65 %define libmudflap_sover %{nil}
66 %define libgomp_sover %{nil}
67 %define libstdcxx_sover %{nil}
68 %define libobjc_sover %{nil}
69 %define libgfortran_sover %{nil}
70 %define libquadmath_sover %{nil}
71 %define libasan_sover %{nil}
72 %define libtsan_sover %{nil}
73 %define libatomic_sover %{nil}
74 %define libitm_sover %{nil}
75
76 # Shared library package suffix
77 # This is used for the "non-standard" set of libraries, the standard
78 # being defined by %product_libs_gcc_ver, the GCC version that should
79 # provide un-suffixed shared library packages following the shared-library
80 # policy.  Even suffixed variants should provide the shared-library policy
81 # mandated names and ensure they conflict with each other.
82 # Note that on SONAME changes of any library the %product_libs_gcc_ver
83 # define needs to be either split or the newest GCC version still providing
84 # the old SONAME needs to unconditionally produce an un-suffixed library
85 # if %product_libs_gcc_ver is newer than it.  Similar the _oldest_ GCC
86 # version first providing a new SONAME needs to unconditionally produce
87 # an un-suffixed library if %product_libs_gcc_ver is lower that it.
88 %if %{!?product_libs_gcc_ver:48}%{?product_libs_gcc_ver} != 48
89 %define pne 1
90 %endif
91 %define libgcc_s_suffix %{?pne:-gcc48}
92 # libgcj SONAME changes with every GCC version
93 %define libgcj_suffix %nil
94 %define libgcj_bc_suffix %{?pne:-gcc48}
95 %define libffi_suffix %{?pne:-gcc48}
96 %define libmudflap_suffix %{?pne:-gcc48}
97 %define libgomp_suffix %{?pne:-gcc48}
98 %define libstdcxx_suffix %{?pne:-gcc48}
99 %define libobjc_suffix %{?pne:-gcc48}
100 %define libgfortran_suffix %{?pne:-gcc48}
101 %define libquadmath_suffix %{?pne:-gcc48}
102 %define libasan_suffix %{?pne:-gcc48}
103 %define libtsan_suffix %{?pne:-gcc48}
104 %define libatomic_suffix %{?pne:-gcc48}
105 %define libitm_suffix %{?pne:-gcc48}
106
107
108
109
110 Name: gcc48-testresults
111 BuildRequires: gcc-c++
112 BuildRequires: bison
113 BuildRequires: flex
114 BuildRequires: glibc-devel-32bit
115 BuildRequires: mpc-devel
116 BuildRequires: mpfr-devel
117 BuildRequires: perl
118 BuildRequires: makeinfo
119 BuildRequires: zlib-devel
120 %ifarch %ix86 x86_64 ppc ppc64 s390 s390x ia64 %sparc hppa %arm
121 BuildRequires: cloog-isl-devel
122 BuildRequires: isl-devel
123 %endif
124 %if %{build_ada}
125 %define hostsuffix -4.7
126 BuildRequires: gcc47-ada
127 %endif
128 %if 0%{?building_libjava:1}%{?building_testsuite:1}
129 BuildRequires: fastjar
130 %endif
131 %if 0%{?building_libffi:1}
132 BuildRequires: pkg-config
133 %endif
134 %ifarch ia64
135 BuildRequires: libunwind-devel
136 %endif
137 %if 0%{?run_tests:1}
138 BuildRequires: dejagnu
139 BuildRequires: expect
140 BuildRequires: gdb
141 %endif
142
143 %define separate_bi32 0
144 %define separate_bi64 0
145 %ifarch ppc sparcv9
146 # Beware, this does _not_ separate libgcj, as for that one multilibing
147 # is inactive for the time being
148 %define separate_bi64 1
149 %endif
150 %ifarch x86_64 s390x ppc64 sparc64
151 %define separate_bi32 1
152 %endif
153
154 # Define two macros to trigger -32bit or -64bit package variants
155 %define separate_biarch 0
156 %if %{separate_bi32}
157 %define separate_biarch 1
158 %define separate_biarch_suffix -32bit
159 %endif
160 %if %{separate_bi64}
161 %define separate_biarch 1
162 %define separate_biarch_suffix -64bit
163 %endif
164
165 %ifarch x86_64 ia64 s390x alpha ppc64 sparc64
166 # 64-bit is primary build target
167 %define build_primary_64bit 1
168 %else
169 %define build_primary_64bit 0
170 %endif
171
172 %define biarch_libjava 0
173
174 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
175
176 URL:          http://gcc.gnu.org/
177 Version: 4.8.1
178 Release:      1
179 %define gcc_version %(echo %version | sed 's/_.*//')
180 %define gcc_dir_version %(echo %gcc_version | cut -d '.' -f 1-2)
181 %define snapshot_date %(echo %version | sed 's/[34]\.[0-9]\.[0-6]//' | sed 's/_/-/')
182 %define binsuffix -4.8
183
184 %if !0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
185 Requires: binutils glibc-devel
186 Requires: cpp48 = %{version}-%{release}
187 Requires: libgcc_s%{libgcc_s} >= %{version}-%{release}
188 Requires: libgomp%{libgomp_sover} >= %{version}-%{release}
189 %if %{build_with_mudflap}
190 Requires: libmudflap%{libmudflap_sover} >= %{version}-%{release}
191 Requires: libmudflapth%{libmudflap_sover} >= %{version}-%{release}
192 %endif
193 %ifarch %asan_arch
194 Requires: libasan%{libasan_sover} >= %{version}-%{release}
195 %endif
196 %ifarch %tsan_arch
197 Requires: libtsan%{libtsan_sover} >= %{version}-%{release}
198 %endif
199 %ifarch %atomic_arch
200 Requires: libatomic%{libatomic_sover} >= %{version}-%{release}
201 %endif
202 %ifarch %itm_arch
203 Requires: libitm%{libitm_sover} >= %{version}-%{release}
204 %endif
205 Suggests: gcc48-info gcc48-locale
206 %endif
207
208 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
209 Source:         gcc-%{version}.tar.bz2
210 Source1:        change_spec
211 Source3:        gcc48-rpmlintrc
212 Source4:        ecj.jar
213 Source6:        baselibs.conf
214
215
216 Summary:      Testsuite results
217 License:        SUSE-Public-Domain
218
219 %description 
220 Results from running the gcc and target library testsuites.
221
222
223
224 # Define the canonical target and host architecture
225 #   %gcc_target_arch  is supposed to be the full target triple
226 #   %TARGET_ARCH      is the canonicalized CPU part
227 #   %CONFIGURE_TARGET is the target triple used for --target=
228 %if 0%{?gcc_target_arch:1}
229 %define CONFIGURE_TARGET %{gcc_target_arch}
230 %define TARGET_ARCH %(echo %{gcc_target_arch} | cut -d - -f 1 | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
231 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "powerpc"
232 %define CONFIGURE_TARGET powerpc64-tizen-linux
233 %endif
234 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "powerpc64"
235 %define CONFIGURE_TARGET powerpc64-tizen-linux
236 %endif
237 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "i586"
238 %define CONFIGURE_TARGET i586-tizen-linux
239 %endif
240 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7l"
241 %define CONFIGURE_TARGET armv7l-tizen-linux-gnueabi
242 %endif
243 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7hl"
244 %define CONFIGURE_TARGET armv7hl-tizen-linux-gnueabi
245 %endif
246 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv5tel"
247 %define CONFIGURE_TARGET armv5tel-tizen-linux-gnueabi
248 %endif
249 %else
250 %define TARGET_ARCH %(echo %{_target_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
251 %endif
252 %define HOST_ARCH %(echo %{_host_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
253
254 %define biarch %(case " %{biarch_targets} " in (*" %{TARGET_ARCH} "*) echo 1;; (*) echo 0;; esac)
255
256 %ifarch ppc
257 %define GCCDIST powerpc64-tizen-linux
258 %else
259 %ifarch %sparc
260 %define GCCDIST sparc64-tizen-linux
261 %else
262 %ifarch %arm
263 %define GCCDIST %{HOST_ARCH}-tizen-linux-gnueabi
264 %else
265 %define GCCDIST %{HOST_ARCH}-tizen-linux
266 %endif
267 %endif
268 %endif
269
270 %define libsubdir %{_libdir}/gcc/%{GCCDIST}/%{gcc_dir_version}
271 %define gxxinclude %{_prefix}/include/c++/%{gcc_dir_version}
272
273
274 # Versionspecific directories
275 %define versmainlibdir %{libsubdir}
276 %define versmainlibdirbi32 %{libsubdir}/32
277 %define versmainlibdirbi64 %{libsubdir}/64
278 %ifarch ppc
279 %define versmainlibdirbi32 %{libsubdir}
280 %define versmainlibdirbi64 %{libsubdir}/64
281 %endif
282 %if %{build_primary_64bit}
283 %define versmainlibdirbi %{versmainlibdirbi32}
284 %else
285 %define versmainlibdirbi %{versmainlibdirbi64}
286 %endif
287
288 %define mainlibdir %{_libdir}
289 %define mainlibdirbi32 %{_prefix}/lib
290 %define mainlibdirbi64 %{_prefix}/lib64
291 %if %{build_primary_64bit}
292 %define mainlibdirbi %{mainlibdirbi32}
293 %else
294 %define mainlibdirbi %{mainlibdirbi64}
295 %endif
296
297
298 # Now define a few macros that make it easy to package libs and
299 # related files just to the right package, without caring for the
300 # exact path the files are in.
301 #   %mainlib  package X from all dirs that belong to the main package
302 #   %biarchlib   package X from all dirs that belong to the -32/64bit package
303 %define mainlib() %{mainlibdir}/%1\
304 %{nil}
305 %define biarchlib() %{nil}
306 %if %{biarch}
307 %if !%{separate_biarch}
308 %define mainlib() %{mainlibdir}/%1\
309 %{mainlibdirbi}/%1\
310 %{nil}
311 %else
312 %define biarchlib() %{mainlibdirbi}/%1\
313 %{nil}
314 %endif
315 %endif
316
317 %define versmainlib() %{versmainlibdir}/%1\
318 %{nil}
319 %define versbiarchlib() %{nil}
320 %if %{biarch}
321 %if !%{separate_biarch}
322 %define versmainlib() %{versmainlibdir}/%1\
323 %{versmainlibdirbi}/%1\
324 %{nil}
325 %else
326 %define versbiarchlib() %{versmainlibdirbi}/%1\
327 %{nil}
328 %endif
329 %endif
330
331
332
333 %prep
334 %setup -q -n gcc-%{version}
335
336
337 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
338 # the libstdc++ abi testsuite baseline files accordingly
339 %ifarch ppc
340 if [ -d libstdc++-v3/config/abi/post/powerpc64-linux-gnu ]; then
341   mkdir -p libstdc++-v3/config/abi/post/powerpc64-linux-gnu/64
342   mv libstdc++-v3/config/abi/post/powerpc64-linux-gnu/baseline_symbols.txt \
343         libstdc++-v3/config/abi/post/powerpc64-linux-gnu/64/
344   mv libstdc++-v3/config/abi/post/powerpc64-linux-gnu/32/baseline_symbols.txt \
345         libstdc++-v3/config/abi/post/powerpc64-linux-gnu/
346 fi
347 %endif
348
349 %build
350 # Avoid rebuilding of generated files
351 contrib/gcc_update --touch
352 # Avoid fucking up testsuite results with Java and indirect dispatch
353 export LD_AS_NEEDED=0
354 # Split version file into version used for directories (X.Y) and
355 # version to report with --version (X.Y.Z).
356 # See also gcc-dir-version.patch.
357 # Also decrement the patchlevel version by one
358 if test `cat gcc/DEV-PHASE` == "prerelease"; then
359   ( cat gcc/BASE-VER | cut -d '.' -f 1-2 | tr -d '\n'; echo -n .; cat gcc/BASE-VER | cut -d '.' -f 3 | tr '0123456789' '0012345678' ) > gcc/FULL-VER
360 else
361   mv gcc/BASE-VER gcc/FULL-VER
362 fi
363 cat gcc/FULL-VER | cut -d '.' -f 1-2 > gcc/BASE-VER
364
365 rm -rf obj-%{GCCDIST}
366 mkdir obj-%{GCCDIST}
367 cd obj-%{GCCDIST}
368 RPM_OPT_FLAGS="$RPM_OPT_FLAGS -U_FORTIFY_SOURCE"
369 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fno-rtti//g' -e 's/-fno-exceptions//g' -e 's/-Wmissing-format-attribute//g' -e 's/-fstack-protector//g' -e 's/-ffortify=.//g' -e 's/-Wall//g' -e 's/-m32//g' -e 's/-m64//g'`
370 %ifarch %ix86
371 # -mcpu is superceded by -mtune but -mtune is not supported by
372 # our bootstrap compiler.  -mcpu gives a warning that stops
373 # the build process, so remove it for now.  Also remove all other
374 # -march and -mtune flags.  They are superseeded by proper
375 # default compiler settings now.
376 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-mcpu=i.86//g' -e 's/-march=i.86//g' -e 's/-mtune=i.86//g'`
377 %endif
378 %ifarch s390 s390x
379 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fsigned-char//g'`
380 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-O1/-O2/g'`
381 %endif
382 %if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
383 # Kill all -march/tune/cpu because that screws building the target libs
384 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-m\(arch\|tune\|cpu\)=[^ ]*//g'`
385 %endif
386 # Replace 2 spaces by one finally
387 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/  / /g'`
388
389 languages=c
390 %if %{build_cp}
391 languages=$languages,c++
392 %endif
393 %if %{build_objc}
394 languages=$languages,objc
395 %endif
396 %if %{build_fortran}
397 languages=$languages,fortran
398 %endif
399 %if %{build_objcp}
400 languages=$languages,obj-c++
401 %endif
402 %if %{build_java}
403 languages=$languages,java
404 %endif
405 %if %{build_ada}
406 languages=$languages,ada
407 %endif
408
409 J=%{?jobs:%jobs}
410 if test -z "$J"; then
411   J=$(getconf _NPROCESSORS_CONF)
412   JL=$(($J * 2))
413 else
414   test 1 -gt "$J" && J=1
415   JL=$(($(getconf _NPROCESSORS_CONF)*2))
416 fi
417 if test "$J" == "0"; then
418   J=1
419 fi
420 if test "$JL" == "0"; then
421   JL=1
422 fi
423 PARALLEL="-j$J -l$JL"
424
425 # we don't want some miscompiles in the testsuite, or some fault in
426 # the compiler to kill the machine.  Hence we limit the amount of memory
427 # by the physical RAM plus half of swap
428 #MEM=$(free -m | awk '/^Mem:/ {print $2}')
429 #SWAP=$(free -m | awk '/^Swap:/ {print $2}')
430 #ulimit -v $(((MEM + SWAP/2)*1024))
431
432 # In general we want to ship release checking enabled compilers
433 # and run BETA with checking enabled.
434 #ENABLE_CHECKING="--enable-checking=yes"
435 ENABLE_CHECKING="--enable-checking=release"
436
437 # Work around tail/head -1 changes
438 export _POSIX2_VERSION=199209
439
440 # configure tries to parse include/features.h to detect
441 # if glibc supports SSP.  When cross compiling we would need
442 # to install a cross glibc, which we don't, or make the whole
443 # thing point to the native glibc, which is in /, hence the
444 # --with-build-sysroot=/
445
446 %if %{build_ada}
447 # Using the host gnatmake like
448 #   CC="gcc%{hostsuffix}" GNATBIND="gnatbind%{hostsuffix}"
449 #   GNATMAKE="gnatmake%{hostsuffix}"
450 # doesn't work due to PR33857, so an un-suffixed gnatmake has to be
451 # available
452 mkdir -p host-tools/bin
453 cp -a /usr/bin/gnatmake%{hostsuffix} host-tools/bin/gnatmake
454 cp -a /usr/bin/gnatlink%{hostsuffix} host-tools/bin/gnatlink
455 cp -a /usr/bin/gnatbind%{hostsuffix} host-tools/bin/gnatbind
456 cp -a /usr/bin/gcc%{hostsuffix} host-tools/bin/gcc
457 ln -sf /usr/%{_lib} host-tools/%{_lib}
458 export PATH="`pwd`/host-tools/bin:$PATH"
459 %endif
460 #%if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
461 #%else
462 #       --enable-threads=posix \
463 #%endif
464 #       --enable-shared \
465 %if "%{TARGET_ARCH}" == "armv7l" || "%{TARGET_ARCH}" == "armv7hl"
466 # temporary workaround for a miscompilation of hash functions in java code
467 GCJ_EXTRA_FLAGS="-marm"
468 %endif
469 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" XCFLAGS="$RPM_OPT_FLAGS" \
470 TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
471 ../configure \
472         --prefix=%{_prefix} \
473         --infodir=%{_infodir} \
474         --mandir=%{_mandir} \
475         --libdir=%{_libdir} \
476         --libexecdir=%{_libdir} \
477     --disable-bootstrap \
478         --enable-languages=$languages \
479         $ENABLE_CHECKING \
480         --with-gxx-include-dir=%{_prefix}/include/c++/%{gcc_dir_version} \
481         --enable-ssp \
482         --disable-libssp \
483         --disable-plugin \
484         --with-bugurl="http://bugs.tizen.org/" \
485         --with-pkgversion="Tizen" \
486 %if !%{build_libjava}
487         --disable-libgcj \
488 %else
489         --with-java-home=%{_libdir}/jvm/java-1.5.0-gcj%{binsuffix}-1.5.0.0/jre \
490         --with-ecj-jar=%{libsubdir}/ecj.jar \
491         --disable-java-awt \
492 %if !%{biarch_libjava}
493         --disable-libjava-multilib \
494 %endif
495 %endif
496 %if !%{build_with_mudflap}
497         --disable-libmudflap \
498 %endif
499         --with-slibdir=/%{_lib} \
500         --with-system-zlib \
501         --enable-__cxa_atexit \
502         --enable-libstdcxx-allocator=new \
503         --disable-libstdcxx-pch \
504         --enable-version-specific-runtime-libs \
505         --enable-linker-build-id \
506 %if 0%{?gcc_target_arch:1}
507 %if 0%{?gcc_icecream:1}
508         --with-build-sysroot=/ \
509         --with-sysroot=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi} \
510         --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/usr/include/c++/%{gcc_dir_version} \
511         --enable-linux-futex \
512 %endif
513 %if 0%{?canonical_target:1}
514         --with-build-time-tools=/usr/%{canonical_target}-tizen-linux%{?canonical_target_abi:%canonical_target_abi}/bin \
515 %endif
516 %if 0%{?sysroot:1}
517         --with-sysroot=%sysroot \
518 %endif
519 %if 0%{?build_static:1}
520         --disable-shared \
521 %endif
522 %if "%{TARGET_ARCH}" == "spu"
523         --with-gxx-include-dir=%sysroot/include/c++/%{gcc_dir_version} \
524         --with-newlib \
525 %endif
526         --disable-nls \
527         --target=%{CONFIGURE_TARGET} \
528 %else
529         --program-suffix=%{binsuffix} \
530         --enable-linux-futex \
531 %ifarch ia64
532         --with-system-libunwind \
533 %else
534         --without-system-libunwind \
535 %endif
536 %endif
537 %if "%{TARGET_ARCH}" == "armv5tel"
538         --with-arch=armv5te \
539         --with-float=soft \
540         --with-mode=arm \
541         --with-abi=aapcs-linux \
542         --disable-sjlj-exceptions \
543 %endif
544 %if "%{TARGET_ARCH}" == "armv7l" 
545         --with-arch=armv7-a \
546         --with-tune=cortex-a9 \
547     --with-float=soft \
548         --with-fpu=vfpv3-d16 \
549         --disable-sjlj-exceptions \
550 %endif
551 %if  "%{TARGET_ARCH}" == "armv7hl"
552         --with-arch=armv7-a \
553         --with-tune=cortex-a9 \
554         --with-float=hard \
555         --with-abi=aapcs-linux \
556         --with-fpu=vfpv3-d16 \
557         --disable-sjlj-exceptions \
558 %endif
559 %if "%{TARGET_ARCH}" == "powerpc" || "%{TARGET_ARCH}" == "powerpc64"
560 %if "%{TARGET_ARCH}" == "powerpc"
561         --with-cpu=default32 \
562 %endif
563         --with-cpu-64=power4 \
564         --enable-secureplt \
565         --with-long-double-128 \
566 %endif
567 %if "%{TARGET_ARCH}" == "sparc64"
568         --with-cpu=ultrasparc \
569         --with-long-double-128 \
570 %endif
571 %if "%{TARGET_ARCH}" == "sparc"
572         --with-cpu=v8 \
573         --with-long-double-128 \
574 %endif
575 %if "%{TARGET_ARCH}" == "i586"
576         --with-arch-32=i586 \
577         --with-tune=generic \
578 %endif
579 %if "%{TARGET_ARCH}" == "x86_64"
580         --with-arch-32=i586 \
581         --with-tune=generic \
582 %endif
583 %if "%{TARGET_ARCH}" == "s390"
584         --with-tune=z196 --with-arch=z10 \
585         --with-long-double-128 \
586         --enable-decimal-float \
587 %endif
588 %if "%{TARGET_ARCH}" == "s390x"
589         --with-tune=z196 --with-arch=z10 \
590         --with-long-double-128 \
591         --enable-decimal-float \
592 %endif
593         --build=%{GCCDIST}
594
595
596 %if 0%{?building_libffi:1}
597 make stage1-bubble $PARALLEL
598 make all-target-libffi $PARALLEL
599 %else
600 STAGE1_FLAGS="-g"
601 # Only run profiled bootstrap on archs where it works
602 #%ifarch %ix86 x86_64 ppc ppc64 ia64
603 #make profiledbootstrap-lean STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
604 #%else
605 #make bootstrap-lean STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
606 make STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
607 #%endif
608 #make -C gcc proto
609 make info
610 %if 0%{?run_tests:1}
611 echo "Run testsuite"
612 (make -C %{GCCDIST}/libstdc++-v3 check-abi || true)
613 mv %{GCCDIST}/libstdc++-v3/testsuite/libstdc++.log %{GCCDIST}/libstdc++-v3/testsuite/libstdc++-abi.log
614 mv %{GCCDIST}/libstdc++-v3/testsuite/libstdc++.sum %{GCCDIST}/libstdc++-v3/testsuite/libstdc++-abi.sum
615 # asan needs a whole shadow address space
616 ulimit -v unlimited || true
617 make -k check $PARALLEL || true
618 mkdir ../testresults
619 ../contrib/test_summary | tee ../testresults/test_summary.txt
620 %endif
621 %endif
622
623 %install
624 export NO_BRP_CHECK_BYTECODE_VERSION=true
625 cd obj-%{GCCDIST}
626 %if 0%{?run_tests:1} 
627 cp `find . -name "*.sum"` ../testresults/
628 cp `find . -name "*.log"  \! -name "config.log" | grep -v 'acats.\?/tests' ` ../testresults/
629 chmod 644 ../testresults/*
630 %endif
631
632 %if 0%{?run_tests:1}
633 %files 
634 %defattr(-,root,root)
635 %doc testresults/test_summary.txt
636 %doc testresults/*.sum
637 %doc testresults/*.log
638 %endif
639
640
641 %changelog