e62b0b6aad8da7f3d25a11b3378560f2ee73560d
[platform/upstream/gcc48.git] / packaging / gcc48-testresults.spec
1 %define building_testsuite 1
2 %define run_tests 1
3 #
4 # spec file for package gcc48
5 #
6 # Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
7 #
8 # All modifications and additions to the file contributed by third parties
9 # remain the property of their copyright owners, unless otherwise agreed
10 # upon. The license for this file, and modifications and additions to the
11 # file, is the same license as for the pristine package itself (unless the
12 # license for the pristine package is not an Open Source License, in which
13 # case the license is the MIT License). An "Open Source License" is a
14 # license that conforms to the Open Source Definition (Version 1.9)
15 # published by the Open Source Initiative.
16
17 # Please submit bugfixes or comments via http://bugs.opensuse.org/
18 #
19
20 # norootforbuild
21 # icecream 0
22
23
24 %define build_ada 0
25
26 %define quadmath_arch %ix86 x86_64 ia64
27 %define tsan_arch x86_64
28 %define asan_arch x86_64 %ix86 ppc ppc64
29 %define itm_arch x86_64 %ix86 %arm ppc ppc64
30 %define atomic_arch x86_64 %ix86 %arm ppc ppc64 s390 s390x
31
32 # We don't want to build java
33 %define build_java 0
34 %define build_libjava 0
35
36 %define build_cp 1
37 %define build_fortran !0%{?building_libjava:1}%{?building_libffi:1}
38 %define build_objc !0%{?building_libjava:1}%{?building_libffi:1}
39 %define build_objcp !0%{?building_libjava:1}%{?building_libffi:1}
40 %define build_with_mudflap 0
41
42 %if %{build_objcp}
43 %define build_cp 1
44 %define build_objc 1
45 %endif
46
47 %if %{build_libjava}
48 %define build_cp 1
49 %endif
50
51 # For optional compilers only build C, C++ and Fortran
52 %if 0%{?build_optional_compiler_languages:1}
53 %define build_ada 0
54 %define build_java 0
55 %define build_libjava 0
56 %define build_objc 0
57 %define build_objcp 0
58 %endif
59
60 # Shared library SONAME versions
61 %define libgcc_s 1
62 %define libgcj_sover %{nil}
63 %define libgcj_bc_sover %{nil}
64 %define libffi_sover %{nil}
65 %define libmudflap_sover %{nil}
66 %define libgomp_sover %{nil}
67 %define libstdcxx_sover %{nil}
68 %define libobjc_sover %{nil}
69 %define libgfortran_sover %{nil}
70 %define libquadmath_sover %{nil}
71 %define libasan_sover %{nil}
72 %define libtsan_sover %{nil}
73 %define libatomic_sover %{nil}
74 %define libitm_sover %{nil}
75
76 # Shared library package suffix
77 # This is used for the "non-standard" set of libraries, the standard
78 # being defined by %product_libs_gcc_ver, the GCC version that should
79 # provide un-suffixed shared library packages following the shared-library
80 # policy.  Even suffixed variants should provide the shared-library policy
81 # mandated names and ensure they conflict with each other.
82 # Note that on SONAME changes of any library the %product_libs_gcc_ver
83 # define needs to be either split or the newest GCC version still providing
84 # the old SONAME needs to unconditionally produce an un-suffixed library
85 # if %product_libs_gcc_ver is newer than it.  Similar the _oldest_ GCC
86 # version first providing a new SONAME needs to unconditionally produce
87 # an un-suffixed library if %product_libs_gcc_ver is lower that it.
88 %if %{!?product_libs_gcc_ver:48}%{?product_libs_gcc_ver} != 48
89 %define pne 1
90 %endif
91 %define libgcc_s_suffix %{?pne:-gcc48}
92 # libgcj SONAME changes with every GCC version
93 %define libgcj_suffix %nil
94 %define libgcj_bc_suffix %{?pne:-gcc48}
95 %define libffi_suffix %{?pne:-gcc48}
96 %define libmudflap_suffix %{?pne:-gcc48}
97 %define libgomp_suffix %{?pne:-gcc48}
98 %define libstdcxx_suffix %{?pne:-gcc48}
99 %define libobjc_suffix %{?pne:-gcc48}
100 %define libgfortran_suffix %{?pne:-gcc48}
101 %define libquadmath_suffix %{?pne:-gcc48}
102 %define libasan_suffix %{?pne:-gcc48}
103 %define libtsan_suffix %{?pne:-gcc48}
104 %define libatomic_suffix %{?pne:-gcc48}
105 %define libitm_suffix %{?pne:-gcc48}
106
107
108
109
110 Name: gcc48-testresults
111 BuildRequires: gcc-c++
112 BuildRequires: bison
113 BuildRequires: flex
114 BuildRequires: glibc-devel-32bit
115 BuildRequires: mpc-devel
116 BuildRequires: mpfr-devel
117 BuildRequires: perl
118 BuildRequires: makeinfo
119 BuildRequires: zlib-devel
120 %ifarch %ix86 x86_64 ppc ppc64 s390 s390x ia64 %sparc hppa %arm
121 BuildRequires: cloog-isl-devel
122 BuildRequires: isl-devel
123 %endif
124 %if %{build_ada}
125 %define hostsuffix -4.7
126 BuildRequires: gcc47-ada
127 %endif
128 %if 0%{?building_libjava:1}%{?building_testsuite:1}
129 BuildRequires: fastjar
130 %endif
131 %if 0%{?building_libffi:1}
132 BuildRequires: pkg-config
133 %endif
134 %ifarch ia64
135 BuildRequires: libunwind-devel
136 %endif
137 %if 0%{?run_tests:1}
138 BuildRequires: dejagnu
139 BuildRequires: expect
140 BuildRequires: gdb
141 %endif
142
143 %define separate_bi32 0
144 %define separate_bi64 0
145 %ifarch ppc sparcv9
146 # Beware, this does _not_ separate libgcj, as for that one multilibing
147 # is inactive for the time being
148 %define separate_bi64 1
149 %endif
150 %ifarch x86_64 s390x ppc64 sparc64
151 %define separate_bi32 1
152 %endif
153
154 # Define two macros to trigger -32bit or -64bit package variants
155 %define separate_biarch 0
156 %if %{separate_bi32}
157 %define separate_biarch 1
158 %define separate_biarch_suffix -32bit
159 %endif
160 %if %{separate_bi64}
161 %define separate_biarch 1
162 %define separate_biarch_suffix -64bit
163 %endif
164
165 %ifarch x86_64 ia64 s390x alpha ppc64 sparc64
166 # 64-bit is primary build target
167 %define build_primary_64bit 1
168 %else
169 %define build_primary_64bit 0
170 %endif
171
172 %define biarch_libjava 0
173
174 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
175
176 URL:          http://gcc.gnu.org/
177 Version: 4.8.1
178 Release:      1
179 %define gcc_version %(echo %version | sed 's/_.*//')
180 %define gcc_dir_version %(echo %gcc_version | cut -d '.' -f 1-2)
181 %define snapshot_date %(echo %version | sed 's/[34]\.[0-9]\.[0-6]//' | sed 's/_/-/')
182 %define binsuffix -4.8
183
184 %if !0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
185 Requires: binutils glibc-devel
186 Requires: cpp48 = %{version}-%{release}
187 Requires: libgcc_s%{libgcc_s} >= %{version}-%{release}
188 Requires: libgomp%{libgomp_sover} >= %{version}-%{release}
189 %if %{build_with_mudflap}
190 Requires: libmudflap%{libmudflap_sover} >= %{version}-%{release}
191 Requires: libmudflapth%{libmudflap_sover} >= %{version}-%{release}
192 %endif
193 %ifarch %asan_arch
194 Requires: libasan%{libasan_sover} >= %{version}-%{release}
195 %endif
196 %ifarch %tsan_arch
197 Requires: libtsan%{libtsan_sover} >= %{version}-%{release}
198 %endif
199 %ifarch %atomic_arch
200 Requires: libatomic%{libatomic_sover} >= %{version}-%{release}
201 %endif
202 %ifarch %itm_arch
203 Requires: libitm%{libitm_sover} >= %{version}-%{release}
204 %endif
205 Suggests: gcc48-info gcc48-locale
206 %endif
207
208 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
209 Source:         gcc-%{version}.tar.bz2
210 Source1:        change_spec
211 Source3:        gcc48-rpmlintrc
212 Source4:        ecj.jar
213 Source6:        baselibs.conf
214
215
216 Summary:      Testsuite results
217 License:        SUSE-Public-Domain
218 Group:        Development/Languages/C and C++
219
220 %description 
221 Results from running the gcc and target library testsuites.
222
223
224
225 # Define the canonical target and host architecture
226 #   %gcc_target_arch  is supposed to be the full target triple
227 #   %TARGET_ARCH      is the canonicalized CPU part
228 #   %CONFIGURE_TARGET is the target triple used for --target=
229 %if 0%{?gcc_target_arch:1}
230 %define CONFIGURE_TARGET %{gcc_target_arch}
231 %define TARGET_ARCH %(echo %{gcc_target_arch} | cut -d - -f 1 | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
232 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "powerpc"
233 %define CONFIGURE_TARGET powerpc64-tizen-linux
234 %endif
235 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "powerpc64"
236 %define CONFIGURE_TARGET powerpc64-tizen-linux
237 %endif
238 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "i586"
239 %define CONFIGURE_TARGET i586-tizen-linux
240 %endif
241 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7l"
242 %define CONFIGURE_TARGET armv7l-tizen-linux-gnueabi
243 %endif
244 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7hl"
245 %define CONFIGURE_TARGET armv7hl-tizen-linux-gnueabi
246 %endif
247 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv5tel"
248 %define CONFIGURE_TARGET armv5tel-tizen-linux-gnueabi
249 %endif
250 %else
251 %define TARGET_ARCH %(echo %{_target_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
252 %endif
253 %define HOST_ARCH %(echo %{_host_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
254
255 %define biarch %(case " %{biarch_targets} " in (*" %{TARGET_ARCH} "*) echo 1;; (*) echo 0;; esac)
256
257 %ifarch ppc
258 %define GCCDIST powerpc64-tizen-linux
259 %else
260 %ifarch %sparc
261 %define GCCDIST sparc64-tizen-linux
262 %else
263 %ifarch %arm
264 %define GCCDIST %{HOST_ARCH}-tizen-linux-gnueabi
265 %else
266 %define GCCDIST %{HOST_ARCH}-tizen-linux
267 %endif
268 %endif
269 %endif
270
271 %define libsubdir %{_libdir}/gcc/%{GCCDIST}/%{gcc_dir_version}
272 %define gxxinclude %{_prefix}/include/c++/%{gcc_dir_version}
273
274
275 # Versionspecific directories
276 %define versmainlibdir %{libsubdir}
277 %define versmainlibdirbi32 %{libsubdir}/32
278 %define versmainlibdirbi64 %{libsubdir}/64
279 %ifarch ppc
280 %define versmainlibdirbi32 %{libsubdir}
281 %define versmainlibdirbi64 %{libsubdir}/64
282 %endif
283 %if %{build_primary_64bit}
284 %define versmainlibdirbi %{versmainlibdirbi32}
285 %else
286 %define versmainlibdirbi %{versmainlibdirbi64}
287 %endif
288
289 %define mainlibdir %{_libdir}
290 %define mainlibdirbi32 %{_prefix}/lib
291 %define mainlibdirbi64 %{_prefix}/lib64
292 %if %{build_primary_64bit}
293 %define mainlibdirbi %{mainlibdirbi32}
294 %else
295 %define mainlibdirbi %{mainlibdirbi64}
296 %endif
297
298
299 # Now define a few macros that make it easy to package libs and
300 # related files just to the right package, without caring for the
301 # exact path the files are in.
302 #   %mainlib  package X from all dirs that belong to the main package
303 #   %biarchlib   package X from all dirs that belong to the -32/64bit package
304 %define mainlib() %{mainlibdir}/%1\
305 %{nil}
306 %define biarchlib() %{nil}
307 %if %{biarch}
308 %if !%{separate_biarch}
309 %define mainlib() %{mainlibdir}/%1\
310 %{mainlibdirbi}/%1\
311 %{nil}
312 %else
313 %define biarchlib() %{mainlibdirbi}/%1\
314 %{nil}
315 %endif
316 %endif
317
318 %define versmainlib() %{versmainlibdir}/%1\
319 %{nil}
320 %define versbiarchlib() %{nil}
321 %if %{biarch}
322 %if !%{separate_biarch}
323 %define versmainlib() %{versmainlibdir}/%1\
324 %{versmainlibdirbi}/%1\
325 %{nil}
326 %else
327 %define versbiarchlib() %{versmainlibdirbi}/%1\
328 %{nil}
329 %endif
330 %endif
331
332
333
334 %prep
335 %setup -q -n gcc-%{version}
336
337
338 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
339 # the libstdc++ abi testsuite baseline files accordingly
340 %ifarch ppc
341 if [ -d libstdc++-v3/config/abi/post/powerpc64-linux-gnu ]; then
342   mkdir -p libstdc++-v3/config/abi/post/powerpc64-linux-gnu/64
343   mv libstdc++-v3/config/abi/post/powerpc64-linux-gnu/baseline_symbols.txt \
344         libstdc++-v3/config/abi/post/powerpc64-linux-gnu/64/
345   mv libstdc++-v3/config/abi/post/powerpc64-linux-gnu/32/baseline_symbols.txt \
346         libstdc++-v3/config/abi/post/powerpc64-linux-gnu/
347 fi
348 %endif
349
350 %build
351 # Avoid rebuilding of generated files
352 contrib/gcc_update --touch
353 # Avoid fucking up testsuite results with Java and indirect dispatch
354 export LD_AS_NEEDED=0
355 # Split version file into version used for directories (X.Y) and
356 # version to report with --version (X.Y.Z).
357 # See also gcc-dir-version.patch.
358 # Also decrement the patchlevel version by one
359 if test `cat gcc/DEV-PHASE` == "prerelease"; then
360   ( cat gcc/BASE-VER | cut -d '.' -f 1-2 | tr -d '\n'; echo -n .; cat gcc/BASE-VER | cut -d '.' -f 3 | tr '0123456789' '0012345678' ) > gcc/FULL-VER
361 else
362   mv gcc/BASE-VER gcc/FULL-VER
363 fi
364 cat gcc/FULL-VER | cut -d '.' -f 1-2 > gcc/BASE-VER
365
366 rm -rf obj-%{GCCDIST}
367 mkdir obj-%{GCCDIST}
368 cd obj-%{GCCDIST}
369 RPM_OPT_FLAGS="$RPM_OPT_FLAGS -U_FORTIFY_SOURCE"
370 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fno-rtti//g' -e 's/-fno-exceptions//g' -e 's/-Wmissing-format-attribute//g' -e 's/-fstack-protector//g' -e 's/-ffortify=.//g' -e 's/-Wall//g' -e 's/-m32//g' -e 's/-m64//g'`
371 %ifarch %ix86
372 # -mcpu is superceded by -mtune but -mtune is not supported by
373 # our bootstrap compiler.  -mcpu gives a warning that stops
374 # the build process, so remove it for now.  Also remove all other
375 # -march and -mtune flags.  They are superseeded by proper
376 # default compiler settings now.
377 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-mcpu=i.86//g' -e 's/-march=i.86//g' -e 's/-mtune=i.86//g'`
378 %endif
379 %ifarch s390 s390x
380 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fsigned-char//g'`
381 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-O1/-O2/g'`
382 %endif
383 %if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
384 # Kill all -march/tune/cpu because that screws building the target libs
385 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-m\(arch\|tune\|cpu\)=[^ ]*//g'`
386 %endif
387 # Replace 2 spaces by one finally
388 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/  / /g'`
389
390 languages=c
391 %if %{build_cp}
392 languages=$languages,c++
393 %endif
394 %if %{build_objc}
395 languages=$languages,objc
396 %endif
397 %if %{build_fortran}
398 languages=$languages,fortran
399 %endif
400 %if %{build_objcp}
401 languages=$languages,obj-c++
402 %endif
403 %if %{build_java}
404 languages=$languages,java
405 %endif
406 %if %{build_ada}
407 languages=$languages,ada
408 %endif
409
410 J=%{?jobs:%jobs}
411 if test -z "$J"; then
412   J=$(getconf _NPROCESSORS_CONF)
413   JL=$(($J * 2))
414 else
415   test 1 -gt "$J" && J=1
416   JL=$(($(getconf _NPROCESSORS_CONF)*2))
417 fi
418 if test "$J" == "0"; then
419   J=1
420 fi
421 if test "$JL" == "0"; then
422   JL=1
423 fi
424 PARALLEL="-j$J -l$JL"
425
426 # we don't want some miscompiles in the testsuite, or some fault in
427 # the compiler to kill the machine.  Hence we limit the amount of memory
428 # by the physical RAM plus half of swap
429 #MEM=$(free -m | awk '/^Mem:/ {print $2}')
430 #SWAP=$(free -m | awk '/^Swap:/ {print $2}')
431 #ulimit -v $(((MEM + SWAP/2)*1024))
432
433 # In general we want to ship release checking enabled compilers
434 # and run BETA with checking enabled.
435 #ENABLE_CHECKING="--enable-checking=yes"
436 ENABLE_CHECKING="--enable-checking=release"
437
438 # Work around tail/head -1 changes
439 export _POSIX2_VERSION=199209
440
441 # configure tries to parse include/features.h to detect
442 # if glibc supports SSP.  When cross compiling we would need
443 # to install a cross glibc, which we don't, or make the whole
444 # thing point to the native glibc, which is in /, hence the
445 # --with-build-sysroot=/
446
447 %if %{build_ada}
448 # Using the host gnatmake like
449 #   CC="gcc%{hostsuffix}" GNATBIND="gnatbind%{hostsuffix}"
450 #   GNATMAKE="gnatmake%{hostsuffix}"
451 # doesn't work due to PR33857, so an un-suffixed gnatmake has to be
452 # available
453 mkdir -p host-tools/bin
454 cp -a /usr/bin/gnatmake%{hostsuffix} host-tools/bin/gnatmake
455 cp -a /usr/bin/gnatlink%{hostsuffix} host-tools/bin/gnatlink
456 cp -a /usr/bin/gnatbind%{hostsuffix} host-tools/bin/gnatbind
457 cp -a /usr/bin/gcc%{hostsuffix} host-tools/bin/gcc
458 ln -sf /usr/%{_lib} host-tools/%{_lib}
459 export PATH="`pwd`/host-tools/bin:$PATH"
460 %endif
461 #%if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
462 #%else
463 #       --enable-threads=posix \
464 #%endif
465 #       --enable-shared \
466 %if "%{TARGET_ARCH}" == "armv7l" || "%{TARGET_ARCH}" == "armv7hl"
467 # temporary workaround for a miscompilation of hash functions in java code
468 GCJ_EXTRA_FLAGS="-marm"
469 %endif
470 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" XCFLAGS="$RPM_OPT_FLAGS" \
471 TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
472 ../configure \
473         --prefix=%{_prefix} \
474         --infodir=%{_infodir} \
475         --mandir=%{_mandir} \
476         --libdir=%{_libdir} \
477         --libexecdir=%{_libdir} \
478     --disable-bootstrap \
479         --enable-languages=$languages \
480         $ENABLE_CHECKING \
481         --with-gxx-include-dir=%{_prefix}/include/c++/%{gcc_dir_version} \
482         --enable-ssp \
483         --disable-libssp \
484         --disable-plugin \
485         --with-bugurl="http://bugs.tizen.org/" \
486         --with-pkgversion="Tizen" \
487 %if !%{build_libjava}
488         --disable-libgcj \
489 %else
490         --with-java-home=%{_libdir}/jvm/java-1.5.0-gcj%{binsuffix}-1.5.0.0/jre \
491         --with-ecj-jar=%{libsubdir}/ecj.jar \
492         --disable-java-awt \
493 %if !%{biarch_libjava}
494         --disable-libjava-multilib \
495 %endif
496 %endif
497 %if !%{build_with_mudflap}
498         --disable-libmudflap \
499 %endif
500         --with-slibdir=/%{_lib} \
501         --with-system-zlib \
502         --enable-__cxa_atexit \
503         --enable-libstdcxx-allocator=new \
504         --disable-libstdcxx-pch \
505         --enable-version-specific-runtime-libs \
506         --enable-linker-build-id \
507 %if 0%{?gcc_target_arch:1}
508 %if 0%{?gcc_icecream:1}
509         --with-build-sysroot=/ \
510         --with-sysroot=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi} \
511         --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/usr/include/c++/%{gcc_dir_version} \
512         --enable-linux-futex \
513 %endif
514 %if 0%{?canonical_target:1}
515         --with-build-time-tools=/usr/%{canonical_target}-tizen-linux%{?canonical_target_abi:%canonical_target_abi}/bin \
516 %endif
517 %if 0%{?sysroot:1}
518         --with-sysroot=%sysroot \
519 %endif
520 %if 0%{?build_static:1}
521         --disable-shared \
522 %endif
523 %if "%{TARGET_ARCH}" == "spu"
524         --with-gxx-include-dir=%sysroot/include/c++/%{gcc_dir_version} \
525         --with-newlib \
526 %endif
527         --disable-nls \
528         --target=%{CONFIGURE_TARGET} \
529 %else
530         --program-suffix=%{binsuffix} \
531         --enable-linux-futex \
532 %ifarch ia64
533         --with-system-libunwind \
534 %else
535         --without-system-libunwind \
536 %endif
537 %endif
538 %if "%{TARGET_ARCH}" == "armv5tel"
539         --with-arch=armv5te \
540         --with-float=soft \
541         --with-mode=arm \
542         --with-abi=aapcs-linux \
543         --disable-sjlj-exceptions \
544 %endif
545 %if "%{TARGET_ARCH}" == "armv7l" 
546         --with-arch=armv7-a \
547         --with-tune=cortex-a9 \
548     --with-float=soft \
549         --with-fpu=vfpv3-d16 \
550         --disable-sjlj-exceptions \
551 %endif
552 %if  "%{TARGET_ARCH}" == "armv7hl"
553         --with-arch=armv7-a \
554         --with-tune=cortex-a9 \
555         --with-float=hard \
556         --with-abi=aapcs-linux \
557         --with-fpu=vfpv3-d16 \
558         --disable-sjlj-exceptions \
559 %endif
560 %if "%{TARGET_ARCH}" == "powerpc" || "%{TARGET_ARCH}" == "powerpc64"
561 %if "%{TARGET_ARCH}" == "powerpc"
562         --with-cpu=default32 \
563 %endif
564         --with-cpu-64=power4 \
565         --enable-secureplt \
566         --with-long-double-128 \
567 %endif
568 %if "%{TARGET_ARCH}" == "sparc64"
569         --with-cpu=ultrasparc \
570         --with-long-double-128 \
571 %endif
572 %if "%{TARGET_ARCH}" == "sparc"
573         --with-cpu=v8 \
574         --with-long-double-128 \
575 %endif
576 %if "%{TARGET_ARCH}" == "i586"
577         --with-arch-32=i586 \
578         --with-tune=generic \
579 %endif
580 %if "%{TARGET_ARCH}" == "x86_64"
581         --with-arch-32=i586 \
582         --with-tune=generic \
583 %endif
584 %if "%{TARGET_ARCH}" == "s390"
585         --with-tune=z196 --with-arch=z10 \
586         --with-long-double-128 \
587         --enable-decimal-float \
588 %endif
589 %if "%{TARGET_ARCH}" == "s390x"
590         --with-tune=z196 --with-arch=z10 \
591         --with-long-double-128 \
592         --enable-decimal-float \
593 %endif
594         --build=%{GCCDIST}
595
596
597 %if 0%{?building_libffi:1}
598 make stage1-bubble $PARALLEL
599 make all-target-libffi $PARALLEL
600 %else
601 STAGE1_FLAGS="-g"
602 # Only run profiled bootstrap on archs where it works
603 #%ifarch %ix86 x86_64 ppc ppc64 ia64
604 #make profiledbootstrap-lean STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
605 #%else
606 #make bootstrap-lean STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
607 make STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
608 #%endif
609 #make -C gcc proto
610 make info
611 %if 0%{?run_tests:1}
612 echo "Run testsuite"
613 (make -C %{GCCDIST}/libstdc++-v3 check-abi || true)
614 mv %{GCCDIST}/libstdc++-v3/testsuite/libstdc++.log %{GCCDIST}/libstdc++-v3/testsuite/libstdc++-abi.log
615 mv %{GCCDIST}/libstdc++-v3/testsuite/libstdc++.sum %{GCCDIST}/libstdc++-v3/testsuite/libstdc++-abi.sum
616 # asan needs a whole shadow address space
617 ulimit -v unlimited || true
618 make -k check $PARALLEL || true
619 mkdir ../testresults
620 ../contrib/test_summary | tee ../testresults/test_summary.txt
621 %endif
622 %endif
623
624 %install
625 export NO_BRP_CHECK_BYTECODE_VERSION=true
626 cd obj-%{GCCDIST}
627 %if 0%{?run_tests:1} 
628 cp `find . -name "*.sum"` ../testresults/
629 cp `find . -name "*.log"  \! -name "config.log" | grep -v 'acats.\?/tests' ` ../testresults/
630 chmod 644 ../testresults/*
631 %endif
632
633 %if 0%{?run_tests:1}
634 %files 
635 %defattr(-,root,root)
636 %doc testresults/test_summary.txt
637 %doc testresults/*.sum
638 %doc testresults/*.log
639 %endif
640
641
642 %changelog