Adding the manifest
[platform/upstream/gcc48.git] / packaging / gcc48-testresults.spec
1 %define building_testsuite 1
2 %define run_tests 1
3 #
4 # spec file for package gcc48
5 #
6 # Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
7 #
8 # All modifications and additions to the file contributed by third parties
9 # remain the property of their copyright owners, unless otherwise agreed
10 # upon. The license for this file, and modifications and additions to the
11 # file, is the same license as for the pristine package itself (unless the
12 # license for the pristine package is not an Open Source License, in which
13 # case the license is the MIT License). An "Open Source License" is a
14 # license that conforms to the Open Source Definition (Version 1.9)
15 # published by the Open Source Initiative.
16
17 # Please submit bugfixes or comments via http://bugs.opensuse.org/
18 #
19
20 # norootforbuild
21 # icecream 0
22
23
24 %define build_ada 0
25
26 %define quadmath_arch %ix86 x86_64 ia64
27 %define tsan_arch x86_64
28 %define asan_arch x86_64 %ix86 ppc ppc64 %arm
29 %define itm_arch x86_64 %ix86 %arm ppc ppc64
30 %define atomic_arch x86_64 %ix86 %arm ppc ppc64 s390 s390x
31
32 # We don't want to build java
33 %define build_java 0
34 %define build_libjava 0
35
36 %define build_cp 1
37 %define build_fortran 0%{?building_libjava:1}%{?building_libffi:1}
38 %define build_objc 0%{?building_libjava:1}%{?building_libffi:1}
39 %define build_objcp 0%{?building_libjava:1}%{?building_libffi:1}
40 %define build_with_mudflap 0
41
42 %if %{build_objcp}
43 %define build_cp 1
44 %define build_objc 1
45 %endif
46
47 %if %{build_libjava}
48 %define build_cp 1
49 %endif
50
51 # For optional compilers only build C, C++ and Fortran
52 %if 0%{?build_optional_compiler_languages:1}
53 %define build_ada 0
54 %define build_java 0
55 %define build_libjava 0
56 %define build_objc 0
57 %define build_objcp 0
58 %endif
59
60 # Shared library SONAME versions
61 %define libgcc_s 1
62 %define libgcj_sover %{nil}
63 %define libgcj_bc_sover %{nil}
64 %define libffi_sover %{nil}
65 %define libmudflap_sover %{nil}
66 %define libgomp_sover %{nil}
67 %define libstdcxx_sover %{nil}
68 %define libobjc_sover %{nil}
69 %define libgfortran_sover %{nil}
70 %define libquadmath_sover %{nil}
71 %define libasan_sover %{nil}
72 %define libtsan_sover %{nil}
73 %define libatomic_sover %{nil}
74 %define libitm_sover %{nil}
75
76 # Shared library package suffix
77 # This is used for the "non-standard" set of libraries, the standard
78 # being defined by %product_libs_gcc_ver, the GCC version that should
79 # provide un-suffixed shared library packages following the shared-library
80 # policy.  Even suffixed variants should provide the shared-library policy
81 # mandated names and ensure they conflict with each other.
82 # Note that on SONAME changes of any library the %product_libs_gcc_ver
83 # define needs to be either split or the newest GCC version still providing
84 # the old SONAME needs to unconditionally produce an un-suffixed library
85 # if %product_libs_gcc_ver is newer than it.  Similar the _oldest_ GCC
86 # version first providing a new SONAME needs to unconditionally produce
87 # an un-suffixed library if %product_libs_gcc_ver is lower that it.
88 %if %{!?product_libs_gcc_ver:48}%{?product_libs_gcc_ver} != 48
89 %define pne 1
90 %endif
91 %define libgcc_s_suffix %{?pne:-gcc48}
92 # libgcj SONAME changes with every GCC version
93 %define libgcj_suffix %nil
94 %define libgcj_bc_suffix %{?pne:-gcc48}
95 %define libffi_suffix %{?pne:-gcc48}
96 %define libmudflap_suffix %{?pne:-gcc48}
97 %define libgomp_suffix %{?pne:-gcc48}
98 %define libstdcxx_suffix %{?pne:-gcc48}
99 %define libobjc_suffix %{?pne:-gcc48}
100 %define libgfortran_suffix %{?pne:-gcc48}
101 %define libquadmath_suffix %{?pne:-gcc48}
102 %define libasan_suffix %{?pne:-gcc48}
103 %define libtsan_suffix %{?pne:-gcc48}
104 %define libatomic_suffix %{?pne:-gcc48}
105 %define libitm_suffix %{?pne:-gcc48}
106
107
108
109
110 Name: gcc48-testresults
111 BuildRequires: gcc-c++
112 BuildRequires: bison
113 BuildRequires: flex
114 BuildRequires: glibc-devel-32bit
115 BuildRequires: mpc-devel
116 BuildRequires: mpfr-devel
117 BuildRequires: perl
118 BuildRequires: makeinfo
119 BuildRequires: zlib-devel
120 %ifarch %ix86 x86_64 ppc ppc64 s390 s390x ia64 %sparc hppa %arm
121 BuildRequires: cloog-isl-devel
122 BuildRequires: isl-devel
123 %endif
124 %if %{build_ada}
125 %define hostsuffix -4.7
126 BuildRequires: gcc47-ada
127 %endif
128 %if 0%{?building_libjava:1}%{?building_testsuite:1}
129 BuildRequires: fastjar
130 %endif
131 %if 0%{?building_libffi:1}
132 BuildRequires: pkg-config
133 %endif
134 %ifarch ia64
135 BuildRequires: libunwind-devel
136 %endif
137 %if 0%{?run_tests:1}
138 BuildRequires: dejagnu
139 BuildRequires: expect
140 BuildRequires: gdb
141 %endif
142
143 %define separate_bi32 0
144 %define separate_bi64 0
145 %ifarch ppc sparcv9
146 # Beware, this does _not_ separate libgcj, as for that one multilibing
147 # is inactive for the time being
148 %define separate_bi64 1
149 %endif
150 %ifarch x86_64 s390x ppc64 sparc64
151 %define separate_bi32 1
152 %endif
153
154 # Define two macros to trigger -32bit or -64bit package variants
155 %define separate_biarch 0
156 %if %{separate_bi32}
157 %define separate_biarch 1
158 %define separate_biarch_suffix -32bit
159 %endif
160 %if %{separate_bi64}
161 %define separate_biarch 1
162 %define separate_biarch_suffix -64bit
163 %endif
164
165 %ifarch x86_64 ia64 s390x alpha ppc64 sparc64
166 # 64-bit is primary build target
167 %define build_primary_64bit 1
168 %else
169 %define build_primary_64bit 0
170 %endif
171
172 %define biarch_libjava 0
173
174 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
175
176 URL:          http://gcc.gnu.org/
177 Version: 4.8.2
178 Release:      1
179 %define gcc_dir_version 4.8
180 %define binsuffix -4.8
181
182 %if !0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
183 Requires: binutils glibc-devel
184 Requires: cpp48 = %{version}-%{release}
185 Requires: libgcc_s%{libgcc_s} >= %{version}-%{release}
186 Requires: libgomp%{libgomp_sover} >= %{version}-%{release}
187 %if %{build_with_mudflap}
188 Requires: libmudflap%{libmudflap_sover} >= %{version}-%{release}
189 Requires: libmudflapth%{libmudflap_sover} >= %{version}-%{release}
190 %endif
191 %ifarch %asan_arch
192 Requires: libasan%{libasan_sover} >= %{version}-%{release}
193 %endif
194 %ifarch %tsan_arch
195 Requires: libtsan%{libtsan_sover} >= %{version}-%{release}
196 %endif
197 %ifarch %atomic_arch
198 Requires: libatomic%{libatomic_sover} >= %{version}-%{release}
199 %endif
200 %ifarch %itm_arch
201 Requires: libitm%{libitm_sover} >= %{version}-%{release}
202 %endif
203 Suggests: gcc48-info gcc48-locale
204 %endif
205
206 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
207 Source:         gcc-%{version}.tar.bz2
208 Source1:        change_spec
209 Source3:        gcc48-rpmlintrc
210 Source4:        ecj.jar
211 Source6:        baselibs.conf
212 Source1001: gcc.manifest
213
214
215 Summary:      Testsuite results
216 License:        SUSE-Public-Domain
217
218 %description 
219 Results from running the gcc and target library testsuites.
220
221
222
223 # Define the canonical target and host architecture
224 #   %gcc_target_arch  is supposed to be the full target triple
225 #   %TARGET_ARCH      is the canonicalized CPU part
226 #   %CONFIGURE_TARGET is the target triple used for --target=
227 %if 0%{?gcc_target_arch:1}
228 %define CONFIGURE_TARGET %{gcc_target_arch}
229 %define TARGET_ARCH %(echo %{gcc_target_arch} | cut -d - -f 1 | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
230 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "powerpc"
231 %define CONFIGURE_TARGET powerpc64-tizen-linux
232 %endif
233 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "powerpc64"
234 %define CONFIGURE_TARGET powerpc64-tizen-linux
235 %endif
236 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "i586"
237 %define CONFIGURE_TARGET i586-tizen-linux
238 %endif
239 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7l"
240 %define CONFIGURE_TARGET armv7l-tizen-linux-gnueabi
241 %endif
242 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7hl"
243 %define CONFIGURE_TARGET armv7hl-tizen-linux-gnueabi
244 %endif
245 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv5tel"
246 %define CONFIGURE_TARGET armv5tel-tizen-linux-gnueabi
247 %endif
248 %else
249 %define TARGET_ARCH %(echo %{_target_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
250 %endif
251 %define HOST_ARCH %(echo %{_host_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
252
253 %define biarch %(case " %{biarch_targets} " in (*" %{TARGET_ARCH} "*) echo 1;; (*) echo 0;; esac)
254
255 %ifarch ppc
256 %define GCCDIST powerpc64-tizen-linux
257 %else
258 %ifarch %sparc
259 %define GCCDIST sparc64-tizen-linux
260 %else
261 %ifarch %arm
262 %define GCCDIST %{HOST_ARCH}-tizen-linux-gnueabi
263 %else
264 %define GCCDIST %{HOST_ARCH}-tizen-linux
265 %endif
266 %endif
267 %endif
268
269 %define libsubdir %{_libdir}/gcc/%{GCCDIST}/%{gcc_dir_version}
270 %define gxxinclude %{_prefix}/include/c++/%{gcc_dir_version}
271
272
273 # Versionspecific directories
274 %define versmainlibdir %{libsubdir}
275 %define versmainlibdirbi32 %{libsubdir}/32
276 %define versmainlibdirbi64 %{libsubdir}/64
277 %ifarch ppc
278 %define versmainlibdirbi32 %{libsubdir}
279 %define versmainlibdirbi64 %{libsubdir}/64
280 %endif
281 %if %{build_primary_64bit}
282 %define versmainlibdirbi %{versmainlibdirbi32}
283 %else
284 %define versmainlibdirbi %{versmainlibdirbi64}
285 %endif
286
287 %define mainlibdir %{_libdir}
288 %define mainlibdirbi32 %{_prefix}/lib
289 %define mainlibdirbi64 %{_prefix}/lib64
290 %if %{build_primary_64bit}
291 %define mainlibdirbi %{mainlibdirbi32}
292 %else
293 %define mainlibdirbi %{mainlibdirbi64}
294 %endif
295
296
297 # Now define a few macros that make it easy to package libs and
298 # related files just to the right package, without caring for the
299 # exact path the files are in.
300 #   %mainlib  package X from all dirs that belong to the main package
301 #   %biarchlib   package X from all dirs that belong to the -32/64bit package
302 %define mainlib() %{mainlibdir}/%1\
303 %{nil}
304 %define biarchlib() %{nil}
305 %if %{biarch}
306 %if !%{separate_biarch}
307 %define mainlib() %{mainlibdir}/%1\
308 %{mainlibdirbi}/%1\
309 %{nil}
310 %else
311 %define biarchlib() %{mainlibdirbi}/%1\
312 %{nil}
313 %endif
314 %endif
315
316 %define versmainlib() %{versmainlibdir}/%1\
317 %{nil}
318 %define versbiarchlib() %{nil}
319 %if %{biarch}
320 %if !%{separate_biarch}
321 %define versmainlib() %{versmainlibdir}/%1\
322 %{versmainlibdirbi}/%1\
323 %{nil}
324 %else
325 %define versbiarchlib() %{versmainlibdirbi}/%1\
326 %{nil}
327 %endif
328 %endif
329
330
331
332 %prep
333 %setup -q -n gcc-%{version}
334 cp %{SOURCE1001} .
335
336
337 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
338 # the libstdc++ abi testsuite baseline files accordingly
339 %ifarch ppc
340 if [ -d libstdc++-v3/config/abi/post/powerpc64-linux-gnu ]; then
341   mkdir -p libstdc++-v3/config/abi/post/powerpc64-linux-gnu/64
342   mv libstdc++-v3/config/abi/post/powerpc64-linux-gnu/baseline_symbols.txt \
343         libstdc++-v3/config/abi/post/powerpc64-linux-gnu/64/
344   mv libstdc++-v3/config/abi/post/powerpc64-linux-gnu/32/baseline_symbols.txt \
345         libstdc++-v3/config/abi/post/powerpc64-linux-gnu/
346 fi
347 %endif
348
349 %build
350 # Avoid rebuilding of generated files
351 contrib/gcc_update --touch
352 # Avoid fucking up testsuite results with Java and indirect dispatch
353 export LD_AS_NEEDED=0
354 # Split version file into version used for directories (X.Y) and
355 # version to report with --version (X.Y.Z).
356 # See also gcc-dir-version.patch.
357 # Also decrement the patchlevel version by one
358 if test `cat gcc/DEV-PHASE` == "prerelease"; then
359   ( cat gcc/BASE-VER | cut -d '.' -f 1-2 | tr -d '\n'; echo -n .; cat gcc/BASE-VER | cut -d '.' -f 3 | tr '0123456789' '0012345678' ) > gcc/FULL-VER
360 else
361   mv gcc/BASE-VER gcc/FULL-VER
362 fi
363 cat gcc/FULL-VER | cut -d '.' -f 1-2 > gcc/BASE-VER
364
365 rm -rf obj-%{GCCDIST}
366 mkdir obj-%{GCCDIST}
367 cd obj-%{GCCDIST}
368 RPM_OPT_FLAGS="$RPM_OPT_FLAGS -U_FORTIFY_SOURCE"
369 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fno-rtti//g' -e 's/-fno-exceptions//g' -e 's/-Wmissing-format-attribute//g' -e 's/-fstack-protector//g' -e 's/-ffortify=.//g' -e 's/-Wall//g' -e 's/-m32//g' -e 's/-m64//g'`
370 %ifarch %ix86
371 # -mcpu is superceded by -mtune but -mtune is not supported by
372 # our bootstrap compiler.  -mcpu gives a warning that stops
373 # the build process, so remove it for now.  Also remove all other
374 # -march and -mtune flags.  They are superseeded by proper
375 # default compiler settings now.
376 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-mcpu=i.86//g' -e 's/-march=i.86//g' -e 's/-mtune=i.86//g'`
377 %endif
378 %ifarch s390 s390x
379 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fsigned-char//g'`
380 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-O1/-O2/g'`
381 %endif
382 %if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
383 # Kill all -march/tune/cpu because that screws building the target libs
384 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-m\(arch\|tune\|cpu\)=[^ ]*//g'`
385 %endif
386 # Replace 2 spaces by one finally
387 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/  / /g'`
388
389 languages=c
390 %if %{build_cp}
391 languages=$languages,c++
392 %endif
393 %if %{build_objc}
394 languages=$languages,objc
395 %endif
396 %if %{build_fortran}
397 languages=$languages,fortran
398 %endif
399 %if %{build_objcp}
400 languages=$languages,obj-c++
401 %endif
402 %if %{build_java}
403 languages=$languages,java
404 %endif
405 %if %{build_ada}
406 languages=$languages,ada
407 %endif
408
409 J=%{?jobs:%jobs}
410 if test -z "$J"; then
411   J=$(getconf _NPROCESSORS_CONF)
412   JL=$(($J * 2))
413 else
414   test 1 -gt "$J" && J=1
415   JL=$(($(getconf _NPROCESSORS_CONF)*2))
416 fi
417 if test "$J" == "0"; then
418   J=1
419 fi
420 if test "$JL" == "0"; then
421   JL=1
422 fi
423 PARALLEL="-j$J -l$JL"
424
425 # we don't want some miscompiles in the testsuite, or some fault in
426 # the compiler to kill the machine.  Hence we limit the amount of memory
427 # by the physical RAM plus half of swap
428 #MEM=$(free -m | awk '/^Mem:/ {print $2}')
429 #SWAP=$(free -m | awk '/^Swap:/ {print $2}')
430 #ulimit -v $(((MEM + SWAP/2)*1024))
431
432 # In general we want to ship release checking enabled compilers
433 # and run BETA with checking enabled.
434 #ENABLE_CHECKING="--enable-checking=yes"
435 ENABLE_CHECKING="--enable-checking=release"
436
437 # Work around tail/head -1 changes
438 export _POSIX2_VERSION=199209
439
440 # configure tries to parse include/features.h to detect
441 # if glibc supports SSP.  When cross compiling we would need
442 # to install a cross glibc, which we don't, or make the whole
443 # thing point to the native glibc, which is in /, hence the
444 # --with-build-sysroot=/
445
446 %if %{build_ada}
447 # Using the host gnatmake like
448 #   CC="gcc%{hostsuffix}" GNATBIND="gnatbind%{hostsuffix}"
449 #   GNATMAKE="gnatmake%{hostsuffix}"
450 # doesn't work due to PR33857, so an un-suffixed gnatmake has to be
451 # available
452 mkdir -p host-tools/bin
453 cp -a /usr/bin/gnatmake%{hostsuffix} host-tools/bin/gnatmake
454 cp -a /usr/bin/gnatlink%{hostsuffix} host-tools/bin/gnatlink
455 cp -a /usr/bin/gnatbind%{hostsuffix} host-tools/bin/gnatbind
456 cp -a /usr/bin/gcc%{hostsuffix} host-tools/bin/gcc
457 ln -sf /usr/%{_lib} host-tools/%{_lib}
458 export PATH="`pwd`/host-tools/bin:$PATH"
459 %endif
460 #%if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
461 #%else
462 #       --enable-threads=posix \
463 #%endif
464 #       --enable-shared \
465 %if "%{TARGET_ARCH}" == "armv7l" || "%{TARGET_ARCH}" == "armv7hl"
466 # temporary workaround for a miscompilation of hash functions in java code
467 GCJ_EXTRA_FLAGS="-marm"
468 %endif
469 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" XCFLAGS="$RPM_OPT_FLAGS" \
470 TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
471 ../configure \
472         --prefix=%{_prefix} \
473         --infodir=%{_infodir} \
474         --mandir=%{_mandir} \
475         --libdir=%{_libdir} \
476         --libexecdir=%{_libdir} \
477     --disable-bootstrap \
478         --enable-languages=$languages \
479         $ENABLE_CHECKING \
480         --with-gxx-include-dir=%{_prefix}/include/c++/%{gcc_dir_version} \
481         --enable-ssp \
482         --disable-libssp \
483         --disable-plugin \
484         --with-bugurl="http://bugs.tizen.org/" \
485         --with-pkgversion="Tizen" \
486 %if !%{build_fortran}
487         --disable-libquadmath \
488 %endif
489 %if !%{build_libjava}
490         --disable-libgcj \
491 %else
492         --with-java-home=%{_libdir}/jvm/java-1.5.0-gcj%{binsuffix}-1.5.0.0/jre \
493         --with-ecj-jar=%{libsubdir}/ecj.jar \
494         --disable-java-awt \
495 %if !%{biarch_libjava}
496         --disable-libjava-multilib \
497 %endif
498 %endif
499 %if !%{build_with_mudflap}
500         --disable-libmudflap \
501 %endif
502         --with-slibdir=/%{_lib} \
503         --with-system-zlib \
504         --enable-__cxa_atexit \
505         --enable-libstdcxx-allocator=new \
506         --disable-libstdcxx-pch \
507         --enable-version-specific-runtime-libs \
508         --enable-linker-build-id \
509 %if 0%{?gcc_target_arch:1}
510 %if 0%{?gcc_icecream:1}
511         --with-sysroot=/ \
512         --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/include/c++/%{gcc_dir_version} \
513         --enable-linux-futex \
514 %endif
515 %if 0%{?canonical_target:1}
516         --with-build-time-tools=/usr/%{canonical_target}-tizen-linux%{?canonical_target_abi:%canonical_target_abi}/bin \
517 %endif
518 %if 0%{?sysroot:1}
519         --with-sysroot=%sysroot \
520 %endif
521 %if 0%{?build_static:1}
522         --disable-shared \
523 %endif
524 %if "%{TARGET_ARCH}" == "spu"
525         --with-gxx-include-dir=%sysroot/include/c++/%{gcc_dir_version} \
526         --with-newlib \
527 %endif
528         --disable-nls \
529         --target=%{CONFIGURE_TARGET} \
530 %else
531         --program-suffix=%{binsuffix} \
532         --enable-linux-futex \
533 %ifarch ia64
534         --with-system-libunwind \
535 %else
536         --without-system-libunwind \
537 %endif
538 %endif
539 %if "%{TARGET_ARCH}" == "armv5tel"
540         --with-arch=armv5te \
541         --with-float=soft \
542         --with-mode=arm \
543         --with-abi=aapcs-linux \
544         --disable-sjlj-exceptions \
545 %endif
546 %if "%{TARGET_ARCH}" == "armv7l" 
547         --with-arch=armv7-a \
548         --with-tune=cortex-a8 \
549         --with-float=softfp \
550         --with-fpu=vfpv3 \
551         --with-mode=thumb \
552         --disable-sjlj-exceptions \
553 %endif
554 %if  "%{TARGET_ARCH}" == "armv7hl"
555         --with-arch=armv7-a \
556         --with-tune=cortex-a9 \
557         --with-float=hard \
558         --with-abi=aapcs-linux \
559         --with-fpu=vfpv3-d16 \
560         --disable-sjlj-exceptions \
561 %endif
562 %if "%{TARGET_ARCH}" == "powerpc" || "%{TARGET_ARCH}" == "powerpc64"
563 %if "%{TARGET_ARCH}" == "powerpc"
564         --with-cpu=default32 \
565 %endif
566         --with-cpu-64=power4 \
567         --enable-secureplt \
568         --with-long-double-128 \
569 %endif
570 %if "%{TARGET_ARCH}" == "sparc64"
571         --with-cpu=ultrasparc \
572         --with-long-double-128 \
573 %endif
574 %if "%{TARGET_ARCH}" == "sparc"
575         --with-cpu=v8 \
576         --with-long-double-128 \
577 %endif
578 %if "%{TARGET_ARCH}" == "i586"
579         --with-arch-32=i586 \
580         --with-tune=generic \
581 %endif
582 %if "%{TARGET_ARCH}" == "x86_64"
583         --with-arch-32=i586 \
584         --with-tune=generic \
585 %endif
586 %if "%{TARGET_ARCH}" == "s390"
587         --with-tune=z196 --with-arch=z10 \
588         --with-long-double-128 \
589         --enable-decimal-float \
590 %endif
591 %if "%{TARGET_ARCH}" == "s390x"
592         --with-tune=z196 --with-arch=z10 \
593         --with-long-double-128 \
594         --enable-decimal-float \
595 %endif
596         --build=%{GCCDIST}
597
598
599 %if 0%{?building_libffi:1}
600 make stage1-bubble $PARALLEL
601 make all-target-libffi $PARALLEL
602 %else
603 STAGE1_FLAGS="-g"
604 # Only run profiled bootstrap on archs where it works
605 #%ifarch %ix86 x86_64 ppc ppc64 ia64
606 #make profiledbootstrap-lean STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
607 #%else
608 #make bootstrap-lean STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
609 make STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
610 #%endif
611 #make -C gcc proto
612 make info
613 %if 0%{?run_tests:1}
614 echo "Run testsuite"
615 (make -C %{GCCDIST}/libstdc++-v3 check-abi || true)
616 mv %{GCCDIST}/libstdc++-v3/testsuite/libstdc++.log %{GCCDIST}/libstdc++-v3/testsuite/libstdc++-abi.log
617 mv %{GCCDIST}/libstdc++-v3/testsuite/libstdc++.sum %{GCCDIST}/libstdc++-v3/testsuite/libstdc++-abi.sum
618 # asan needs a whole shadow address space
619 ulimit -v unlimited || true
620 make -k check $PARALLEL || true
621 mkdir ../testresults
622 ../contrib/test_summary | tee ../testresults/test_summary.txt
623 %endif
624 %endif
625
626 %install
627 export NO_BRP_CHECK_BYTECODE_VERSION=true
628 cd obj-%{GCCDIST}
629 %if 0%{?run_tests:1} 
630 cp `find . -name "*.sum"` ../testresults/
631 cp `find . -name "*.log"  \! -name "config.log" | grep -v 'acats.\?/tests' ` ../testresults/
632 chmod 644 ../testresults/*
633 %endif
634
635 %if 0%{?run_tests:1}
636 %files 
637 %manifest gcc.manifest
638 %defattr(-,root,root)
639 %doc testresults/test_summary.txt
640 %doc testresults/*.sum
641 %doc testresults/*.log
642 %endif
643
644
645 %changelog