add packaging
[platform/upstream/gcc47.git] / packaging / cross-armv7el-gcc47-icecream-backend.spec
1 #
2 # spec file for package gcc (Version 4.0.1)
3 #
4 # Copyright (c) 2005 SUSE Linux AG, Nuernberg, Germany.
5 # This file and all modifications and additions to the pristine
6 # package are under the same license as the package itself.
7 #
8 # Please submit bugfixes or comments via http://www.suse.de/feedback/
9 #
10
11 %define build_cp 1
12 %define build_ada 0
13 %define build_libjava 0
14 %define build_java 0
15 %define build_fortran 0
16 %define build_objc 0
17 %define build_objcp 0
18 %define build_nof 0
19 %define build_with_mudflap 0
20 %define gcc_target_arch armv7el-tizen-linux
21 %define gcc_icecream 1
22
23 %define binutils_target armv7el
24 %if %{binutils_target} == "armv7l" || %{binutils_target} == "armv7hl" || %{binutils_target} == "armv7el"
25 %define binutils_target arm
26 %endif
27 %if %{binutils_target} == "armv5el"
28 %define binutils_target arm
29 %endif
30 %define canonical_target %(echo %{binutils_target} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
31 %if %{binutils_target} == "arm"
32 %define canonical_target_abi -gnueabi
33 %endif
34
35 Name:         cross-armv7el-gcc47-icecream-backend
36 BuildRequires: cross-%{binutils_target}-binutils
37 BuildRequires: bison
38 BuildRequires: flex
39 BuildRequires: gettext-devel
40 BuildRequires: glibc-devel-32bit
41 BuildRequires: mpc-devel
42 BuildRequires: mpfr-devel
43 BuildRequires: perl
44 BuildRequires: makeinfo
45 BuildRequires: zlib-devel
46 %ifarch %ix86 x86_64  %arm
47 BuildRequires: cloog-devel
48 BuildRequires: ppl-devel
49 %endif
50 %ifarch ia64
51 BuildRequires: libunwind-devel
52 %endif
53 ExclusiveArch: ppc ppc64 %ix86 x86_64 ia64 
54 %define _binary_payload w.ufdio
55
56 # COMMON-BEGIN
57 # COMMON-BEGIN
58 %define biarch_targets x86_64 
59
60 URL:          http://gcc.gnu.org/
61 Version: 4.7.2
62 Release:      1
63 %define gcc_version %(echo %version | sed 's/_.*//')
64 %define gcc_dir_version %(echo %gcc_version | cut -d '.' -f 1-2)
65 %define snapshot_date %(echo %version | sed 's/[34]\.[0-9]\.[0-6]//' | sed 's/_/-/')
66 %define binsuffix -4.7
67 # COMMON-END
68 # COMMON-BEGIN
69 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
70 #Source:                gcc-%{gcc_version}%{snapshot_date}.tar.bz2
71 Source:     gcc-%{version}.tar.bz2
72
73 Source1:        change_spec
74 Source2:        libgcj47-rpmlintrc
75 Source3:        gcc47-rpmlintrc
76 Source4:        ecj.jar
77 Source6:        baselibs.conf
78 # Patches auto-generated by git-buildpackage:
79 Patch0:     0001-dir-version.patch
80
81 # GCC-TESTSUITE-DELETE-BEGIN
82 # LIBFFI-DELETE-BEGIN
83 # LIBJAVA-DELETE-BEGIN
84 Group:          Development/Languages/C and C++
85 Summary:        The GNU C Compiler and Support Files
86 License:        GPL-3.0+
87
88 %description
89 Core package for the GNU Compiler Collection, including the C language
90 frontend.
91
92 Language frontends other than C are split to different sub-packages,
93 namely gcc-ada, gcc-c++, gcc-fortran, gcc-java, gcc-objc and
94 gcc-obj-c++.
95
96
97
98 # COMMON-END
99 # COMMON-BEGIN
100
101 # Define the canonical target and host architecture
102 #   %gcc_target_arch  is supposed to be the full target triple
103 #   %TARGET_ARCH      is the canonicalized CPU part
104 #   %CONFIGURE_TARGET is the target triple used for --target=
105 %if 0%{?gcc_target_arch:1}
106 %define CONFIGURE_TARGET %{gcc_target_arch}
107 %define TARGET_ARCH %(echo %{gcc_target_arch} | cut -d - -f 1 | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
108 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "i586"
109 %define CONFIGURE_TARGET i586-tizen-linux
110 %endif
111 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7l"
112 %define CONFIGURE_TARGET armv7l-tizen-linux-gnueabi
113 %endif
114 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7hl"
115 %define CONFIGURE_TARGET armv7hl-tizen-linux-gnueabi
116 %endif
117 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7el"
118 %define CONFIGURE_TARGET armv7el-tizen-linux-gnueabi
119 %endif
120 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv5el"
121 %define CONFIGURE_TARGET armv5el-tizen-linux-gnueabi
122 %endif
123 %else
124 %define TARGET_ARCH %(echo %{_target_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
125 %endif
126 %define HOST_ARCH %(echo %{_host_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
127
128 %define biarch %(case " %{biarch_targets} " in (*" %{TARGET_ARCH} "*) echo 1;; (*) echo 0;; esac)
129
130 %ifarch %arm
131 %define GCCDIST %{HOST_ARCH}-tizen-linux-gnueabi
132 %else
133 %define GCCDIST %{HOST_ARCH}-tizen-linux
134 %endif
135
136 %define libsubdir %{_libdir}/gcc/%{GCCDIST}/%{gcc_dir_version}
137 %define gxxinclude %{_prefix}/include/c++/%{gcc_dir_version}
138
139 # COMMON-END
140 # COMMON-BEGIN
141
142 %prep
143 #%setup -q -n gcc-%{gcc_version}%{snapshot_date}
144 %setup -q -n gcc-%{version}
145 # 0001-dir-version.patch
146 %patch0 -p1
147
148 %build
149 # Avoid rebuilding of generated files
150 contrib/gcc_update --touch
151 # Avoid fucking up testsuite results with Java and indirect dispatch
152 export LD_AS_NEEDED=0
153 # Split version file into version used for directories (X.Y) and
154 # version to report with --version (X.Y.Z).
155 # See also gcc-dir-version.patch.
156 # Also decrement the patchlevel version by one
157 if test `cat gcc/DEV-PHASE` == "prerelease"; then
158   ( cat gcc/BASE-VER | cut -d '.' -f 1-2 | tr -d '\n'; echo -n .; cat gcc/BASE-VER | cut -d '.' -f 3 | tr '0123456789' '0012345678' ) > gcc/FULL-VER
159 else
160   mv gcc/BASE-VER gcc/FULL-VER
161 fi
162 cat gcc/FULL-VER | cut -d '.' -f 1-2 > gcc/BASE-VER
163
164 rm -rf obj-%{GCCDIST}
165 mkdir obj-%{GCCDIST}
166 cd obj-%{GCCDIST}
167 RPM_OPT_FLAGS="$RPM_OPT_FLAGS -U_FORTIFY_SOURCE"
168 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fno-rtti//g' -e 's/-fno-exceptions//g' -e 's/-Wmissing-format-attribute//g' -e 's/-fstack-protector//g' -e 's/-ffortify=.//g' -e 's/-Wall//g' -e 's/-m32//g' -e 's/-m64//g'`
169 %ifarch %ix86
170 # -mcpu is superceded by -mtune but -mtune is not supported by
171 # our bootstrap compiler.  -mcpu gives a warning that stops
172 # the build process, so remove it for now.  Also remove all other
173 # -march and -mtune flags.  They are superseeded by proper
174 # default compiler settings now.
175 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-mcpu=i.86//g' -e 's/-march=i.86//g' -e 's/-mtune=i.86//g'`
176 %endif
177 %if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
178 # Kill all -march/tune/cpu because that screws building the target libs
179 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-m\(arch\|tune\|cpu\)=[^ ]*//g'`
180 %endif
181 # Replace 2 spaces by one finally
182 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/  / /g'`
183
184 languages=c
185 %if %{build_cp}
186 languages=$languages,c++
187 %endif
188 %if %{build_objc}
189 languages=$languages,objc
190 %endif
191 %if %{build_fortran}
192 languages=$languages,fortran
193 %endif
194 %if %{build_objcp}
195 languages=$languages,obj-c++
196 %endif
197 %if %{build_java}
198 languages=$languages,java
199 %endif
200 %if %{build_ada}
201 languages=$languages,ada
202 %endif
203
204 J=%{?jobs:%jobs}
205 if test -z "$J"; then
206   J=$(getconf _NPROCESSORS_CONF)
207   JL=$(($J * 2))
208 else
209   test 1 -gt "$J" && J=1
210   JL=$(($(getconf _NPROCESSORS_CONF)*2))
211 fi
212 if test "$J" == "0"; then
213   J=1
214 fi
215 if test "$JL" == "0"; then
216   JL=1
217 fi
218 PARALLEL="-j$J -l$JL"
219
220 # we don't want some miscompiles in the testsuite, or some fault in
221 # the compiler to kill the machine.  Hence we limit the amount of memory
222 # by the physical RAM plus half of swap
223 #MEM=$(free -m | awk '/^Mem:/ {print $2}')
224 #SWAP=$(free -m | awk '/^Swap:/ {print $2}')
225 #ulimit -v $(((MEM + SWAP/2)*1024))
226
227 # In general we want to ship release checking enabled compilers
228 # and run BETA with checking enabled.
229 #ENABLE_CHECKING="--enable-checking=yes"
230 ENABLE_CHECKING="--enable-checking=release"
231
232 # Work around tail/head -1 changes
233 export _POSIX2_VERSION=199209
234
235 # configure tries to parse include/features.h to detect
236 # if glibc supports SSP.  When cross compiling we would need
237 # to install a cross glibc, which we don't, or make the whole
238 # thing point to the native glibc, which is in /, hence the
239 # --with-sysroot=/
240
241 %if %{build_ada}
242 # Using the host gnatmake like
243 #   CC="gcc%{hostsuffix}" GNATBIND="gnatbind%{hostsuffix}"
244 #   GNATMAKE="gnatmake%{hostsuffix}"
245 # doesn't work due to PR33857, so an un-suffixed gnatmake has to be
246 # available
247 mkdir -p host-tools/bin
248 cp -a /usr/bin/gnatmake%{hostsuffix} host-tools/bin/gnatmake
249 cp -a /usr/bin/gnatlink%{hostsuffix} host-tools/bin/gnatlink
250 cp -a /usr/bin/gnatbind%{hostsuffix} host-tools/bin/gnatbind
251 cp -a /usr/bin/gcc%{hostsuffix} host-tools/bin/gcc
252 ln -sf /usr/%{_lib} host-tools/%{_lib}
253 export PATH="`pwd`/host-tools/bin:$PATH"
254 %endif
255 #%if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
256 #%else
257 #       --enable-threads=posix \
258 #%endif
259 #       --enable-shared \
260 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" XCFLAGS="$RPM_OPT_FLAGS" \
261 TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS" \
262 ../configure \
263         --prefix=%{_prefix} \
264         --infodir=%{_infodir} \
265         --mandir=%{_mandir} \
266         --libdir=%{_libdir} \
267         --libexecdir=%{_libdir} \
268         --enable-languages=$languages \
269         $ENABLE_CHECKING \
270         --with-gxx-include-dir=%{_prefix}/include/c++/%{gcc_dir_version} \
271         --enable-ssp \
272         --disable-libssp \
273         --disable-libitm \
274 %if 0%{?fast_build}
275         --disable-bootstrap \
276 %endif
277         --disable-plugin \
278         --with-bugurl="http://bugs.tizen.org/" \
279         --with-pkgversion="Tizen Linux" \
280 %if !%{build_libjava}
281         --disable-libgcj \
282 %else
283         --with-java-home=%{_libdir}/jvm/java-1.5.0-gcj%{binsuffix}-1.5.0.0/jre \
284         --with-ecj-jar=%{libsubdir}/ecj.jar \
285         --disable-java-awt \
286 %if !%{biarch_libjava}
287         --disable-libjava-multilib \
288 %endif
289 %endif
290 %if !%{build_with_mudflap}
291         --disable-libmudflap \
292 %endif
293         --with-slibdir=/%{_lib} \
294         --with-system-zlib \
295         --enable-__cxa_atexit \
296         --enable-libstdcxx-allocator=new \
297         --disable-libstdcxx-pch \
298         --enable-version-specific-runtime-libs \
299         --enable-linker-build-id \
300 %if 0%{?gcc_target_arch:1}
301 %if 0%{?gcc_icecream:1}
302         --with-build-sysroot=/ \
303         --with-sysroot=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi} \
304         --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/usr/include/c++/%{gcc_dir_version} \
305         --enable-linux-futex \
306 %endif
307 %if 0%{?canonical_target:1}
308         --with-build-time-tools=/usr/%{canonical_target}-tizen-linux%{?canonical_target_abi:%canonical_target_abi}/bin \
309 %endif
310 %if 0%{?build_static:1}
311         --disable-shared \
312 %endif
313 %if "%{TARGET_ARCH}" == "spu"
314         --with-sysroot=/usr/spu \
315         --with-gxx-include-dir=%{_prefix}/spu/include/c++/%{gcc_dir_version} \
316         --with-newlib \
317 %endif
318         --disable-nls \
319         --target=%{CONFIGURE_TARGET} \
320 %else
321         --program-suffix=%{binsuffix} \
322         --enable-linux-futex \
323 %ifarch ia64
324         --with-system-libunwind \
325 %else
326         --without-system-libunwind \
327 %endif
328 %endif
329 %if "%{TARGET_ARCH}" == "armv5tel"
330         --with-arch=armv5te \
331         --with-float=soft \
332         --with-mode=arm \
333         --with-abi=aapcs-linux \
334         --disable-sjlj-exceptions \
335 %endif
336 %if "%{TARGET_ARCH}" == "armv7el" 
337         --with-arch=armv7-a \
338         --with-tune=cortex-a9 \
339         --with-float=soft \
340         --with-abi=softfp \
341         --with-fpu=vfpv3 \
342         --disable-sjlj-exceptions \
343 %endif
344 %if "%{TARGET_ARCH}" == "armv7l" || "%{TARGET_ARCH}" == "armv7hl"
345         --with-arch=armv7-a \
346         --with-tune=cortex-a9 \
347         --with-float=hard \
348         --with-abi=aapcs-linux \
349         --with-fpu=vfpv3-d16 \
350         --disable-sjlj-exceptions \
351 %endif
352 %if "%{TARGET_ARCH}" == "i586"
353         --with-arch-32=i586 \
354         --with-tune=generic \
355 %endif
356 %if "%{TARGET_ARCH}" == "x86_64"
357         --with-arch-32=i586 \
358         --with-tune=generic \
359 %endif
360         --build=%{GCCDIST}
361
362 # COMMON-END
363 # COMMON-END
364
365 make %{?jobs:-j%jobs} all-gcc TARGET-gcc="cc1 cc1plus gcc-cross g++ native"
366
367 %install
368 cd obj-%{GCCDIST}
369 rm -rf $RPM_BUILD_ROOT
370 make -C gcc DESTDIR=$RPM_BUILD_ROOT/inst install-driver install-common
371 make DESTDIR=$RPM_BUILD_ROOT/inst maybe-install-lto-plugin
372
373 # But the assembler comes from the cross-binutils, and hence is _not_
374 # named funnily, not even on ppc, so there we need the original target
375 install -s -D %{_prefix}/bin/%{canonical_target}-tizen-linux%{?canonical_target_abi:%canonical_target_abi}-as \
376         $RPM_BUILD_ROOT/env/usr/bin/as
377 install -s $RPM_BUILD_ROOT/inst%{_prefix}/bin/%{CONFIGURE_TARGET}-g++ \
378         $RPM_BUILD_ROOT/env/usr/bin/g++
379 install -s $RPM_BUILD_ROOT/inst%{_prefix}/bin/%{CONFIGURE_TARGET}-gcc \
380         $RPM_BUILD_ROOT/env/usr/bin/gcc
381
382 %define targetlibsubdir %{_libdir}/gcc/%{CONFIGURE_TARGET}/%{gcc_dir_version}
383 for back in cc1 cc1plus; do 
384         install -s -D $RPM_BUILD_ROOT/inst%{targetlibsubdir}/$back \
385                 $RPM_BUILD_ROOT/env%{targetlibsubdir}/$back
386 done
387 if test -f $RPM_BUILD_ROOT/inst%{targetlibsubdir}/liblto_plugin.so; then
388   install -s -D $RPM_BUILD_ROOT/inst%{targetlibsubdir}/liblto_plugin.so \
389                 $RPM_BUILD_ROOT/env%{targetlibsubdir}/liblto_plugin.so
390 fi
391
392 libs=`for bin in $RPM_BUILD_ROOT/env/usr/bin/* $RPM_BUILD_ROOT/env%{targetlibsubdir}/*; do \
393   ldd $bin | sed -n '\,^[^/]*\(/[^ ]*\).*,{ s//\1/; p; }'  ;\
394 done | sort -u `
395 for lib in $libs; do
396    # Check wether the same library also exists in the parent directory,
397    # and prefer that on the assumption that it is a more generic one.
398    baselib=`echo "$lib" | sed 's,/[^/]*\(/[^/]*\)$,\1,'`
399    test -f "$baselib" && lib=$baselib
400    install -s -D $lib $RPM_BUILD_ROOT/env$lib
401 done
402 rm -rf $RPM_BUILD_ROOT/inst
403 cd $RPM_BUILD_ROOT/env
404 tar cvzf ../%{name}_%{_arch}.tar.gz *
405 cd ..
406 mkdir -p usr/share/icecream-envs
407 mv %{name}_%{_arch}.tar.gz usr/share/icecream-envs
408 rpm -q --changelog glibc >  usr/share/icecream-envs/%{name}_%{_arch}.glibc
409 rpm -q --changelog binutils >  usr/share/icecream-envs/%{name}_%{_arch}.binutils
410 rm -r env
411 cd $RPM_BUILD_DIR
412
413 %clean
414 rm -rf $RPM_BUILD_ROOT
415
416 %files
417 %defattr(-,root,root)
418 /usr/share/icecream-envs
419
420 %changelog -n cross-armv7el-gcc47-icecream-backend