package licenses as %license
[platform/upstream/fuse.git] / packaging / fuse.spec
1 Name:           fuse
2 Summary:        User space File System
3 License:        GPL-2.0+ ; LGPL-2.1+
4 Group:          System/Filesystems
5 Version:        2.9.0
6 Release:        0
7 Source:         %{name}-%{version}.tar.gz
8 Source2:        fuse.rpmlintrc
9 Source98:       baselibs.conf
10 Url:            http://fuse.sourceforge.net
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
12 Requires:       util-linux >= 2.18
13 BuildRequires:  pkgconfig
14 Supplements:    filesystem(fuse)
15
16 %description
17 With FUSE, a user space program can export a file system through the
18 kernel-default (Linux kernel).
19
20 User space file systems which are implemented using FUSE are provided
21 by the following packages:
22
23 - curlftpfs (mount FTP servers),
24
25 - encfs (layered file encryption),
26
27 - fuseiso (mount iso, img, bin, mdf and nrg CD-ROM images),
28
29 - fusepod (mount iPods),
30
31 - fusesmb (mount a fully browseable network neighborhood),
32
33 - gphotofs (mount gphoto-supported cameras),
34
35 - ntfs-3g (mount NTFS volumes read-write),
36
37 - obexfs (mount of bluetooth devices),
38
39 - sshfs (mount over ssh),
40
41 - wdfs (mount of WebDAV shares)
42
43 This package contains the mount binaries for fuse (might not be needed
44 by some FUSE filesystems like ntfs-3g) and the documentation for FUSE.
45
46 After installing fuse-devel, administrators can compile and install
47 other user space file systems which can be found at
48 http://fuse.sourceforge.net/wiki
49
50 %package -n libulockmgr
51 Summary:        Library of FUSE, the User space File System for GNU/Linux and BSD
52 Group:          System/Filesystems
53
54 %description -n libulockmgr
55 With FUSE, a user space program can export a file system through the
56 kernel-default (Linux kernel).
57
58 %package -n libfuse
59 Summary:        Library of FUSE, the User space File System for GNU/Linux and BSD
60 Group:          System/Filesystems
61
62 %description -n libfuse
63 With FUSE, a user space program can export a file system through the
64 kernel-default (Linux kernel).
65
66 A FUSE file system which only needs libfuse is ntfs-3g, other FUSE
67 file systems might need the fuse package in addition to have fusermount
68 and /sbin/mount.fuse.
69
70 After installing fuse-devel, administrators can compile and install
71 other user space file systems which can be found at
72 http://fuse.sourceforge.net/wiki
73
74 %package devel
75 Summary:        Development package for FUSE (userspace filesystem) modules
76 Group:          Development/Languages/C and C++
77 Requires:       fuse = %{version}
78 Requires:       glibc-devel
79 Requires:       libfuse = %{version}
80 Requires:       libulockmgr = %{version}
81
82 %description devel
83 This package contains all include files, libraries and configuration
84 files needed to develop programs that use the fuse (FUSE) library to
85 implement kernel-default (Linux) file systems in user space.
86
87 With fuse-devel, administrators can compile and install other user
88 space file systems which can be found at
89 http://fuse.sourceforge.net/wiki
90
91 %prep
92 %setup -q
93
94 %build
95 export CFLAGS="$RPM_OPT_FLAGS -g -fno-strict-aliasing"
96 export MOUNT_FUSE_PATH=%{_sbindir}
97 %configure --with-pic \
98     --with-pkgconfigdir=%{_libdir}/pkgconfig \
99     --enable-lib \
100     --enable-util 
101 make %{?_smp_mflags}
102
103 %install
104 %make_install
105 rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/init.d
106
107 %post -n libfuse -p /sbin/ldconfig
108
109 %postun -n libfuse -p /sbin/ldconfig
110
111 %post -n libulockmgr -p /sbin/ldconfig
112
113 %postun -n libulockmgr -p /sbin/ldconfig
114
115
116 %docs_package
117
118 %files
119 %defattr(-,root,root)
120 %license COPYING*
121 %verify(not mode) %attr(4750,root,trusted) %{_bindir}/fusermount
122 %{_sbindir}/mount.fuse
123 %{_bindir}/ulockmgr_server
124
125 %files -n libfuse
126 %defattr(-,root,root)
127 %{_libdir}/libfuse.so.2*
128
129 %files -n libulockmgr
130 %defattr(-,root,root)
131 %{_libdir}/libulockmgr.so.*
132
133 %files devel
134 %defattr(-,root,root)
135 %doc  doc
136 %{_libdir}/libfuse.so
137 %{_libdir}/libulockmgr.so
138 %{_includedir}/fuse.h
139 %{_includedir}/fuse
140 %{_libdir}/pkgconfig/*.pc
141 %{_includedir}/ulockmgr.h