b604553995cde9dcf9e46ad83c226609d549499e
[platform/upstream/fontconfig.git] / packaging / fontconfig.spec
1 %global freetype_version 2.9.0
2
3 Name:           fontconfig
4 Summary:        Font configuration and customization library
5 Version:        2.13.0
6 Release:        1
7 Group:          Graphics & UI Framework/Fonts
8 License:        MIT
9 URL:            http://fontconfig.org
10 Source0:        http://fontconfig.org/release/fontconfig-%{version}.tar.gz
11 Source100:      fontconfig.conf
12 Source1001:     fontconfig.manifest
13 BuildRequires:  pkgconfig(freetype2) >= %{freetype_version}
14 BuildRequires:  gawk
15 BuildRequires:  expat-devel
16 BuildRequires:  perl
17 BuildRequires:  gperf
18 BuildRequires:  python
19 BuildRequires:  systemd-devel
20 BuildRequires:  gettext-tools
21 BuildRequires:  libuuid-devel
22 BuildRequires:  pkgconfig(libtzplatform-config)
23 Requires(pre):  %{TZ_SYS_BIN}/fc-cache, %{TZ_SYS_BIN}/mkdir %{TZ_SYS_BIN}/rm, %{TZ_SYS_BIN}/grep, %{TZ_SYS_BIN}/chsmack
24 Requires(post): /sbin/ldconfig
25 Requires(postun): /sbin/ldconfig
26
27 %description
28 Fontconfig is designed to locate fonts within the
29 system and select them according to requirements specified by
30 applications.
31
32 %package devel
33 Summary:        Font configuration and customization library
34 Group:          Graphics & UI Framework/Fonts
35 Requires:       %{name} = %{version}
36 Requires:       fontconfig = %{version}
37 Requires:       freetype-devel >= %{freetype_version}
38 Requires:       pkg-config
39
40 %description devel
41 The fontconfig-devel package includes the header files,
42 and developer docs for the fontconfig package.
43
44 Install fontconfig-devel if you want to develop programs which
45 will use fontconfig.
46
47 %prep
48 %setup -q
49 cp %{SOURCE1001} .
50
51 %build
52 # We don't want to rebuild the docs, but we want to install the included ones.
53 export HASDOCBOOK=no
54
55 %reconfigure --disable-static \
56     --with-expat=%{_prefix} \
57     --with-expat-include=%{_includedir} \
58     --with-expat-lib=%{_libdir} \
59     --with-freetype-config=%{TZ_SYS_BIN}/freetype-config \
60     --with-add-fonts=%{TZ_SYS_RO_SHARE}/fonts,%{TZ_SYS_RO_SHARE}/app_fonts,%{TZ_SYS_RO_SHARE}/fallback_fonts,%{TZ_SYS_SHARE}/fonts \
61     --with-cache-dir=%{TZ_SYS_VAR}/cache/fontconfig \
62     --with-baseconfigdir=%{TZ_SYS_RO_ETC}/fonts \
63     --with-configdir=%{TZ_SYS_RO_ETC}/fonts/conf.d \
64     --with-templatedir=%{TZ_SYS_RO_ETC}/fonts/conf.avail \
65     --with-xmldir=%{TZ_SYS_RO_ETC}/fonts \
66     --disable-docs
67
68 make %{?jobs:-j%jobs}
69
70 #make check
71 %install
72 rm -rf %{buildroot}
73
74 %make_install
75
76 mkdir -p %{buildroot}%{_tmpfilesdir}
77 install -m 0644 %SOURCE100 %{buildroot}%{_tmpfilesdir}/fontconfig.conf
78
79 # All font packages depend on this package, so we create
80 # and own /usr/share/fonts
81 mydir=$RPM_BUILD_ROOT%{TZ_SYS_RO_SHARE}/fonts
82 mkdir -p $RPM_BUILD_ROOT%{TZ_SYS_RO_SHARE}/fonts
83
84 # Remove unpackaged files. no need when configure --disable-static
85 #rm $RPM_BUILD_ROOT%{_libdir}/*.la
86 #rm $RPM_BUILD_ROOT%{_libdir}/*.a
87
88 %post
89 /sbin/ldconfig
90
91 umask 0022
92
93 mkdir -p %{TZ_SYS_RO_SHARE}/fonts
94 mkdir -p %{TZ_SYS_RO_SHARE}/fallback_fonts
95 mkdir -p %{TZ_SYS_RO_SHARE}/app_fonts
96
97 mkdir -p %{TZ_SYS_VAR}/cache/fontconfig
98 chown root:root %{TZ_SYS_VAR}/cache/fontconfig
99 chmod 755 %{TZ_SYS_VAR}/cache/fontconfig
100 chsmack -t %{TZ_SYS_VAR}/cache/fontconfig
101 chsmack -a User::App::Shared %{TZ_SYS_VAR}/cache/fontconfig
102
103 mkdir -p %{TZ_SYS_SHARE}/fonts
104 chown app_fw:users %{TZ_SYS_SHARE}/fonts
105 chmod 755 %{TZ_SYS_SHARE}/fonts
106 chsmack -t %{TZ_SYS_SHARE}/fonts
107 chsmack -a User::App::Shared %{TZ_SYS_SHARE}/fonts
108
109 # Skip making fontconfig cache folder for users. (/opt/home/app/.cache)
110 # The path will be changed according to a name of user.
111 #rm -rf %{TZ_USER_CACHE}/fontconfig
112 #mkdir -p %{TZ_USER_CACHE}/fontconfig
113 #chmod 755 %{TZ_USER_CACHE}
114 #chown app:app %{TZ_USER_CACHE}
115 #chsmack -t %{TZ_USER_CACHE}
116 #chsmack -a System::Shared %{TZ_USER_CACHE}
117 #chmod 755 %{TZ_USER_CACHE}/fontconfig
118 #chown app:app %{TZ_USER_CACHE}/fontconfig
119 #chsmack -t %{TZ_USER_CACHE}/fontconfig
120 #chsmack -a System::Shared %{TZ_USER_CACHE}/fontconfig
121
122 # remove 49-sansserif.conf to fix bmc #9024
123 #rm -rf /usr/%{_sysconfdir}/fonts/conf.d/49-sansserif.conf
124
125 # Force regeneration of all fontconfig cache files
126 # The check for existance is needed on dual-arch installs (the second
127 #  copy of fontconfig might install the binary instead of the first)
128 # The HOME setting is to avoid problems if HOME hasn't been reset
129 #if [ -x %{TZ_SYS_BIN}/fc-cache ] && %{TZ_SYS_BIN}/fc-cache --version 2>&1 | grep -q %{version} ; then
130 #fc-cache -rf --system-only
131 #fi
132
133 %postun -p /sbin/ldconfig
134
135 %files
136 %manifest fontconfig.manifest
137 %defattr(-,root,root,-)
138 %defattr(-, root, root)
139 %doc README AUTHORS COPYING
140 %{_libdir}/libfontconfig.so.*
141 %{TZ_SYS_BIN}/fc-*
142 %{TZ_SYS_RO_ETC}/fonts/*
143 %dir %{TZ_SYS_RO_ETC}/fonts/conf.avail
144 %dir %{TZ_SYS_RO_SHARE}/fonts
145 %{TZ_SYS_RO_SHARE}/gettext/its/fontconfig*
146 %{TZ_SYS_RO_SHARE}/locale/*/*/fontconfig*
147 %doc %{TZ_SYS_RO_ETC}/fonts/conf.d/README
148 %config %{TZ_SYS_RO_ETC}/fonts/conf.avail/*.conf
149 %config(noreplace) %{TZ_SYS_RO_ETC}/fonts/conf.d/*.conf
150 %{_tmpfilesdir}/fontconfig.conf
151 %license COPYING
152
153 %files devel
154 %manifest fontconfig.manifest
155 %defattr(-,root,root,-)
156 %defattr(-, root, root)
157 %{_libdir}/libfontconfig.so
158 %{_libdir}/pkgconfig/*
159 %{_includedir}/fontconfig
160