resetting manifest requested domain to floor
[platform/upstream/flac.git] / packaging / flac.spec
1 Name:           flac
2 BuildRequires:  gcc-c++
3 BuildRequires:  gettext-tools
4 BuildRequires:  libogg-devel
5 BuildRequires:  libtool
6 BuildRequires:  pkg-config
7 %ifarch %{ix86}
8 BuildRequires:  nasm
9 %endif
10 Version:        1.2.1
11 Release:        0
12 License:        BSD-3-Clause
13 Summary:        Free Lossless Audio Codec
14 Url:            http://flac.sourceforge.net/
15 Group:          Multimedia/Audio
16 Source:         %{name}-%{version}.tar.bz2
17 Source1001:     flac.manifest
18
19 %description
20 FLAC is an open source lossless audio codec developed by Josh Coalson.
21
22 %package -n libflac
23 Summary:        Free Lossless Audio Codec Library
24
25 %description -n libflac
26 This package contains the library for FLAC (Free Lossless Audio Codec)
27 developed by Josh Coalson.
28
29 %package -n libflac++
30 Summary:        Free Lossless Audio Codec Library
31
32 %description -n libflac++
33 This package contains the C++ library for FLAC (Free Lossless Audio
34 Codec) developed by Josh Coalson.
35
36 %package devel
37 Summary:        FLAC Library Development Package
38 Requires:       glibc-devel
39 Requires:       libflac = %{version}
40 Requires:       libflac = %{version}
41 Requires:       libstdc++-devel
42
43 %description devel
44 This package contains the files needed to compile programs that use the
45 FLAC library.
46
47 %prep
48 %setup -q
49 cp %{SOURCE1001} .
50
51 %build
52 autoreconf --force --install
53 %define warn_flags -O3 -W -Wall -Wstrict-prototypes -Wformat-security
54 export CFLAGS="%{optflags} %{warn_flags}"
55 export CXXFLAGS="$CFLAGS"
56 %configure  --disable-thorough-tests --disable-exhaustive-tests\
57     --disable-xmms-plugin \
58         --disable-static \
59         --disable-rpath \
60         --with-pic \
61     --enable-sse
62
63 make %{?_smp_mflags}
64
65 %install
66 %make_install
67 rm -rf %{buildroot}%{_datadir}/doc/%{name}-%{version}
68
69 %post -n libflac -p /sbin/ldconfig
70
71 %postun -n libflac -p /sbin/ldconfig
72
73 %post -n libflac++ -p /sbin/ldconfig
74
75 %postun -n libflac++ -p /sbin/ldconfig
76
77 %files
78 %manifest %{name}.manifest
79 %defattr(-, root, root)
80 %license  COPYING.*
81 %{_bindir}/*
82 %{_mandir}/man*/*
83
84 %files -n libflac
85 %manifest %{name}.manifest
86 %defattr(-, root, root)
87 %{_libdir}/libFLAC.so.8*
88
89 %files -n libflac++
90 %manifest %{name}.manifest
91 %defattr(-, root, root)
92 %{_libdir}/libFLAC++.so.6*
93
94 %files devel
95 %manifest %{name}.manifest
96 %defattr(-, root, root)
97 %{_libdir}/lib*.so
98 %{_includedir}/*
99 %{_libdir}/pkgconfig/*.pc
100 %{_datadir}/aclocal/*.m4