Change make_build rpm macro
[platform/upstream/fdupes.git] / packaging / fdupes.spec
1 Name:           fdupes
2 Version:        2.1.2
3 Release:        0
4 License:        MIT
5 Summary:        Identifying or deleting duplicate files
6 Url:            http://premium.caribe.net/~adrian2/fdupes.html
7 Group:          Base/Compression
8 Source0:        %{name}-%{version}.tar.bz2
9 Source1:        macros.fdupes
10 Source1001:     fdupes.manifest
11
12 %description
13 FDUPES is a program for identifying or deleting duplicate files
14 residing within specified directories
15
16 %prep
17 %setup -q
18 cp %{SOURCE1001} .
19
20 %build
21 export CFLAGS+=" -fPIC"
22 export LDFLAGS+=" -pie"
23 %{reconfigure} --without-ncurses
24 %{__make} %{?_smp_mflags}
25
26 %install
27 install -D -m755 fdupes %{buildroot}%{_bindir}/fdupes
28 install -D -m644 fdupes.1 %{buildroot}%{_mandir}/man1/fdupes.1
29 install -D -m644 %{SOURCE1} %{buildroot}%{_sysconfdir}/rpm/macros.fdupes
30
31 %{remove_docs}
32
33 %files
34 %manifest %{name}.manifest
35 %license README
36 %{_bindir}/fdupes
37 %config %{_sysconfdir}/rpm