Bump to 3.8.0
[platform/upstream/evolution-data-server.git] / packaging / evolution-data-server.spec
1 %define baseline 3.7
2
3 %define USE_EVOLDAP 0
4 %define with_introspection 1
5
6 # should match configure.ac
7 %define so_edataserver 17
8 %define so_ecal 15
9 %define so_edata_cal 20
10 %define so_edata_book 17
11 %define so_ebook 14
12 %define so_camel 43
13 %define so_ebackend 6
14 %define _evo_version 3.8
15
16
17 Name:           evolution-data-server
18 Version:        3.8.0
19 Release:        0
20 Summary:        Evolution Data Server
21 License:        LGPL-2.0+
22 Group:          Development/Libraries
23 Url:            http://www.gnome.org
24 Source0:        http://download.gnome.org/sources/evolution-data-server/%{baseline}/%{name}-%{version}.tar.xz
25 Source98:       baselibs.conf
26 BuildRequires:  db4-devel
27 BuildRequires:  fdupes
28 BuildRequires:  gcc-c++
29 BuildRequires:  gettext-tools
30 BuildRequires:  glibc-locale
31 BuildRequires:  gnome-common
32 BuildRequires:  gperf
33 BuildRequires:  gtk-doc
34 BuildRequires:  intltool
35 BuildRequires:  vala
36 BuildRequires:  pkgconfig(gcr-base-3) >= 3.4
37 BuildRequires:  pkgconfig(goa-1.0) >= 3.2
38 BuildRequires:  pkgconfig(gobject-introspection-1.0)
39 BuildRequires:  pkgconfig(gtk+-3.0)
40 BuildRequires:  pkgconfig(gweather-3.0) >= 3.5.0
41 BuildRequires:  pkgconfig(libIDL-2.0)
42 BuildRequires:  pkgconfig(libgdata) >= 0.10
43 BuildRequires:  pkgconfig(libical) >= 0.43
44 BuildRequires:  pkgconfig(libsecret-unstable) >= 0.5
45 BuildRequires:  pkgconfig(libsoup-2.4) >= 2.40.3
46 BuildRequires:  pkgconfig(nss)
47 BuildRequires:  pkgconfig(oauth)
48 BuildRequires:  pkgconfig(python-2.7)
49 BuildRequires:  pkgconfig(sqlite3) >= 3.5
50
51 Recommends:     %{name}-locale = %{version}
52 %ifarch  %ix86
53 Obsoletes:      evolution-data-server-32bit
54 %endif
55 Requires(post): glib2-tools
56 Requires(postun): glib2-tools
57
58 %description
59 Evolution Data Server provides a central location for your address book
60 and calendar in the GNOME Desktop.
61
62
63 %package -n libcamel
64 Summary:        Evolution Data Server - Messaging Library
65 Group:          System/Libraries
66
67 %description -n libcamel
68 Evolution Data Server provides a central location for your address book
69 and calendar in the GNOME Desktop.
70
71 This package contains a shared system library for messaging.
72
73
74 %package -n libebackend
75 Summary:        Evolution Data Server - Backend Utilities Library
76 Group:          System/Libraries
77
78 %description -n libebackend
79 Evolution Data Server provides a central location for your address book
80 and calendar in the GNOME Desktop.
81
82 This package contains a shared system library for backends.
83
84
85 %package -n libebook
86 Summary:        Evolution Data Server - Address Book Client Library
87 Group:          System/Libraries
88
89 %description -n libebook
90 Evolution Data Server provides a central location for your address book
91 and calendar in the GNOME Desktop.
92
93 This package contains a shared system library to access address books.
94
95
96 %package -n libebook-contacts
97 Summary:        Evolution Data Server - Address Book Client Library
98 Group:          System/Libraries
99
100 %description -n libebook-contacts
101 Evolution Data Server provides a central location for your address book
102 and calendar in the GNOME Desktop.
103
104 This package contains a shared system library to access address books.
105
106
107 %if %{?with_introspection}
108
109 %package -n typelib-EBookContacts
110 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
111 Group:          System/Libraries
112
113 %description -n typelib-EBookContacts
114 Evolution Data Server provides a central location for your address book
115 and calendar in the GNOME Desktop.
116
117 This package provides the GObject Introspection bindings for the library
118 for address book contacts.
119 %endif
120
121
122 %package -n libecal
123 Summary:        Evolution Data Server - Calendar Client Library
124 Group:          System/Libraries
125
126 %description -n libecal
127 Evolution Data Server provides a central location for your address book
128 and calendar in the GNOME Desktop.
129
130 This package contains a shared system library to access calendars.
131
132 %package -n libedata-book
133 Summary:        Evolution Data Server - Address Book Backend Library
134 Group:          System/Libraries
135
136 %description -n libedata-book
137 Evolution Data Server provides a central location for your address book
138 and calendar in the GNOME Desktop.
139
140 This package contains a shared system library for address book backends.
141
142
143 %if %{?with_introspection}
144
145 %package -n typelib-EBook
146 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
147 Group:          System/Libraries
148
149 %description -n typelib-EBook
150 Evolution Data Server provides a central location for your address book
151 and calendar in the GNOME Desktop.
152
153 This package provides the GObject Introspection bindings for the library
154 for address book backends.
155 %endif
156
157
158 %package -n libedata-cal
159 Summary:        Evolution Data Server - Calendar Backend Library
160 Group:          System/Libraries
161
162 %description -n libedata-cal
163 Evolution Data Server provides a central location for your address book
164 and calendar in the GNOME Desktop.
165
166 This package contains a shared system library for calendar backends.
167
168
169 %package -n libedataserver
170 Summary:        Evolution Data Server - Utilities Library
171 Group:          System/Libraries
172
173 %description -n libedataserver
174 Evolution Data Server provides a central location for your address book
175 and calendar in the GNOME Desktop.
176
177 This package contains a shared system library.
178
179
180 %if %{?with_introspection}
181
182 %package -n typelib-EDataServer
183 Summary:        Evolution Data Server - Utilities Library, Introspection bindings
184 Group:          System/Libraries
185
186 %description -n typelib-EDataServer
187 Evolution Data Server provides a central location for your address book
188 and calendar in the GNOME Desktop.
189
190 This package provides the GObject Introspection bindings for the
191 libedataserver library.
192
193 %endif
194
195
196 %package devel
197 Summary:        Evolution Data Server - Development Files
198 Group:          Development/Libraries
199 Requires:       evolution-data-server = %{?epoch:}%{version}
200 Requires:       libcamel = %{version}
201 Requires:       libebackend = %{version}
202 Requires:       libebook = %{version}
203 Requires:       libecal = %{version}
204 Requires:       libedata-book = %{version}
205 Requires:       libedata-cal = %{version}
206 Requires:       libedataserver = %{version}
207 %if %{?with_introspection}
208 Requires:       typelib-EBook = %{version}
209 Requires:       typelib-EDataServer = %{version}
210 %endif
211 Requires(post):   /sbin/ldconfig
212 Requires(postun): /sbin/ldconfig
213
214 %description devel
215 The Evolution Data Server development files provide the necessary
216 libraries, headers, and other files for developing applications which
217 use the Evolution Data Server for storing contact and calendar
218 information.
219
220
221 %package doc
222 Summary:        Evolution Data Server - Developer Documentation
223 Group:          Documentation
224 Requires:       %{name} = %{version}
225
226 %description doc
227 Evolution Data Server provides a central location for your address book
228 and calendar in the GNOME Desktop.
229
230 This package contains developer documentation.
231
232 %prep
233 %setup -q
234
235 %build
236
237 %autogen \
238  --libexecdir=%{_libexecdir}/evolution-data-server \
239  --enable-ipv6=yes \
240  --enable-smime=yes \
241  --enable-nntp=yes \
242  --disable-static \
243  --disable-uoa \
244 %if %{?with_introspection}
245  --enable-vala-bindings \
246  --enable-introspection \
247 %else
248  --disable-vala-bindings \
249  --disable-introspection \
250 %endif
251  # end of configure line
252
253 make %{?_smp_mflags} V=1
254
255 %install
256 %make_install
257 %find_lang evolution-data-server-%{_evo_version}
258 mv evolution-data-server-%{_evo_version}.lang evolution-data-server.lang
259 %fdupes %{buildroot}
260
261 %lang_package
262
263 %post
264 %glib2_gsettings_schema_post
265
266 %postun
267 %glib2_gsettings_schema_postun
268
269 %post -n libcamel -p /sbin/ldconfig
270
271 %postun -n libcamel -p /sbin/ldconfig
272
273 %post -n libebackend -p /sbin/ldconfig
274
275 %postun -n libebackend -p /sbin/ldconfig
276
277 %post -n libebook -p /sbin/ldconfig
278
279 %postun -n libebook -p /sbin/ldconfig
280
281 %post -n libebook-contacts -p /sbin/ldconfig
282
283 %postun -n libebook-contacts -p /sbin/ldconfig
284
285 %post -n  libecal -p /sbin/ldconfig
286
287 %postun -n  libecal -p /sbin/ldconfig
288
289 %post -n libedata-book -p /sbin/ldconfig
290
291 %postun -n libedata-book -p /sbin/ldconfig
292
293 %post -n libedata-cal -p /sbin/ldconfig
294
295 %postun -n libedata-cal -p /sbin/ldconfig
296
297 %post -n libedataserver -p /sbin/ldconfig
298
299 %postun -n libedataserver -p /sbin/ldconfig
300
301
302 %files
303 %defattr(-,root,root)
304 %license COPYING
305 %{_datadir}/GConf/gsettings/evolution-data-server.convert
306 %{_datadir}/GConf/gsettings/libedataserver.convert
307 %{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
308 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
309 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
310 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
311 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
312 %{_datadir}/pixmaps/evolution-data-server/
313 %{_datadir}/dbus-1/services/org.gnome.evolution.dataserver.*.service
314 %{_libdir}/evolution-data-server/
315 %if "%{_libdir}" != "%{_libexecdir}"
316 %{_libexecdir}/evolution-data-server/
317 %endif
318
319
320 %files -n libcamel
321 %defattr(-, root, root)
322 %{_libdir}/libcamel-1.2.so.%{so_camel}*
323
324
325 %files -n libebackend
326 %defattr(-, root, root)
327 %{_libdir}/libebackend-1.2.so.%{so_ebackend}*
328
329
330 %files -n libebook
331 %defattr(-, root, root)
332 %{_libdir}/libebook-1.2.so.%{so_ebook}*
333
334
335 %if %{?with_introspection}
336 %files -n typelib-EBook
337 %defattr(-, root, root)
338 %{_libdir}/girepository-1.0/EBook-1.2.typelib
339 %endif
340
341
342 %files -n libebook-contacts
343 %defattr(-, root, root)
344 %{_libdir}/libebook-contacts-1.2.so.0*
345
346
347 %if %{?with_introspection}
348 %files -n typelib-EBookContacts
349 %defattr(-, root, root)
350 %{_libdir}/girepository-1.0/EBookContacts-1.2.typelib
351 %endif
352
353
354 %files -n libecal
355 %defattr(-, root, root)
356 %{_libdir}/libecal-1.2.so.%{so_ecal}*
357
358
359 %files -n libedata-book
360 %defattr(-, root, root)
361 %{_libdir}/libedata-book-1.2.so.%{so_edata_book}*
362
363
364 %files -n libedata-cal
365 %defattr(-, root, root)
366 %{_libdir}/libedata-cal-1.2.so.%{so_edata_cal}*
367
368
369 %files -n libedataserver
370 %defattr(-, root, root)
371 %{_libdir}/libedataserver-1.2.so.%{so_edataserver}*
372
373
374 %if %{?with_introspection}
375 %files -n typelib-EDataServer
376 %defattr(-, root, root)
377 %{_libdir}/girepository-1.0/EDataServer-1.2.typelib
378 %endif
379
380
381 %files devel
382 %defattr(-, root, root)
383 %{_includedir}/evolution-data-server/
384 %{_libdir}/*.so
385 %{_libdir}/pkgconfig/*.pc
386 %if %{?with_introspection}
387 %{_datadir}/gir-1.0/*.gir
388 %dir %{_datadir}/vala
389 %dir %{_datadir}/vala/vapi
390 %{_datadir}/vala/vapi/*.deps
391 %{_datadir}/vala/vapi/*.vapi
392 %endif