45c908f3278625515ec3d3290756c7f8a5cd8075
[platform/upstream/evas.git] / packaging / evas.spec
1 %bcond_with wayland
2 Name:           evas
3 Version:        1.7.7
4 Release:        1
5 License:        BSD 2-clause
6 Summary:        Multi-platform Canvas Library
7 Url:            http://www.enlightenment.org/
8 Group:          Graphics/EFL
9 Source0:        evas-%{version}.tar.bz2
10 BuildRequires:  doxygen
11 BuildRequires:  giflib-devel
12 BuildRequires:  libjpeg-devel
13 BuildRequires:  pkgconfig(eet)
14 BuildRequires:  pkgconfig(eina)
15 BuildRequires:  pkgconfig(fontconfig)
16 BuildRequires:  pkgconfig(freetype2)
17 BuildRequires:  pkgconfig(fribidi)
18 BuildRequires:  pkgconfig(gl)
19 BuildRequires:  pkgconfig(glesv2)
20 BuildRequires:  pkgconfig(harfbuzz)
21 BuildRequires:  pkgconfig(ice)
22 BuildRequires:  pkgconfig(libpng)
23 BuildRequires:  pkgconfig(libtiff-4)
24 BuildRequires:  pkgconfig(pixman-1)
25 BuildRequires:  pkgconfig(x11)
26 BuildRequires:  pkgconfig(xext)
27 BuildRequires:  pkgconfig(xrender)
28 %if %{with wayland}
29 BuildRequires:  pkgconfig(egl)
30 BuildRequires:  pkgconfig(wayland-client)
31 BuildRequires:  pkgconfig(wayland-cursor)
32 BuildRequires:  pkgconfig(wayland-egl)
33 BuildRequires:  pkgconfig(xkbcommon)
34 %endif
35
36 %description
37 Evas is a clean display canvas API for several target display systems
38 that can draw anti-aliased text, smooth super and sub-sampled scaled
39 images, alpha-blend objects much and more.
40
41 %package devel
42 Summary:        Development components for the evas package
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}
45
46 %description devel
47 Development files for evas
48
49 %package examples
50 Summary:        Examples for the evas package
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}
53
54 %description examples
55 Examples files for evas
56
57 %prep
58 %setup -q
59
60 %build
61 %configure --enable-pthreads \
62 %if %{with wayland}
63             --enable-gles-variety-sgx \
64             --enable-wayland-egl \
65 %else
66             --enable-gl-xcb \
67             --with-x
68 %endif
69
70 make %{?_smp_mflags}
71
72 %install
73 %make_install
74
75 %post -p /sbin/ldconfig
76
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(-,root,root,-)
81 %license COPYING
82 %{_bindir}/evas_cserve*
83 %{_libdir}/evas/modules/*/*/*/module.so
84 %{_libdir}/libevas.so.*
85 %{_libdir}/evas/cserve2
86 %{_prefix}/libexec/*
87 %{_datadir}/evas/checkme
88
89 %files devel
90 %defattr(-,root,root,-)
91 %{_includedir}/evas-1/*.h
92 %{_libdir}/*.so
93 %{_libdir}/pkgconfig/*.pc
94
95
96 %files examples
97 %{_datadir}/evas/examples/*
98
99 %changelog