79d78307c00a6ec3b87f4c427d72f05b698b666e
[platform/upstream/elfutils.git] / elfutils.spec
1 # -*- rpm-spec-*-
2 Summary: A collection of utilities and DSOs to handle compiled objects
3 Name: elfutils
4 Version: 0.160
5 Release: 1
6 License: GPLv3+ and (GPLv2+ or LGPLv3+)
7 Group: Development/Tools
8 Source: elfutils-%{version}.tar.bz2
9 Obsoletes: libelf libelf-devel
10 Requires: elfutils-libelf = %{version}-%{release}
11 Requires: glibc >= 2.7
12 Requires: libstdc++
13
14 # ExcludeArch: xxx
15
16 BuildRoot: %{_tmppath}/%{name}-root
17 BuildRequires: gcc >= 4.1.2-33
18 BuildRequires: glibc >= 2.7
19 BuildRequires: bison >= 1.875
20 BuildRequires: flex >= 2.5.4a
21 BuildRequires: bzip2
22 BuildRequires: m4
23 BuildRequires: gettext
24 BuildRequires: zlib-devel
25 BuildRequires: bzip2-devel
26 BuildRequires: xz-devel
27 BuildRequires: gcc-c++
28
29 %define _gnu %{nil}
30 %define _programprefix eu-
31
32 %description
33 Elfutils is a collection of utilities, including ld (a linker),
34 nm (for listing symbols from object files), size (for listing the
35 section sizes of an object or archive file), strip (for discarding
36 symbols), readelf (to see the raw ELF file structures), and elflint
37 (to check for well-formed ELF files).  Also included are numerous
38 helper libraries which implement DWARF, ELF, and machine-specific ELF
39 handling.
40
41 %package devel
42 Summary: Development libraries to handle compiled objects.
43 Group: Development/Tools
44 License: GPLv2+ or LGPLv3+
45 Requires: elfutils = %{version}-%{release}
46 Requires: elfutils-libelf-devel = %{version}-%{release}
47
48 %description devel
49 The elfutils-devel package contains the libraries to create
50 applications for handling compiled objects.  libebl provides some
51 higher-level ELF access functionality.  libdw provides access to
52 the DWARF debugging information.  libasm provides a programmable
53 assembler interface.
54
55 %package devel-static
56 Summary: Static archives to handle compiled objects.
57 Group: Development/Tools
58 License: GPLv2+ or LGPLv3+
59 Requires: elfutils-devel = %{version}-%{release}
60
61 %description devel-static
62 The elfutils-devel-static archive contains the static archives
63 with the code the handle compiled objects.
64
65 %package libelf
66 Summary: Library to read and write ELF files.
67 Group: Development/Tools
68 License: GPLv2+ or LGPLv3+
69
70 %description libelf
71 The elfutils-libelf package provides a DSO which allows reading and
72 writing ELF files on a high level.  Third party programs depend on
73 this package to read internals of ELF files.  The programs of the
74 elfutils package use it also to generate new ELF files.
75
76 %package libelf-devel
77 Summary: Development support for libelf
78 Group: Development/Tools
79 License: GPLv2+ or LGPLv3+
80 Requires: elfutils-libelf = %{version}-%{release}
81 Conflicts: libelf-devel
82
83 %description libelf-devel
84 The elfutils-libelf-devel package contains the libraries to create
85 applications for handling compiled objects.  libelf allows you to
86 access the internals of the ELF object file format, so you can see the
87 different sections of an ELF file.
88
89 %package libelf-devel-static
90 Summary: Static archive of libelf
91 Group: Development/Tools
92 License: GPLv2+ or LGPLv3+
93 Requires: elfutils-libelf-devel = %{version}-%{release}
94 Conflicts: libelf-devel
95
96 %description libelf-devel-static
97 The elfutils-libelf-static package contains the static archive
98 for libelf.
99
100 %prep
101 %setup -q
102
103 %build
104 %configure --program-prefix=%{_programprefix}
105 make
106
107 %install
108 rm -rf ${RPM_BUILD_ROOT}
109 mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
110
111 %makeinstall
112
113 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
114 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
115
116 # XXX Nuke unpackaged files
117 { cd ${RPM_BUILD_ROOT}
118   rm -f .%{_bindir}/eu-ld
119   rm -f .%{_includedir}/elfutils/libasm.h
120   rm -f .%{_libdir}/libasm.so
121   rm -f .%{_libdir}/libasm.a
122 }
123
124 %check
125 make check
126
127 %clean
128 rm -rf ${RPM_BUILD_ROOT}
129
130 %post -p /sbin/ldconfig
131
132 %postun -p /sbin/ldconfig
133
134 %post libelf -p /sbin/ldconfig
135
136 %postun libelf -p /sbin/ldconfig
137
138 %files
139 %defattr(-,root,root)
140 %doc COPYING COPYING-GPLV2 COPYING-LGPLV3 README TODO CONTRIBUTING
141 %{_bindir}/eu-elflint
142 %{_bindir}/eu-nm
143 %{_bindir}/eu-readelf
144 %{_bindir}/eu-size
145 %{_bindir}/eu-strip
146 %{_bindir}/eu-findtextrel
147 %{_bindir}/eu-addr2line
148 %{_bindir}/eu-elfcmp
149 %{_bindir}/eu-ranlib
150 %{_bindir}/eu-strings
151 %{_bindir}/eu-objdump
152 %{_bindir}/eu-ar
153 %{_bindir}/eu-unstrip
154 %{_bindir}/eu-make-debug-archive
155 #%{_bindir}/eu-ld
156 %{_libdir}/libasm-%{version}.so
157 %{_libdir}/libdw-%{version}.so
158 %{_libdir}/libasm.so.*
159 %{_libdir}/libdw.so.*
160 %dir %{_libdir}/elfutils
161 %{_libdir}/elfutils/lib*.so
162
163 %files devel
164 %defattr(-,root,root)
165 %{_includedir}/dwarf.h
166 %dir %{_includedir}/elfutils
167 %{_includedir}/elfutils/elf-knowledge.h
168 #%{_includedir}/elfutils/libasm.h
169 %{_includedir}/elfutils/libebl.h
170 %{_includedir}/elfutils/libdw.h
171 %{_includedir}/elfutils/libdwfl.h
172 %{_includedir}/elfutils/libdwelf.h
173 %{_libdir}/libebl.a
174 #%{_libdir}/libasm.so
175 %{_libdir}/libdw.so
176
177 %files devel-static
178 %{_libdir}/libdw.a
179 #%{_libdir}/libasm.a
180
181 %files libelf
182 %defattr(-,root,root)
183 %{_libdir}/libelf-%{version}.so
184 %{_libdir}/libelf.so.*
185 %{_datadir}/locale/*/LC_MESSAGES/elfutils.mo
186
187 %files libelf-devel
188 %defattr(-,root,root)
189 %{_includedir}/libelf.h
190 %{_includedir}/gelf.h
191 %{_includedir}/nlist.h
192 %{_includedir}/elfutils/version.h
193 %{_libdir}/libelf.so
194
195 %files libelf-devel-static
196 %{_libdir}/libelf.a
197
198 %changelog
199 * Mon Aug 25 2014 Mark Wielaard <mjw@redhat.com> 0.160-1
200 - libdw: New functions dwarf_cu_getdwarf, dwarf_cu_die.
201   dwarf.h remove non-existing DW_TAG_mutable_type.
202 - libdwfl: Handle LZMA .ko.xz compressed kernel modules.
203 - unstrip: New option -F, --force to combining files even if some ELF
204   headers don't seem to match.
205 - backends: Handle ARM THUMB functions. Add support for ppc64le ELFv2 abi.
206
207 * Sat May 17 2014 Mark Wielaard <mjw@redhat.com> 0.159-1
208 - stack: New option -d, --debugname to lookup DWARF debuginfo name 
209   for frame.  New option -i, --inlines to show inlined frames 
210   using DWARF debuginfo.
211 - libdwelf: New libdwelf.h header for libdw.so DWARF ELF Low-level 
212   Functions.  New function dwelf_elf_gnu_debuglink, 
213   dwelf_dwarf_gnu_debugaltlink, and dwelf_elf_gnu_build_id.
214 - libdw: Support for DWZ multifile forms DW_FORM_GNU_ref_alt and      
215   DW_FORM_GNU_strp_alt is now enabled by default and no longer        
216   experimental. Added new functions dwarf_getalt and dwarf_setalt       
217   to get or set the alternative debug file used for the alt FORMs.     
218   The dwfl_linux_proc_find_elf callback will now find ELF from       
219   process memory for (deleted) files if the Dwfl has process state     
220   attached.
221 - libdwfl: The dwfl_build_id_find_debuginfo and 
222   dwfl_standard_find_debuginfo functions will now try to 
223   resolve and set the alternative debug file.
224 - backends: Add CFI unwinding for arm. Relies on .debug_frame.        
225   Add arm process initial register state compatible mode to AARCH64. 
226   Add aarch64 native and core unwind support.
227 - other: All separate elfutils-robustify patches have been merged.    
228   CVE-2014-0172 Check overflow before calling malloc to uncompress 
229   data.
230
231 * Fri Jan  3 2014 Mark Wielaard <mjw@redhat.com> 0.158-1
232 - libdwfl: dwfl_core_file_report has new parameter executable.
233   New functions dwfl_module_getsymtab_first_global,
234   dwfl_module_getsym_info and dwfl_module_addrinfo.
235   Added unwinder with type Dwfl_Thread_Callbacks, opaque types
236   Dwfl_Thread and Dwfl_Frame and functions dwfl_attach_state,
237   dwfl_pid, dwfl_thread_dwfl, dwfl_thread_tid, dwfl_frame_thread,
238   dwfl_thread_state_registers, dwfl_thread_state_register_pc,
239   dwfl_getthread_frames, dwfl_getthreads, dwfl_thread_getframes
240   and dwfl_frame_pc.
241 - addr2line: New option -x to show the section an address was found in.
242 - stack: New utility that uses the new unwinder for processes and cores.
243 - backends: Unwinder support for i386, x86_64, s390, s390x, ppc and ppc64.
244   aarch64 support.
245
246 * Mon Sep 30 2013 Mark Wielaard <mjw@redhat.com> 0.157-1
247 - libdw: Add new functions dwarf_getlocations, dwarf_getlocation_attr 
248          and dwarf_getlocation_die.
249 - readelf: Show contents of NT_SIGINFO and NT_FILE core notes.
250 - addr2line: Support -i, --inlines output option.
251 - backends: abi_cfi hook for arm, ppc and s390.
252
253 * Thu Jul 25 2013 Jan Kratochvil <jan.kratochvil@redhat.com> 0.156-1
254 - lib: New macro COMPAT_VERSION_NEWPROTO.
255 - libdw: Handle GNU extension opcodes in dwarf_getlocation.
256 - libdwfl: Fix STB_GLOBAL over STB_WEAK preference in 
257   dwfl_module_addrsym.          Add minisymtab support.          Add 
258   parameter add_p_vaddr to dwfl_report_elf.          Use DT_DEBUG 
259   library search first.
260 - libebl: Handle new core note types in EBL.
261 - backends: Interpret NT_ARM_VFP.           Implement core file 
262   registers parsing for s390/s390x.
263 - readelf: Add --elf-section input option to inspect an embedded ELF 
264   file.          Add -U, --unresolved-address-offsets output control.   
265          Add --debug-dump=decodedline support.          Accept version 
266   8 .gdb_index section format.          Adjust output formatting width. 
267            When highpc is in constant form print it also as address.    
268         Display raw .debug_aranges. Use libdw only for decodedaranges.
269 - elflint: Add __bss_start__ to the list of allowed symbols.
270 - tests: Add configure --enable-valgrind option to run all tests 
271   under valgrind.        Enable automake parallel-tests for make check.
272 - translations: Updated Polish translation.
273 - Updates for Automake 1.13.
274
275 * Fri Aug 24 2012 Mark Wielaard <mjw@redhat.com> 0.155-1
276 - libelf: elf*_xlatetomd now works for cross-endian ELF note data.    
277        elf_getshdr now works consistently on non-mmaped ELF files after 
278           calling elf_cntl(ELF_C_FDREAD).         Implement support for 
279   ar archives with 64-bit symbol table.
280 - libdw: dwarf.h corrected the DW_LANG_ObjC constant name (was 
281   DW_LANG_Objc).        Any existing sources using the old name will 
282   have to be updated.        Add DW_MACRO_GNU .debug_macro type 
283   encodings constants, DW_ATE_UTF        and DW_OP_GNU_parameter_ref to 
284   dwarf.h.        Experimental support for DWZ multifile forms 
285   DW_FORM_GNU_ref_alt        and DW_FORM_GNU_strp_alt.  Disabled by 
286   default.  Use configure        --enable-dwz to test it.
287 - readelf: Add .debug_macro parsing support.          Add .gdb_index 
288   version 7 parsing support.          Recognize DW_OP_GNU_parameter_ref.
289 - backends: Add support for Tilera TILE-Gx processor.
290 - translations: Updated Ukrainian translation.
291
292 * Fri Jun 22 2012 Mark Wielaard <mjw@redhat.com> 0.154-1
293 - libelf: [g]elf[32|64]_offscn() do not match SHT_NOBITS sections at 
294   OFFSET.
295 - libdw: dwarf_highpc function now handles DWARF 4 DW_AT_high_pc 
296   constant form.        Fix bug using dwarf_next_unit to iterate over 
297   .debug_types.
298 - elflint: Now accepts gold linker produced executables.
299 - The license is now GPLv2/LGPLv3+ for the libraries and GPLv3+ for 
300   stand-alone programs. There is now also a formal CONTRIBUTING 
301   document describing how to submit patches.
302
303 * Thu Feb 23 2012 Mark Wielaard <mjw@redhat.com> 0.153-1
304 - libdw: Support reading .zdebug_* DWARF sections compressed via zlib.
305 - libdwfl: Speed up dwfl_module_addrsym.
306 - nm: Support C++ demangling.
307 - ar: Support D modifier for "deterministic output" with no 
308   uid/gid/mtime info.     The U modifier is the inverse.     elfutils 
309   can be configured with the --enable-deterministic-archives     option 
310   to make the D behavior the default when U is not specified.
311 - ranlib: Support -D and -U flags with same meaning.
312 - readelf: Improve output of -wline. Add support for printing SDT elf 
313   notes.          Add printing of .gdb_index section.    Support for 
314   typed DWARF stack, call_site and entry_value.
315 - strip: Add --reloc-debug-sections option.        Improved SHT_GROUP 
316   sections handling.
317
318 * Tue Feb 15 2011  <drepper@gmail.com> 0.152-1
319 - Various build and warning nits fixed for newest GCC and Autoconf.
320 - libdwfl: Yet another prelink-related fix for another regression.
321          Look for Linux kernel images in files named with compression
322   suffixes.
323 - elfcmp: New flag --ignore-build-id to ignore differing build ID
324   bits.         New flag -l/--verbose to print all differences.
325
326 * Wed Jan 12 2011  <drepper@gmail.com> 0.151-1
327 - libdwfl: Fix for more prelink cases with separate debug file.
328 - strip: New flag --strip-sections to remove section headers entirely.
329
330 * Mon Nov 22 2010  <drepper@gmail.com> 0.150-1
331 - libdw: Fix for handling huge .debug_aranges section.
332 - libdwfl: Fix for handling prelinked DSO with separate debug file.
333 - findtextrel: Fix diagnostics to work with usual section ordering.
334 - libebl: i386 backend fix for multi-register integer return value
335   location.
336
337 * Mon Sep 13 2010  <drepper@redhat.com> 0.149-1
338 - libdw: Decode new DW_OP_GNU_implicit_pointer operation;        new
339   function dwarf_getlocation_implicit_pointer.
340 - libdwfl: New function dwfl_dwarf_line.
341 - addr2line: New flag -F/--flags to print more DWARF line information
342   details.
343 - strip: -g recognizes .gdb_index as a debugging section.
344
345 * Mon Jun 28 2010  <drepper@redhat.com> 0.148-1
346 - libdw: Accept DWARF 4 format: new functions dwarf_next_unit,
347   dwarf_offdie_types.        New functions dwarf_lineisa,
348   dwarf_linediscriminator, dwarf_lineop_index.
349 - libdwfl: Fixes in core-file handling, support cores from PIEs.
350          When working from build IDs, don't open a named file that
351   mismatches.
352 - readelf: Handle DWARF 4 formats.
353
354 * Mon May  3 2010 Ulrich Drepper <drepper@redhat.com> 0.147-1
355 - libdw: Fixes in CFI handling, best possible handling of bogus CFA
356   ops.
357 - libdwfl: Ignore R_*_NONE relocs, works around old (binutils) ld -r
358   bugs.
359
360 * Wed Apr 21 2010  <drepper@redhat.com> 0.146-1
361 - libdwfl: New function dwfl_core_file_report.
362
363 * Tue Feb 23 2010 Ulrich Drepper <drepper@redhat.com> 0.145-1
364 - Fix build with --disable-dependency-tracking.
365 - Fix build with most recent glibc headers.
366 - libelf: More robust to bogus section headers.
367 - libdw: Fix CFI decoding.
368 - libdwfl: Fix address bias returned by CFI accessors.   Fix core
369   file module layout identification.
370 - readelf: Fix CFI decoding.
371
372 * Thu Jan 14 2010  <drepper@redhat.com> 0.144-1
373 - libelf: New function elf_getphdrnum.  Now support using more than
374   65536 program headers in a file.
375 - libdw: New function dwarf_aggregate_size for computing (constant)
376   type        sizes, including array_type cases with nontrivial
377   calculation.
378 - readelf: Don't give errors for missing info under -a.
379   Handle Linux "VMCOREINFO" notes under -n.
380
381 * Mon Sep 21 2009  <drepper@redhat.com> 0.143-1
382 - libdw: Various convenience functions for individual attributes now
383   use dwarf_attr_integrate to look up indirect inherited
384   attributes.  Location expression handling now supports
385   DW_OP_implicit_value.
386 - libdwfl: Support automatic decompression of files in XZ format,
387   and of Linux kernel images made with bzip2 or LZMA (as well
388   as gzip).
389
390 * Mon Jun 29 2009  <drepper@redhat.com> 0.142-1
391 - libelf: Add elf_getshdrnum alias for elf_getshnum and elf_getshdrstrndx alias
392   for elf_getshstrndx and deprecate original names.  Sun screwed up
393   their implementation and asked for a solution.
394 - libebl: Add support for STB_GNU_UNIQUE.
395 - elflint: Add support for STB_GNU_UNIQUE.
396 - readelf: Add -N option, speeds up DWARF printing without address->name lookups.
397 - libdw: Add support for decoding DWARF CFI into location description form.
398   Handle some new DWARF 3 expression operations previously omitted.
399   Basic handling of some new encodings slated for DWARF
400
401 * Thu Apr 23 2009 Ulrich Drepper <drepper@redhat.com> 0.141-1
402 - libebl: sparc backend fixes;  some more arm backend support
403 - libdwfl: fix dwfl_module_build_id for prelinked DSO case;
404   fixes in core file support;    dwfl_module_getsym interface
405   improved for non-address symbols
406 - strip: fix infinite loop on strange inputs with -f
407 - addr2line: take -j/--section=NAME option for binutils compatibility
408            (same effect as '(NAME)0x123' syntax already supported)
409
410 * Mon Feb 16 2009 Ulrich Drepper <drepper@redhat.com> 0.140-1
411 - libelf: Fix regression in creation of section header
412 - libdwfl: Less strict behavior if DWARF reader ist just used to
413   display data
414
415 * Thu Jan 22 2009 Ulrich Drepper <drepper@redhat.com> 0.139-1
416 - libcpu: Add Intel SSE4 disassembler support
417 - readelf: Implement call frame information and exception handling
418   dumping.          Add -e option.  Enable it implicitly for -a.
419 - elflint: Check PT_GNU_EH_FRAME program header entry.
420 - libdwfl: Support automatic gzip/bzip2 decompression of ELF files.
421
422 * Wed Dec 31 2008 Roland McGrath <roland@redhat.com> 0.138-1
423 - Install <elfutils/version.h> header file for applications to use in
424   source version compatibility checks.
425 - libebl: backend fixes for i386 TLS relocs; backend support for
426   NT_386_IOPERM
427 - libcpu: disassembler fixes
428 - libdwfl: bug fixes
429 - libelf: bug fixes
430 - nm: bug fixes for handling corrupt input files
431
432 * Tue Aug 26 2008 Ulrich Drepper <drepper@redhat.com> 0.137-1
433 - Minor fixes for unreleased 0.136 release.
434
435 * Mon Aug 25 2008 Ulrich Drepper <drepper@redhat.com> 0.136-1
436 - libdwfl: bug fixes; new segment interfaces;    all the libdwfl-based
437  tools now support --core=COREFILE option
438
439 * Mon May 12 2008 Ulrich Drepper <drepper@redhat.com> 0.135-1
440 - libdwfl: bug fixes
441 - strip: changed handling of ET_REL files wrt symbol tables and relocs
442
443 * Tue Apr  8 2008 Ulrich Drepper <drepper@redhat.com> 0.134-1
444 - elflint: backend improvements for sparc, alpha
445 - libdwfl, libelf: bug fixes
446
447 * Sat Mar  1 2008 Ulrich Drepper <drepper@redhat.com> 0.133-1
448 - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
449 - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
450 - libdwfl: bug fixes and optimization in relocation handling
451 - elfcmp: bug fix for non-allocated section handling
452 - ld: implement newer features of binutils linker.
453
454 * Mon Jan 21 2008 Ulrich Drepper <drepper@redhat.com> 0.132-1
455 - libcpu: Implement x86 and x86-64 disassembler.
456 - libasm: Add interface for disassembler.
457 - all programs: add debugging of branch prediction.
458 - libelf: new function elf_scnshndx.
459
460 * Sun Nov 11 2007 Ulrich Drepper <drepper@redhat.com> 0.131-1
461 - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now depreca
462 ted;       bug fixes for oddly-formatted DWARF
463 - libdwfl: bug fixes in offline archive support, symbol table handling;
464          apply partial relocations for dwfl_module_address_section on
465 ET_REL
466 - libebl: powerpc backend support for Altivec registers
467
468 * Mon Oct 15 2007 Ulrich Drepper <drepper@redhat.com> 0.130-1
469 - readelf: -p option can take an argument like -x for one section,
470          or no argument (as before) for all SHF_STRINGS sections;
471          new option --archive-index (or -c);     improved -n output fo
472 r core files, on many machines
473 - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
474         new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
475 - readelf, elflint: handle SHT_NOTE sections without requiring phdrs
476 - elflint: stricter checks on debug sections
477 - libdwfl: new functions dwfl_build_id_find_elf, dwfl_build_id_find_debu
478 ginfo,   dwfl_module_build_id, dwfl_module_report_build_id;      suppo
479 rt dynamic symbol tables found via phdrs;        dwfl_standard_find_de
480 buginfo now uses build IDs when available
481 - unstrip: new option --list (or -n)
482 - libebl: backend improvements for sparc, alpha, powerpc
483
484 * Tue Aug 14 2007 Ulrich Drepper <drepper@redhat.com> 0.129-1
485 - readelf: new options --hex-dump (or -x), --strings (or -p)
486 - addr2line: new option --symbols (or -S)
487
488 * Wed Apr 18 2007 Ulrich Drepper <drepper@redhat.com> 0.127-1
489 - libdw: new function dwarf_getsrcdirs
490 - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
491          dwfl_module_address_section
492
493 * Mon Feb  5 2007 Ulrich Drepper <drepper@redhat.com> 0.126-1
494 - new program: ar
495
496 * Mon Dec 18 2006 Ulrich Drepper <drepper@redhat.com> 0.125-1
497 - elflint: Compare DT_GNU_HASH tests.
498 - move archives into -static RPMs
499 - libelf, elflint: better support for core file handling
500
501 * Tue Oct 10 2006 Ulrich Drepper <drepper@redhat.com> 0.124-1
502 - libebl: sparc backend support for return value location
503 - libebl, libdwfl: backend register name support extended with more info
504 - libelf, libdw: bug fixes for unaligned accesses on machines that care
505 - readelf, elflint: trivial bugs fixed
506
507 * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
508 - libebl: Backend build fixes, thanks to Stepan Kasal.
509 - libebl: ia64 backend support for register names, return value location
510 - libdwfl: Handle truncated linux kernel module section names.
511 - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
512 - elflint: Fix checks to permit --hash-style=gnu format.
513
514 * Wed Jul 12 2006 Ulrich Drepper <drepper@redhat.com> 0.122-1
515 - libebl: add function to test for relative relocation
516 - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
517 - elflint, readelf: add support for DT_GNU_HASHlibelf: add elf_gnu_hash
518 - elflint, readelf: add support for 64-bit SysV-style hash tables
519 - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
520
521 * Wed Jun 14 2006  <drepper@redhat.com> 0.121-1
522 - libelf: bug fixes for rewriting existing files when using mmap.
523 - make all installed headers usable in C++ code.
524 - readelf: better output format.
525 - elflint: fix tests of dynamic section content.
526 - ld: Implement --as-needed, --execstack, PT_GNU_STACK.  Many small patc
527 hes.
528 - libdw, libdwfl: handle files without aranges info.
529
530 * Tue Apr  4 2006 Ulrich Drepper <drepper@redhat.com> 0.120-1
531 - Bug fixes.
532 - dwarf.h updated for DWARF 3.0 final specification.
533 - libdwfl: New function dwfl_version.
534 - The license is now GPL for most files.  The libelf, libebl, libdw,and
535 libdwfl libraries have additional exceptions.  Add reference toOIN.
536
537 * Thu Jan 12 2006 Roland McGrath <roland@redhat.com> 0.119-1
538 - elflint: more tests.
539 - libdwfl: New function dwfl_module_register_names.
540 - libebl: New backend hook for register names.
541
542 * Tue Dec  6 2005 Ulrich Drepper <drepper@redhat.com> 0.118-1
543 - elflint: more tests.
544 - libdwfl: New function dwfl_module_register_names.
545 - libebl: New backend hook for register names.
546
547 * Thu Nov 17 2005 Ulrich Drepper <drepper@redhat.com> 0.117-1
548 - libdwfl: New function dwfl_module_return_value_location.
549 - libebl: Backend improvements for several CPUs.
550
551 * Mon Oct 31 2005 Ulrich Drepper <drepper@redhat.com> 0.116-1
552 - libdw: New functions dwarf_ranges, dwarf_entrypc, dwarf_diecu,       d
553 warf_entry_breakpoints.  Removed Dwarf_Func type and functions       d
554 warf_func_name, dwarf_func_lowpc, dwarf_func_highpc,       dwarf_func_
555 entrypc, dwarf_func_die; dwarf_getfuncs callback now uses       Dwarf_
556 Die, and dwarf_func_file, dwarf_func_line, dwarf_func_col       replac
557 ed by dwarf_decl_file, dwarf_decl_line, dwarf_decl_column;       dwarf
558 _func_inline, dwarf_func_inline_instances now take Dwarf_Die.       Ty
559 pe Dwarf_Loc renamed to Dwarf_Op; dwarf_getloclist,       dwarf_addrlo
560 clists renamed dwarf_getlocation, dwarf_getlocation_addr.
561
562 * Fri Sep  2 2005 Ulrich Drepper <drepper@redhat.com> 0.115-1
563 - libelf: speed-ups of non-mmap reading.
564 - strings: New program.
565 - Implement --enable-gcov option for configure.
566 - libdw: New function dwarf_getscopes_die.
567
568 * Wed Aug 24 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
569 - libelf: new function elf_getaroff
570 - libdw: Added dwarf_func_die, dwarf_func_inline, dwarf_func_inline_inst
571 ances.
572 - libdwfl: New functions dwfl_report_offline, dwfl_offline_section_addre
573 ss,      dwfl_linux_kernel_report_offline.
574 - ranlib: new program
575
576 * Mon Aug 15 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
577 - libelf: new function elf_getaroff
578 - ranlib: new program
579
580 * Wed Aug 10 2005 Ulrich Drepper <@redhat.com> 0.113-1
581 - elflint: relax a bit. Allow version definitions for defined symbols ag
582 ainstDSO versions also for symbols in nobits sections.  Allow .rodata
583 sectionto have STRINGS and MERGE flag set.
584 - strip: add some more compatibility with binutils.
585
586 * Sat Aug  6 2005 Ulrich Drepper <@redhat.com> 0.113-1
587 - elflint: relax a bit. Allow version definitions for defined symbols ag
588 ainstDSO versions also for symbols in nobits sections.  Allow .rodata
589 sectionto have STRINGS and MERGE flag set.
590
591 * Sat Aug  6 2005 Ulrich Drepper <@redhat.com> 0.113-1
592 - elflint: relax a bit. Allow version definitions for defined symbols ag
593 ainstDSO versions also for symbols in nobits sections.
594
595 * Fri Aug  5 2005 Ulrich Drepper <@redhat.com> 0.112-1
596 - elfcmp: some more relaxation.
597 - elflint: many more tests, especially regarding to symbol versioning.
598 - libelf: Add elfXX_offscn and gelf_offscn.
599 - libasm: asm_begin interface changes.
600 - libebl: Add three new interfaces to directly access machine, class, an
601 ddata encoding information.
602 - objdump: New program.  Just the beginning.
603
604 * Thu Jul 28 2005 Ulrich Drepper <@redhat.com> 0.111-1
605 - libdw: now contains all of libdwfl.  The latter is not installed anymore.
606 - elfcmp: little usability tweak, name and index of differing section is
607  printed.
608
609 * Sun Jul 24 2005 Ulrich Drepper <@redhat.com> 0.110-1
610 - libelf: fix a numbe rof problems with elf_update
611 - elfcmp: fix a few bugs.  Compare gaps.
612 - Fix a few PLT problems and mudflap build issues.
613 - libebl: Don't expose Ebl structure definition in libebl.h.  It's now p
614 rivate.
615
616 * Thu Jul 21 2005 Ulrich Drepper <@redhat.com> 0.109-1
617 - libebl: Check for matching modules.
618 - elflint: Check that copy relocations only happen for OBJECT or NOTYPE
619 symbols.
620 - elfcmp: New program.
621 - libdwfl: New library.
622
623 * Mon May  9 2005 Ulrich Drepper <@redhat.com> 0.108-1
624 - strip: fix bug introduced in last change
625 - libdw: records returned by dwarf_getsrclines are now sorted by address
626
627 * Sun May  8 2005 Ulrich Drepper <@redhat.com> 0.108-1
628 - strip: fix bug introduced in last change
629
630 * Sun May  8 2005 Ulrich Drepper <@redhat.com> 0.107-1
631 - readelf: improve DWARF output format
632 - strip: support Linux kernel modules
633
634 * Fri Apr 29 2005 Ulrich Drepper <drepper@redhat.com> 0.107-1
635 - readelf: improve DWARF output format
636
637 * Mon Apr  4 2005 Ulrich Drepper <drepper@redhat.com> 0.106-1
638 - libdw: Updated dwarf.h from DWARF3 speclibdw: add new funtions dwarf_f
639 unc_entrypc, dwarf_func_file, dwarf_func_line,dwarf_func_col, dwarf_ge
640 tsrc_file
641
642 * Fri Apr  1 2005 Ulrich Drepper <drepper@redhat.com> 0.105-1
643 - addr2line: New program
644 - libdw: add new functions: dwarf_addrdie, dwarf_macro_*, dwarf_getfuncs
645 ,dwarf_func_*.
646 - findtextrel: use dwarf_addrdie
647
648 * Mon Mar 28 2005 Ulrich Drepper <drepper@redhat.com> 0.104-1
649 - findtextrel: New program.
650
651 * Mon Mar 21 2005 Ulrich Drepper <drepper@redhat.com> 0.103-1
652 - libdw: Fix using libdw.h with gcc < 4 and C++ code.  Compiler bug.
653
654 * Tue Feb 22 2005 Ulrich Drepper <drepper@redhat.com> 0.102-1
655 - More Makefile and spec file cleanups.
656
657 * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
658 - upgrade to 0.94
659
660 * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
661 - upgrade to 0.93
662
663 * Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
664 - full version
665 - macroized spec file for GPL or OSL builds
666 - include only libelf under GPL plus wrapper scripts
667
668 * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
669 - macroized spec file for GPL or OSL builds
670
671 * Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
672 - split elfutils-devel into two packages.
673
674 * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
675 - include only libelf under GPL plus wrapper scripts
676
677 * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
678 - readelf, not readline, in %%description (#111214).
679
680 * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
681 - update to 0.89 (fix eu-strip)
682
683 * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
684 - update to 0.86 (fix eu-strip on s390x/alpha)
685 - libebl is an archive now; remove references to DSO
686
687 * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
688 - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
689
690 * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
691 - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
692
693 * Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
694 - upgrade to 0.82 (strip tests fixed on big-endian).
695
696 * Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
697 - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
698
699 * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
700 - upgrade to 0.80 (debugedit changes for kernel in progress).
701
702 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
703 - rebuilt
704
705 * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
706 - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
707
708 * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
709 - upgrade to 0.78 (libdwarf bugfix, libdw additions).
710
711 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
712 - debuginfo rebuild
713
714 * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
715 - use the correct way of identifying the section via the sh_info link.
716
717 * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
718 - update to 0.75 (eu-strip -g fix)
719
720 * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
721 - update to 0.74 (fix for writing with some non-dirty sections)
722
723 * Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
724 - another -0.73 update (with sparc fixes).
725 - do "make check" in %%check, not %%install, section.
726
727 * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
728 - update to 0.73 (with s390 fixes).
729
730 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
731 - rebuilt
732
733 * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
734 - fix arguments to gelf_getsymshndx and elf_getshstrndx
735 - fix other warnings
736 - reenable checks on s390x
737
738 * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
739 - temporarily disable checks on s390x, until someone has
740   time to look at it
741
742 * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
743 - update to 0.72
744
745 * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
746 - update to 0.71
747
748 * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
749 - update to 0.69.
750 - add "make check" and segfault avoidance patch.
751 - elfutils-libelf needs to run ldconfig.
752
753 * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
754 - update to 0.68.
755
756 * Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
757 - update to 0.67.
758
759 * Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
760 - update to 0.65.
761
762 * Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
763 - update to 0.64.
764
765 * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
766 - split packages further into elfutils-libelf
767
768 * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
769 - update to 0.63.
770
771 * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
772 - Adjust for dropping libtool
773
774 * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
775 - update to 0.59
776
777 * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
778 - update to 0.56
779
780 * Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
781 - update to 0.54
782
783 * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
784 - update to 0.53
785 - drop x86_64 hack, ICE fixed in gcc-3.2-11.
786
787 * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
788 - get beehive to punch a rhpkg generated package.
789
790 * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
791 - build in 8.0.1.
792 - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
793
794 * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
795 - Add libelf-devel to conflicts for elfutils-devel
796
797 * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
798 - Split into runtime and devel package
799
800 * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
801 - integrate into official sources
802
803 * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
804 - Swaddle.