Updated to release 1.7.8
[platform/upstream/eeze.git] / packaging / eeze.spec
1 Name:           eeze
2 Version:        1.7.8
3 Release:        1
4 License:        BSD 2-clause
5 Summary:        Device Convenience Library
6 Url:            http://www.enlightenment.org/
7 Group:          Graphics/EFL
8 Source0:        eeze-%{version}.tar.bz2
9 Source1001:     eeze.manifest
10 BuildRequires:  doxygen
11 BuildRequires:  pkgconfig(ecore)
12 BuildRequires:  pkgconfig(eina)
13 BuildRequires:  pkgconfig(libudev)
14 BuildRequires:  pkgconfig(udev)
15
16 %description
17 Eeze is a library for manipulating devices through udev with a simple
18 and fast api. It interfaces directly with libudev, avoiding such
19 middleman daemons as udisks/upower or hal, to immediately gather
20 device information the instant it becomes known to the system.  This
21 can be used to determine such things as:
22   * If a cdrom has a disk inserted
23   * The temperature of a cpu core
24   * The remaining power left in a battery
25   * The current power consumption of various parts
26   * Monitor in realtime the status of peripheral devices
27
28 Each of the above examples can be performed by using only a single
29 eeze function, as one of the primary focuses of the library is to
30 reduce the complexity of managing devices.
31
32 %package devel
33 Summary:        Development components for the eeze package
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}
36
37 %description devel
38 Development files for eeze
39
40 %prep
41 %setup -q
42 cp %{SOURCE1001} .
43
44
45 %build
46
47 %configure --disable-static
48 make %{?_smp_mflags}
49
50 %install
51 %make_install
52
53
54
55
56 %post -p /sbin/ldconfig
57
58 %postun -p /sbin/ldconfig
59
60
61
62
63
64 %files
65 %manifest %{name}.manifest
66 %defattr(-,root,root,-)
67 %license COPYING
68 %{_libdir}/libeeze.so.*
69
70
71 %files devel
72 %manifest %{name}.manifest
73 %defattr(-,root,root,-)
74 %{_includedir}/eeze-1/*.h
75 %{_libdir}/*.so
76 %{_libdir}/pkgconfig/*.pc
77
78
79
80 %changelog