Updated to release 1.7.8
[platform/upstream/eeze.git] / eeze.spec
1 %{!?_rel:%{expand:%%global _rel 0.enl%{?dist}}}
2 %define _missing_doc_files_terminate_build 0
3
4 Summary: Device Convenience Library
5 Name: eeze
6 Version: 1.7.8
7 Release: %{_rel}
8 License: BSD
9 Group: System Environment/Libraries
10 Source: http://download.enlightenment.org/releases/%{name}-%{version}.tar.gz
11 Packager: %{?_packager:%{_packager}}%{!?_packager:Michael Jennings <mej@eterm.org>}
12 Vendor: %{?_vendorinfo:%{_vendorinfo}}%{!?_vendorinfo:The Enlightenment Project (http://www.enlightenment.org/)}
13 Distribution: %{?_distribution:%{_distribution}}%{!?_distribution:%{_vendor}}
14 Requires: ecore, libudev, libmount, eject
15 BuildRequires: ecore-devel, libudev-devel, libmount-devel
16 URL: http://www.enlightenment.org/
17 BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19 %description
20 Eeze is a library for manipulating devices through udev with a simple
21 and fast api. It interfaces directly with libudev, avoiding such
22 middleman daemons as udisks/upower or hal, to immediately gather
23 device information the instant it becomes known to the system.  This
24 can be used to determine such things as:
25   * If a cdrom has a disk inserted
26   * The temperature of a cpu core
27   * The remaining power left in a battery
28   * The current power consumption of various parts
29   * Monitor in realtime the status of peripheral devices
30
31 Each of the above examples can be performed by using only a single
32 eeze function, as one of the primary focuses of the library is to
33 reduce the complexity of managing devices.
34
35 %package devel
36 Summary: Development files for Eeze
37 Group: System Environment/Libraries
38 Requires: %{name} = %{version}
39 Requires: ecore-devel, libudev-devel
40
41 %description devel
42 Headers, static libraries, test programs and documentation for Eeze
43
44 %prep
45 %setup -q
46
47 %build
48 %{configure} --prefix=%{_prefix}
49 %{__make} %{?_smp_mflags} %{?mflags}
50
51 %install
52 %{__make} %{?mflags_install} DESTDIR=$RPM_BUILD_ROOT install
53
54 %clean
55 test "x$RPM_BUILD_ROOT" != "x/" && rm -rf $RPM_BUILD_ROOT
56
57 %post
58 /sbin/ldconfig
59
60 %postun
61 /sbin/ldconfig
62
63 %files
64 %defattr(-, root, root)
65 %doc AUTHORS COPYING README
66 %{_libdir}/*.so.*
67 #%{_libdir}/enlightenment/utils/eeze_scanner
68 %{_bindir}/*
69
70 %files devel
71 %defattr(-, root, root)
72 %{_includedir}/*
73 %{_libdir}/*.a
74 %{_libdir}/*.so
75 %{_libdir}/*.la
76 %{_libdir}/pkgconfig/*
77
78 %changelog