7c7f8ae9606708f03a2fcf753883b9612fba1d22
[platform/upstream/edje.git] / packaging / edje.spec
1 Name:           edje
2 Version:        1.7.2
3 Release:        1
4 License:        BSD 2-clause
5 Summary:        Complex Graphical Design/Layout Engine
6 Url:            http://www.enlightenment.org/
7 Group:          Graphics/X11
8 Source0:        edje-%{version}.tar.gz
9 BuildRequires:  doxygen
10 BuildRequires:  python-devel
11 #BuildRequires:  vim
12 BuildRequires:  pkgconfig(ecore)
13 BuildRequires:  pkgconfig(ecore-evas)
14 BuildRequires:  pkgconfig(ecore-file)
15 BuildRequires:  pkgconfig(ecore-imf)
16 BuildRequires:  pkgconfig(ecore-imf-evas)
17 BuildRequires:  pkgconfig(eet)
18 BuildRequires:  pkgconfig(eina)
19 BuildRequires:  pkgconfig(embryo)
20 BuildRequires:  pkgconfig(evas)
21 BuildRequires:  pkgconfig(lua)
22
23 %description
24 Edje is a complex graphical design and layout engine. It provides a
25 mechanism for allowing configuration data to define visual elements in
26 terms of layout, behavior, and appearance.  Edje allows for multiple
27 collections of layouts in one file, allowing a complete set of images,
28 animations, and controls to exist as a unified whole.
29
30 Edje separates the arrangement, appearance, and behavior logic into
31 distinct independent entities.  This allows visual objects to share
32 image data and configuration information without requiring them to do
33 so.  This separation and simplistic event driven style of programming
34 can produce almost any look and feel one could want for basic visual
35 elements. Anything more complex is likely the domain of an application
36 or widget set that may use Edje as a conveneient way of being able to
37 configure parts of the display.
38
39 %package devel
40 Summary:        Development components for the edje package
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}
43
44 %description devel
45 Development files for edje
46
47 %prep
48 %setup -q
49
50 %build
51 %configure --disable-static
52 make %{?_smp_mflags}
53
54 %install
55 %make_install
56
57 %post -p /sbin/ldconfig
58 %postun -p /sbin/ldconfig
59
60 %files
61 %defattr(-,root,root,-)
62 %doc COPYING
63 %{_bindir}/edje*
64 %{_libdir}/*.so.*
65 %{_libdir}/edje/*
66 %{_datadir}/edje/include/edje.inc
67 %{_datadir}/mime/packages/edje.xml
68 %{_bindir}/inkscape2edc
69
70 %files devel
71 %defattr(-,root,root,-)
72 %{_includedir}/edje-1/*.h
73 %{_libdir}/*.so
74 %{_libdir}/pkgconfig/*.pc
75 %{_datadir}/edje/examples/*
76
77 %changelog