Update to 1.7.5
[platform/upstream/edje.git] / packaging / edje.spec
1 Name:           edje
2 Version:        1.7.5
3 Release:        1
4 License:        BSD 2-clause
5 Summary:        Complex Graphical Design/Layout Engine
6 Url:            http://www.enlightenment.org/
7 Group:          Graphics/EFL
8 Source0:        edje-%{version}.tar.bz2
9 BuildRequires:  doxygen
10 BuildRequires:  python-devel
11 BuildRequires:  pkgconfig(ecore)
12 BuildRequires:  pkgconfig(ecore-evas)
13 BuildRequires:  pkgconfig(ecore-file)
14 BuildRequires:  pkgconfig(ecore-imf)
15 BuildRequires:  pkgconfig(ecore-imf-evas)
16 BuildRequires:  pkgconfig(eet)
17 BuildRequires:  pkgconfig(eina)
18 BuildRequires:  pkgconfig(embryo)
19 BuildRequires:  pkgconfig(evas)
20 BuildRequires:  pkgconfig(lua)
21
22 %description
23 Edje is a complex graphical design and layout engine. It provides a
24 mechanism for allowing configuration data to define visual elements in
25 terms of layout, behavior, and appearance.  Edje allows for multiple
26 collections of layouts in one file, allowing a complete set of images,
27 animations, and controls to exist as a unified whole.
28
29 Edje separates the arrangement, appearance, and behavior logic into
30 distinct independent entities.  This allows visual objects to share
31 image data and configuration information without requiring them to do
32 so.  This separation and simplistic event driven style of programming
33 can produce almost any look and feel one could want for basic visual
34 elements. Anything more complex is likely the domain of an application
35 or widget set that may use Edje as a conveneient way of being able to
36 configure parts of the display.
37
38 %package devel
39 Summary:        Development components for the edje package
40 Group:          Development/Libraries
41 Requires:       %{name}-tools = %{version}
42
43 %description devel
44 Development files for edje
45
46 %package tools
47 Summary:    Tools for %{name}
48 Group:      Development/Libraries
49 Requires:   %{name} = %{version}
50 Provides:   %{name}-bin
51 Obsoletes:  %{name}-bin
52
53 %description tools
54 Tools for %{name}.
55
56 %prep
57 %setup -q
58
59 %build
60 %configure --disable-static
61 make %{?_smp_mflags}
62
63 %install
64 %make_install
65
66 %post -p /sbin/ldconfig
67 %postun -p /sbin/ldconfig
68
69 %files
70 %defattr(-,root,root,-)
71 %license COPYING
72 %{_libdir}/*.so.*
73 %{_libdir}/edje/*
74 %{_datadir}/edje/include/edje.inc
75 %{_datadir}/mime/packages/edje.xml
76 %{_bindir}/inkscape2edc
77
78 %files tools
79 %{_bindir}/edje*
80
81 %files devel
82 %defattr(-,root,root,-)
83 %{_includedir}/edje-1/*.h
84 %{_libdir}/*.so
85 %{_libdir}/pkgconfig/*.pc
86 %{_datadir}/edje/examples/*
87
88 %changelog