Update to release 1.7.8
[platform/upstream/edje.git] / packaging / edje.spec
1 Name:           edje
2 Version:        1.7.8
3 Release:        1
4 License:        BSD 2-clause
5 Summary:        Complex Graphical Design/Layout Engine
6 Url:            http://www.enlightenment.org/
7 Group:          Graphics/EFL
8 Source0:        edje-%{version}.tar.bz2
9 Source1001:     edje.manifest
10 BuildRequires:  doxygen
11 BuildRequires:  python-devel
12 BuildRequires:  pkgconfig(ecore)
13 BuildRequires:  pkgconfig(ecore-evas)
14 BuildRequires:  pkgconfig(ecore-file)
15 BuildRequires:  pkgconfig(ecore-imf)
16 BuildRequires:  pkgconfig(ecore-imf-evas)
17 BuildRequires:  pkgconfig(eet)
18 BuildRequires:  pkgconfig(eina)
19 BuildRequires:  pkgconfig(embryo)
20 BuildRequires:  pkgconfig(evas)
21 BuildRequires:  pkgconfig(lua)
22
23 %description
24 Edje is a complex graphical design and layout engine. It provides a
25 mechanism for allowing configuration data to define visual elements in
26 terms of layout, behavior, and appearance.  Edje allows for multiple
27 collections of layouts in one file, allowing a complete set of images,
28 animations, and controls to exist as a unified whole.
29
30 Edje separates the arrangement, appearance, and behavior logic into
31 distinct independent entities.  This allows visual objects to share
32 image data and configuration information without requiring them to do
33 so.  This separation and simplistic event driven style of programming
34 can produce almost any look and feel one could want for basic visual
35 elements. Anything more complex is likely the domain of an application
36 or widget set that may use Edje as a conveneient way of being able to
37 configure parts of the display.
38
39 %package devel
40 Summary:        Development components for the edje package
41 Group:          Development/Libraries
42 Requires:       %{name}-tools = %{version}
43
44 %description devel
45 Development files for edje
46
47 %package tools
48 Summary:    Tools for %{name}
49 Group:      Development/Libraries
50 Requires:   %{name} = %{version}
51 Provides:   %{name}-bin
52 Obsoletes:  %{name}-bin
53
54 %description tools
55 Tools for %{name}.
56
57 %prep
58 %setup -q
59 cp %{SOURCE1001} .
60
61 %build
62 %configure --disable-static
63 make %{?_smp_mflags}
64
65 %install
66 %make_install
67
68 %post -p /sbin/ldconfig
69 %postun -p /sbin/ldconfig
70
71 %files
72 %manifest %{name}.manifest
73 %defattr(-,root,root,-)
74 %license COPYING
75 %{_libdir}/*.so.*
76 %{_libdir}/edje/*
77 %{_datadir}/edje/include/edje.inc
78 %{_datadir}/mime/packages/edje.xml
79 %{_bindir}/inkscape2edc
80
81 %files tools
82 %manifest %{name}.manifest
83 %{_bindir}/edje*
84
85 %files devel
86 %manifest %{name}.manifest
87 %defattr(-,root,root,-)
88 %{_includedir}/edje-1/*.h
89 %{_libdir}/*.so
90 %{_libdir}/pkgconfig/*.pc
91 %{_datadir}/edje/examples/*
92
93 %changelog