Fix for UBSan build
[platform/upstream/doxygen.git] / packaging / doxygen.spec
1 Name:           doxygen
2 Version:        1.8.2
3 Release:        1
4 License:        GPL-2.0+
5 Summary:        Automated C, C++, and Java Documentation Generator
6 Url:            http://www.stack.nl/~dimitri/doxygen/
7 Group:          Development/Tools
8 Source:         http://ftp.stack.nl/pub/users/dimitri/doxygen-%{version}.src.tar.gz
9 Source1001:     doxygen.manifest
10 BuildRequires:  bison
11 BuildRequires:  flex
12 BuildRequires:  gcc-c++
13 BuildRequires:  gettext-tools
14 %description
15 Doxygen is a documentation system for C, C++, Java, and IDL. It can
16 generate an online class browser (in HTML) and an offline reference
17 manual (in LaTeX) from a set of documented source files. The
18 documentation is extracted directly from the sources. Doxygen is
19 developed on a Linux platform, but it runs on most other UNIX flavors
20 as well. An executable for Windows 95/NT is also available.
21
22 %prep
23 %setup -q
24 cp %{SOURCE1001} .
25
26 %build
27 %{?ubsan:
28 /usr/bin/gcc-unforce-options
29 /usr/bin/gcc-force-options -fsanitize=undefined -fno-sanitize=vptr
30 }
31 unset QTDIR
32 ./configure \
33    --prefix %{_prefix} \
34    --shared \
35    --release
36 make %{?_smp_mflags}
37
38 %install
39 %make_install
40
41 %docs_package
42
43 %files
44 %manifest %{name}.manifest
45 %defattr(-,root,root)
46 %attr(755,root,root) %{_bindir}/*
47