[CVE-2015-8899] Fix crash when empty address from DNS overlays A record from hosts
[platform/upstream/dnsmasq.git] / packaging / dnsmasq.spec
1 Name:       dnsmasq
2 Summary:    dnsmasq, DNS forwarder.
3 Version:    2.74
4 Release:    1
5 Group:      System/Network
6 License:    GPL-2.0+
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     packaging/dnsmasq.manifest
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(dbus-1)
11 BuildRequires: pkgconfig(libtzplatform-config)
12
13 %description
14 Dnsmasq is a lightweight, easy to configure DNS forwarder and DHCP server.
15 It is designed to provide DNS and, optionally, DHCP, to a small network.
16 It can serve the names of local machines that are not in the global DNS.
17 The DHCP server integrates with the DNS server and allows machines with
18 DHCP-allocated addresses to appear in DNS with names configured either
19 in each host or in a central configuration file. Dnsmasq supports static
20 and dynamic DHCP leases and BOOTP for network booting of diskless machines.
21
22 %prep
23 %setup -q
24 cp %{SOURCE1001} .
25
26 %build
27 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
28 make %{?jobs:-j%jobs}
29
30 %post
31 mkdir -p %{TZ_SYS_VAR}/lib/misc
32
33 %install
34 %make_install
35 mkdir -p %{buildroot}%{_sysconfdir}/dbus-1/system.d
36 cp dbus/dnsmasq.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d/dnsmasq.conf
37 mkdir -p %{buildroot}/usr/share/license
38 cp COPYING %{buildroot}/usr/share/license/dnsmasq
39
40 %files
41 %manifest %{name}.manifest
42 %{_bindir}/dnsmasq
43 /usr/share/license/dnsmasq
44 %attr(644,root,root) %{_sysconfdir}/dbus-1/system.d/*