94e2260b9c9f4a816d79e3098bb7c9eb08b6d24e
[platform/upstream/curl.git] / packaging / curl.spec
1 Name:       curl
2 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
3 Version:    7.37.1
4 Release:    1
5 Group:      Applications/Internet
6 License:    MIT
7 URL:        http://curl.haxx.se/
8 #Source0:    http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
9 Source0:    %{name}-%{version}.tar.gz
10 Source1001:     %{name}.manifest
11
12 BuildRequires:  pkgconfig(openssl)
13 BuildRequires:  pkgconfig(libidn)
14 BuildRequires:  pkgconfig(zlib)
15 BuildRequires:  pkgconfig(libcares)
16 BuildRequires:  pkgconfig(libnghttp2)
17 Provides:   webclient
18
19
20 %description
21 cURL is a tool for getting files from HTTP, FTP, FILE, LDAP, LDAPS,
22 DICT, TELNET and TFTP servers, using any of the supported protocols.
23 cURL is designed to work without user interaction or any kind of
24 interactivity. cURL offers many useful capabilities, like proxy support,
25 user authentication, FTP upload, HTTP post, and file transfer resume.
26
27
28
29 %package -n libcurl
30 Summary:    A library for getting files from web servers
31 Group:      System/Libraries
32 License:    MIT
33 Requires(post): /sbin/ldconfig
34 Requires(postun): /sbin/ldconfig
35
36 %description -n libcurl
37 This package provides a way for applications to use FTP, HTTP, Gopher and
38 other servers for getting files.
39
40
41 %package -n libcurl-devel
42 Summary:    Files needed for building applications with libcurl
43 Group:      Development/Libraries
44 License:    MIT
45 Requires:   libcurl = %{version}-%{release}
46 Requires:   libidn-devel
47 Provides:   curl-devel = %{version}-%{release}
48 Obsoletes:   curl-devel < %{version}-%{release}
49
50 %description -n libcurl-devel
51 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
52 Dict servers, using any of the supported protocols. The libcurl-devel
53 package includes files needed for developing applications which can
54 use cURL's capabilities internally.
55
56
57
58 %prep
59 %setup -q
60 cp %{SOURCE1001} .
61
62 #%patch01 -p1
63 #%patch02 -p1
64
65 %build
66
67 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
68
69 %if "%{?tizen_profile_name}" == "tv"
70 CFLAGS+=" -DTIZEN_TV_EXT"
71 %reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
72 %else
73 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
74 %endif
75 --with-ca-path=/etc/ssl/certs \
76 --with-libidn \
77 --with-lber-lib=lber \
78 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
79 --disable-static \
80 --with-nghttp2 \
81
82 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
83
84 sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \
85 Makefile libcurl.pc
86 # Remove bogus rpath
87 sed -i \
88 -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
89 -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
90
91 make %{?_smp_mflags}
92
93 %install
94 rm -rf %{buildroot}
95
96 rm -rf $RPM_BUILD_ROOT
97
98 make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
99
100 rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
101 install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
102 install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
103
104
105 # don't need curl's copy of the certs; use openssl's
106 find ${RPM_BUILD_ROOT} -name ca-bundle.crt -exec rm -f '{}' \;
107 rm -rf ${RPM_BUILD_ROOT}/usr/share/man
108
109 # LICENSE
110 rm -rf %{buildroot}/usr/share/license
111 mkdir -p %{buildroot}/usr/share/license
112 cp COPYING %{buildroot}/usr/share/license/%{name}
113
114 %post -n libcurl -p /sbin/ldconfig
115
116 %postun -n libcurl -p /sbin/ldconfig
117
118 %files
119 %{_bindir}/curl
120
121 %files -n libcurl
122 %manifest %{name}.manifest
123 %{_libdir}/libcurl.so.*
124 /usr/share/license/%{name}
125
126 %files -n libcurl-devel
127 %{_bindir}/curl-config*
128 %{_includedir}/curl
129 %{_libdir}/*.so
130 %{_libdir}/pkgconfig/*.pc
131 %{_datadir}/aclocal/libcurl.m4
132