Fixed build error
[platform/upstream/curl.git] / packaging / curl.spec
1 Name:       curl
2 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
3 Version:    7.53.1
4 Release:    1
5 Group:      Applications/Internet
6 License:    MIT
7 URL:        http://curl.haxx.se/
8 #Source0:    http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
9 Source0:    %{name}-%{version}.tar.gz
10 Source1001:     %{name}.manifest
11
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(openssl)
14 BuildRequires:  pkgconfig(zlib)
15 BuildRequires:  pkgconfig(libcares)
16 BuildRequires:  pkgconfig(libnghttp2)
17
18 Provides:   webclient
19
20
21 %description
22 curl is a client to get documents/files from servers, using any of the
23 supported protocols. The command is designed to work without user
24 interaction or any kind of interactivity.
25
26 curl offers a busload of useful tricks like proxy support, user
27 authentication, ftp upload, HTTP post, file transfer resume and more.
28
29 %package -n libcurl
30 Summary:    A library for getting files from web servers
31 Group:      System/Libraries
32 License:    MIT
33 Requires(post): /sbin/ldconfig
34 Requires(postun): /sbin/ldconfig
35
36 %description -n libcurl
37 This package provides a way for applications to use FTP, HTTP, Gopher and
38 other servers for getting files.
39
40
41 %package -n libcurl-devel
42 Summary:    Files needed for building applications with libcurl
43 Group:      Development/Libraries
44 License:    MIT
45 Requires:   libcurl = %{version}-%{release}
46 Requires:   glib2-devel
47 Provides:   curl-devel = %{version}-%{release}
48 Obsoletes:   curl-devel < %{version}-%{release}
49
50 %description -n libcurl-devel
51 libcurl is the core engine of curl; this packages contains all the libs,
52 headers, and manual pages to develop applications using libcurl.
53
54 %prep
55 %setup -q
56 cp %{SOURCE1001} .
57
58 #%patch01 -p1
59 #%patch02 -p1
60
61 %build
62
63 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
64
65 %if "%{TIZEN_PROFILE_TV}" == "1"
66 CFLAGS+=" -DTIZEN_TV_EXT"
67 %reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
68 %else
69 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
70 %endif
71 --with-ca-path==/etc/ssl/certs \
72 --with-ca-bundle=/etc/ssl/ca-bundle.pem \
73 --with-glib2 \
74 --with-lber-lib=lber \
75 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
76 --disable-static \
77 --with-nghttp2 \
78 --without-zsh-functions-dir \
79
80 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
81
82 sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \
83 Makefile libcurl.pc
84 # Remove bogus rpath
85 sed -i \
86 -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
87 -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
88
89 make %{?_smp_mflags}
90
91 %install
92 rm -rf %{buildroot}
93
94 rm -rf $RPM_BUILD_ROOT
95
96 make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
97
98 rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
99 install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
100 install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
101
102
103 # don't need curl's copy of the certs; use openssl's
104 find ${RPM_BUILD_ROOT} -name ca-bundle.crt -exec rm -f '{}' \;
105 rm -rf ${RPM_BUILD_ROOT}/usr/share/man
106
107 %post -n libcurl -p /sbin/ldconfig
108
109 %postun -n libcurl -p /sbin/ldconfig
110
111 %files
112 %{_bindir}/curl
113 %license COPYING
114
115 %files -n libcurl
116 %manifest %{name}.manifest
117 %{_libdir}/libcurl.so.*
118 %license COPYING
119
120 %files -n libcurl-devel
121 %{_bindir}/curl-config*
122 %{_includedir}/curl
123 %{_libdir}/*.so
124 %{_libdir}/pkgconfig/*.pc
125 %{_datadir}/aclocal/libcurl.m4
126