Enable ipv6 for TV profile
[platform/upstream/curl.git] / packaging / curl.spec
1 Name:       curl
2 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
3 Version:    7.59.0
4 Release:    1
5 Group:      Applications/Internet
6 License:    MIT
7 URL:        http://curl.haxx.se/
8 #Source0:    http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
9 Source0:    %{name}-%{version}.tar.gz
10 Source1001:     %{name}.manifest
11
12 BuildRequires:  pkgconfig(icu-uc)
13 BuildRequires:  pkgconfig(openssl)
14 BuildRequires:  pkgconfig(zlib)
15 BuildRequires:  pkgconfig(libcares)
16 BuildRequires:  pkgconfig(libnghttp2)
17 Provides:   webclient
18
19
20 %description
21 curl is a client to get documents/files from servers, using any of the
22 supported protocols. The command is designed to work without user
23 interaction or any kind of interactivity.
24
25 curl offers a busload of useful tricks like proxy support, user
26 authentication, ftp upload, HTTP post, file transfer resume and more.
27
28 %package -n libcurl
29 Summary:    A library for getting files from web servers
30 Group:      System/Libraries
31 License:    MIT
32 Requires(post): /sbin/ldconfig
33 Requires(postun): /sbin/ldconfig
34
35 %description -n libcurl
36 This package provides a way for applications to use FTP, HTTP, Gopher and
37 other servers for getting files.
38
39
40 %package -n libcurl-devel
41 Summary:    Files needed for building applications with libcurl
42 Group:      Development/Libraries
43 License:    MIT
44 Requires:   libcurl = %{version}-%{release}
45 Provides:   curl-devel = %{version}-%{release}
46 Obsoletes:   curl-devel < %{version}-%{release}
47
48 %description -n libcurl-devel
49 libcurl is the core engine of curl; this packages contains all the libs,
50 headers, and manual pages to develop applications using libcurl.
51
52 %package -n libcurl-extension-dlp
53 Summary:        Extensions for Tizen OS
54 Provides:       libcurl-extension-dlp = %{version}-%{release}
55 Requires(post): /sbin/ldconfig
56 Requires(postun): /sbin/ldconfig
57
58 %description -n libcurl-extension-dlp
59 libcurl extensions for Tinen OS.
60
61 %prep
62 %setup -q
63 cp %{SOURCE1001} .
64
65 #%patch01 -p1
66 #%patch02 -p1
67
68 %build
69
70 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
71 CFLAGS+=" -fstack-protector-strong -Wl,-z,relro -D_FORTIFY_SOURCE=2 -fPIE -pie"
72 %if "%{tizen_profile_name}" == "tv"
73 CFLAGS+=" -DTIZEN_TV_EXT"
74 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
75 %else
76 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
77 %endif
78 --with-ca-path==/etc/ssl/certs \
79 --with-ca-bundle=/etc/ssl/ca-bundle.pem \
80 --with-icu-uc \
81 --with-lber-lib=lber \
82 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
83 --disable-static \
84 --with-nghttp2 \
85 --without-zsh-functions-dir \
86 --enable-dlp \
87
88 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
89
90 sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \
91 Makefile libcurl.pc
92 # Remove bogus rpath
93 sed -i \
94 -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
95 -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
96
97 make %{?_smp_mflags}
98
99 %install
100 rm -rf %{buildroot}
101
102 rm -rf $RPM_BUILD_ROOT
103
104 make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
105
106 rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl{,_extension_dlp}.la
107 install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
108 install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
109
110
111 # don't need curl's copy of the certs; use openssl's
112 find ${RPM_BUILD_ROOT} -name ca-bundle.crt -exec rm -f '{}' \;
113 rm -rf ${RPM_BUILD_ROOT}/usr/share/man
114
115 %post -n libcurl -p /sbin/ldconfig
116
117 %postun -n libcurl -p /sbin/ldconfig
118
119 %files
120 %{_bindir}/curl
121 %license COPYING
122
123 %files -n libcurl
124 %manifest %{name}.manifest
125 %{_libdir}/libcurl.so.*
126 %license COPYING
127
128 %files -n libcurl-devel
129 %{_bindir}/curl-config*
130 %{_includedir}/curl
131 %{_libdir}/*.so
132 %{_libdir}/pkgconfig/*.pc
133 %{_datadir}/aclocal/libcurl.m4
134
135 %files -n libcurl-extension-dlp
136 %manifest %{name}.manifest
137 %{_libdir}/libcurl_extension_dlp.so.*
138 %license COPYING