Use icu library for IDN feature
[platform/upstream/curl.git] / packaging / curl.spec
1 Name:       curl
2 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
3 Version:    7.59.0
4 Release:    1
5 Group:      Applications/Internet
6 License:    MIT
7 URL:        http://curl.haxx.se/
8 #Source0:    http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
9 Source0:    %{name}-%{version}.tar.gz
10 Source1001:     %{name}.manifest
11
12 BuildRequires:  pkgconfig(icu-uc)
13 BuildRequires:  pkgconfig(openssl)
14 BuildRequires:  pkgconfig(zlib)
15 BuildRequires:  pkgconfig(libcares)
16 BuildRequires:  pkgconfig(libnghttp2)
17
18 Provides:   webclient
19
20
21 %description
22 curl is a client to get documents/files from servers, using any of the
23 supported protocols. The command is designed to work without user
24 interaction or any kind of interactivity.
25
26 curl offers a busload of useful tricks like proxy support, user
27 authentication, ftp upload, HTTP post, file transfer resume and more.
28
29 %package -n libcurl
30 Summary:    A library for getting files from web servers
31 Group:      System/Libraries
32 License:    MIT
33 Requires(post): /sbin/ldconfig
34 Requires(postun): /sbin/ldconfig
35
36 %description -n libcurl
37 This package provides a way for applications to use FTP, HTTP, Gopher and
38 other servers for getting files.
39
40
41 %package -n libcurl-devel
42 Summary:    Files needed for building applications with libcurl
43 Group:      Development/Libraries
44 License:    MIT
45 Requires:   libcurl = %{version}-%{release}
46 Provides:   curl-devel = %{version}-%{release}
47 Obsoletes:   curl-devel < %{version}-%{release}
48
49 %description -n libcurl-devel
50 libcurl is the core engine of curl; this packages contains all the libs,
51 headers, and manual pages to develop applications using libcurl.
52
53 %prep
54 %setup -q
55 cp %{SOURCE1001} .
56
57 #%patch01 -p1
58 #%patch02 -p1
59
60 %build
61
62 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
63 CFLAGS+=" -fstack-protector-strong -Wl,-z,relro -D_FORTIFY_SOURCE=2 -fPIE -pie"
64 %if "%{TIZEN_PROFILE_TV}" == "1"
65 CFLAGS+=" -DTIZEN_TV_EXT"
66 %reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
67 %else
68 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
69 %endif
70 --with-ca-path==/etc/ssl/certs \
71 --with-ca-bundle=/etc/ssl/ca-bundle.pem \
72 --with-icu-uc \
73 --with-lber-lib=lber \
74 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
75 --disable-static \
76 --with-nghttp2 \
77 --without-zsh-functions-dir \
78
79 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
80
81 sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \
82 Makefile libcurl.pc
83 # Remove bogus rpath
84 sed -i \
85 -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
86 -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
87
88 make %{?_smp_mflags}
89
90 %install
91 rm -rf %{buildroot}
92
93 rm -rf $RPM_BUILD_ROOT
94
95 make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
96
97 rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl{,_extension_dlp}.la
98 install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
99 install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
100
101
102 # don't need curl's copy of the certs; use openssl's
103 find ${RPM_BUILD_ROOT} -name ca-bundle.crt -exec rm -f '{}' \;
104 rm -rf ${RPM_BUILD_ROOT}/usr/share/man
105
106 %post -n libcurl -p /sbin/ldconfig
107
108 %postun -n libcurl -p /sbin/ldconfig
109
110 %files
111 %{_bindir}/curl
112 %license COPYING
113
114 %files -n libcurl
115 %manifest %{name}.manifest
116 %{_libdir}/libcurl.so.*
117 %license COPYING
118
119 %files -n libcurl-devel
120 %{_bindir}/curl-config*
121 %{_includedir}/curl
122 %{_libdir}/*.so
123 %{_libdir}/pkgconfig/*.pc
124 %{_datadir}/aclocal/libcurl.m4