4ab88378c229d40643b23027365856e07a5ada05
[platform/upstream/curl.git] / packaging / curl.spec
1 Name:       curl
2 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
3 Version:    7.53.1
4 Release:    1
5 Group:      Applications/Internet
6 License:    MIT
7 URL:        http://curl.haxx.se/
8 #Source0:    http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
9 Source0:    %{name}-%{version}.tar.gz
10 Source1001:     %{name}.manifest
11
12 BuildRequires:  pkgconfig(openssl)
13 BuildRequires:  pkgconfig(libidn)
14 BuildRequires:  pkgconfig(zlib)
15 BuildRequires:  pkgconfig(libcares)
16 BuildRequires:  pkgconfig(libnghttp2)
17
18 Provides:   webclient
19
20
21 %description
22 curl is a client to get documents/files from servers, using any of the
23 supported protocols. The command is designed to work without user
24 interaction or any kind of interactivity.
25
26 curl offers a busload of useful tricks like proxy support, user
27 authentication, ftp upload, HTTP post, file transfer resume and more.
28
29 %package -n libcurl
30 Summary:    A library for getting files from web servers
31 Group:      System/Libraries
32 License:    MIT
33 Requires(post): /sbin/ldconfig
34 Requires(postun): /sbin/ldconfig
35
36 %description -n libcurl
37 This package provides a way for applications to use FTP, HTTP, Gopher and
38 other servers for getting files.
39
40
41 %package -n libcurl-devel
42 Summary:    Files needed for building applications with libcurl
43 Group:      Development/Libraries
44 License:    MIT
45 Requires:   libcurl = %{version}-%{release}
46 Requires:   libidn-devel
47 Requires:       nghttp2-devel
48 Provides:   curl-devel = %{version}-%{release}
49 Obsoletes:   curl-devel < %{version}-%{release}
50
51 %description -n libcurl-devel
52 libcurl is the core engine of curl; this packages contains all the libs,
53 headers, and manual pages to develop applications using libcurl.
54
55 %prep
56 %setup -q
57 cp %{SOURCE1001} .
58
59 #%patch01 -p1
60 #%patch02 -p1
61
62 %build
63
64 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
65
66 %if "%{TIZEN_PROFILE_TV}" == "1"
67 CFLAGS+=" -DTIZEN_TV_EXT"
68 %reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
69 %else
70 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
71 %endif
72 --with-ca-path==/etc/ssl/certs \
73 --with-ca-bundle=/etc/ssl/ca-bundle.pem \
74 --with-libidn \
75 --with-lber-lib=lber \
76 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
77 --disable-static \
78 --with-nghttp2 \
79 --without-zsh-functions-dir \
80
81 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
82
83 sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \
84 Makefile libcurl.pc
85 # Remove bogus rpath
86 sed -i \
87 -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
88 -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
89
90 make %{?_smp_mflags}
91
92 %install
93 rm -rf %{buildroot}
94
95 rm -rf $RPM_BUILD_ROOT
96
97 make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
98
99 rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
100 install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
101 install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
102
103
104 # don't need curl's copy of the certs; use openssl's
105 find ${RPM_BUILD_ROOT} -name ca-bundle.crt -exec rm -f '{}' \;
106 rm -rf ${RPM_BUILD_ROOT}/usr/share/man
107
108 %post -n libcurl -p /sbin/ldconfig
109
110 %postun -n libcurl -p /sbin/ldconfig
111
112 %files
113 %{_bindir}/curl
114 %license COPYING
115
116 %files -n libcurl
117 %manifest %{name}.manifest
118 %{_libdir}/libcurl.so.*
119 %license COPYING
120
121 %files -n libcurl-devel
122 %{_bindir}/curl-config*
123 %{_includedir}/curl
124 %{_libdir}/*.so
125 %{_libdir}/pkgconfig/*.pc
126 %{_datadir}/aclocal/libcurl.m4
127