add packaging
[platform/upstream/curl.git] / packaging / curl.spec
1 Name:       curl
2 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
3 Version:    7.21.3
4 Release:    1
5 Group:      Applications/Internet
6 License:    MIT
7 #URL:        http://curl.haxx.se/
8 #Source0:    http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
9 Source0:    %{name}-%{version}.tar.bz2
10
11 BuildRequires:  pkgconfig(openssl)
12 BuildRequires:  pkgconfig(libidn)
13 BuildRequires:  pkgconfig(nss)
14 BuildRequires:  pkgconfig(zlib)
15 BuildRequires:  pkgconfig(libcares)
16 Provides:   webclient
17
18
19 %description
20 cURL is a tool for getting files from HTTP, FTP, FILE, LDAP, LDAPS,
21 DICT, TELNET and TFTP servers, using any of the supported protocols.
22 cURL is designed to work without user interaction or any kind of
23 interactivity. cURL offers many useful capabilities, like proxy support,
24 user authentication, FTP upload, HTTP post, and file transfer resume.
25
26
27
28 %package -n libcurl
29 Summary:    A library for getting files from web servers
30 Group:      System/Libraries
31
32 %description -n libcurl
33 This package provides a way for applications to use FTP, HTTP, Gopher and
34 other servers for getting files.
35
36
37 %package -n libcurl-devel
38 Summary:    Files needed for building applications with libcurl
39 Group:      Development/Libraries
40 Requires:   libcurl = %{version}-%{release}
41 Requires:   libidn-devel
42 Provides:   curl-devel = %{version}-%{release}
43 Obsoletes:   curl-devel < %{version}-%{release}
44
45 %description -n libcurl-devel
46 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
47 Dict servers, using any of the supported protocols. The libcurl-devel
48 package includes files needed for developing applications which can
49 use cURL's capabilities internally.
50
51
52
53 %prep
54 %setup -q
55
56
57 %build
58
59 export CPPFLAGS="$(pkg-config --cflags nss) -DHAVE_PK11_CREATEGENERICOBJECT"
60
61 %reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
62 --with-ca-path=/etc/ssl/certs \
63 --with-libidn \
64 --with-lber-lib=lber \
65 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
66 --disable-static
67
68 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
69
70 sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \
71 Makefile libcurl.pc
72 # Remove bogus rpath
73 sed -i \
74 -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
75 -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
76
77 make %{?_smp_mflags}
78
79 %install
80 rm -rf %{buildroot}
81
82 rm -rf $RPM_BUILD_ROOT
83
84 make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
85
86 rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
87 install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
88 install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
89
90
91 # don't need curl's copy of the certs; use openssl's
92 find ${RPM_BUILD_ROOT} -name ca-bundle.crt -exec rm -f '{}' \;
93 rm -rf ${RPM_BUILD_ROOT}/usr/share/man
94
95 %post -n libcurl -p /sbin/ldconfig
96
97 %postun -n libcurl -p /sbin/ldconfig
98
99 %files
100 %{_bindir}/curl
101
102 %files -n libcurl
103 %{_libdir}/libcurl.so.*
104
105 %files -n libcurl-devel
106 %{_bindir}/curl-config*
107 %{_includedir}/curl
108 %{_libdir}/*.so
109 %{_libdir}/pkgconfig/*.pc
110 %{_datadir}/aclocal/libcurl.m4
111
112