Update version to 7.59.0
[platform/upstream/curl.git] / packaging / curl.spec
1 Name:       curl
2 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
3 Version:    7.59.0
4 Release:    1
5 Group:      Applications/Internet
6 License:    MIT
7 URL:        http://curl.haxx.se/
8 #Source0:    http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
9 Source0:    %{name}-%{version}.tar.gz
10 Source1001:     %{name}.manifest
11
12 BuildRequires:  pkgconfig(openssl)
13 BuildRequires:  pkgconfig(zlib)
14 BuildRequires:  pkgconfig(libcares)
15 BuildRequires:  pkgconfig(libnghttp2)
16
17 Provides:   webclient
18
19
20 %description
21 curl is a client to get documents/files from servers, using any of the
22 supported protocols. The command is designed to work without user
23 interaction or any kind of interactivity.
24
25 curl offers a busload of useful tricks like proxy support, user
26 authentication, ftp upload, HTTP post, file transfer resume and more.
27
28 %package -n libcurl
29 Summary:    A library for getting files from web servers
30 Group:      System/Libraries
31 License:    MIT
32 Requires(post): /sbin/ldconfig
33 Requires(postun): /sbin/ldconfig
34
35 %description -n libcurl
36 This package provides a way for applications to use FTP, HTTP, Gopher and
37 other servers for getting files.
38
39
40 %package -n libcurl-devel
41 Summary:    Files needed for building applications with libcurl
42 Group:      Development/Libraries
43 License:    MIT
44 Requires:   libcurl = %{version}-%{release}
45 Provides:   curl-devel = %{version}-%{release}
46 Obsoletes:   curl-devel < %{version}-%{release}
47
48 %description -n libcurl-devel
49 libcurl is the core engine of curl; this packages contains all the libs,
50 headers, and manual pages to develop applications using libcurl.
51
52 %prep
53 %setup -q
54 cp %{SOURCE1001} .
55
56 #%patch01 -p1
57 #%patch02 -p1
58
59 %build
60
61 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
62 CFLAGS+=" -fstack-protector-strong -Wl,-z,relro -D_FORTIFY_SOURCE=2 -fPIE -pie"
63 %if "%{TIZEN_PROFILE_TV}" == "1"
64 CFLAGS+=" -DTIZEN_TV_EXT"
65 %reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
66 %else
67 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
68 %endif
69 --with-ca-path==/etc/ssl/certs \
70 --with-ca-bundle=/etc/ssl/ca-bundle.pem \
71 --with-lber-lib=lber \
72 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
73 --disable-static \
74 --with-nghttp2 \
75 --without-zsh-functions-dir \
76
77 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
78
79 sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \
80 Makefile libcurl.pc
81 # Remove bogus rpath
82 sed -i \
83 -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
84 -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
85
86 make %{?_smp_mflags}
87
88 %install
89 rm -rf %{buildroot}
90
91 rm -rf $RPM_BUILD_ROOT
92
93 make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
94
95 rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl{,_extension_dlp}.la
96 install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
97 install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
98
99
100 # don't need curl's copy of the certs; use openssl's
101 find ${RPM_BUILD_ROOT} -name ca-bundle.crt -exec rm -f '{}' \;
102 rm -rf ${RPM_BUILD_ROOT}/usr/share/man
103
104 %post -n libcurl -p /sbin/ldconfig
105
106 %postun -n libcurl -p /sbin/ldconfig
107
108 %files
109 %{_bindir}/curl
110 %license COPYING
111
112 %files -n libcurl
113 %manifest %{name}.manifest
114 %{_libdir}/libcurl.so.*
115 %license COPYING
116
117 %files -n libcurl-devel
118 %{_bindir}/curl-config*
119 %{_includedir}/curl
120 %{_libdir}/*.so
121 %{_libdir}/pkgconfig/*.pc
122 %{_datadir}/aclocal/libcurl.m4