Apply changed gcov path
[platform/upstream/csr-framework.git] / packaging / csr-framework.spec
1 # services timeoout time on idle for on-demand activation.
2 # give it '-1' if don't want to timeout on idle.
3 %define service_idle_timeout_time       60
4 %define popup_service_idle_timeout_time 10
5
6 # Configure engine file system.
7 #
8 # ro_dir_name / rw_dir_name
9 # - dir name is directory name inside of CSR directory.
10 # - 'dbspace' cannot be used as a dir_name.
11 %define engine_ro_dir_name engine
12 %define engine_rw_dir_name engine
13
14 # base of detailed url of content screening engine.
15 # If it's defined, detailed_url for client will be generated by
16 #                  concatenating base url + malware name.
17 # Else it's not defined, detailed_url getter in engine API will be used.
18 %define with_detailed_base_url 0
19 %define detailed_base_url %nil
20
21 %define with_sample_engine 1
22
23 Summary: A general purpose content screening and reputation solution
24 Name: csr-framework
25 Version: 2.3.7
26 Release: 0
27 Source: %{name}-%{version}.tar.gz
28 License: Apache-2.0 and BSL-1.0
29 Group: Security/Service
30 URL: http://tizen.org
31 BuildRequires: cmake
32 BuildRequires: gettext-tools
33 BuildRequires: pkgconfig(dlog)
34 BuildRequires: pkgconfig(libsystemd)
35 BuildRequires: pkgconfig(vconf)
36 BuildRequires: pkgconfig(sqlite3)
37 BuildRequires: pkgconfig(pkgmgr)
38 BuildRequires: pkgconfig(pkgmgr-info)
39 BuildRequires: pkgconfig(libsmack)
40 BuildRequires: pkgconfig(capi-appfw-application)
41 BuildRequires: pkgconfig(elementary)
42 BuildRequires: pkgconfig(efl-extension)
43 BuildRequires: pkgconfig(icu-i18n)
44 BuildRequires: pkgconfig(libtzplatform-config)
45 BuildRequires: pkgconfig(cynara-client)
46 Requires:      lib%{name}-common = %{version}-%{release}
47 %{?systemd_requires}
48
49 %description
50 General purpose content screening and reputation solution. Can scan
51 file contents and checking url to prevent malicious items.
52
53 %global service_name                 csr
54 %global bin_dir                      %{_bindir}
55 %global sbin_dir                     /sbin
56 %global ro_data_dir                  %{_datadir}
57 %global rw_data_dir                  /opt/share
58 %global ro_db_dir                    %{ro_data_dir}/%{service_name}/dbspace
59 %global rw_db_dir                    %{rw_data_dir}/%{service_name}/dbspace
60 %global ro_res_dir                   %{ro_data_dir}/%{service_name}/res
61 %global engine_rw_working_dir        %{rw_data_dir}/%{service_name}/%{engine_rw_dir_name}
62 %global engine_dir                   %{ro_data_dir}/%{service_name}/%{engine_ro_dir_name}
63 %global test_dir                     %{rw_data_dir}/%{service_name}-test
64 %global test_res_dir                 %{ro_data_dir}/%{service_name}-test
65
66 %global service_user                 security_fw
67 %global service_group                security_fw
68 %global test_user                    owner
69 %global popup_service_env_file_path  /run/tizen-system-env
70 %global smack_domain_name            System
71 %global popup_unitdir                %{_unitdir_user}
72
73 %package -n lib%{name}-common
74 Summary: CSR framework (common library)
75 License: Apache-2.0
76 Group:   Security/Libraries
77 BuildRequires: pkgconfig(cynara-creds-socket)
78 Requires: %{sbin_dir}/ldconfig
79
80 %description -n lib%{name}-common
81 Content Screening and Reputation framework package (common library)
82
83 %package -n lib%{name}-client
84 Summary: CSR framework (client library)
85 License: Apache-2.0
86 Group:   Security/Libraries
87 BuildRequires: pkgconfig(capi-base-common)
88 Requires: %{name} = %{version}-%{release}
89 Requires: %{sbin_dir}/ldconfig
90
91 %description -n lib%{name}-client
92 Content Screening and Reputation framework package (client library)
93
94 %package devel
95 Summary: CSR framework (development files)
96 LICENSE: Apache-2.0
97 Group:   Security/Development
98 BuildRequires: pkgconfig(capi-base-common)
99 Requires:      %{name} = %{version}-%{release}
100 Requires:      lib%{name}-client
101
102 %description devel
103 Content Screening and Reputation framework development files like headers and pkgconfigs
104
105 %package engine-devel
106 Summary: CSR framework (engine development files)
107 LICENSE: Apache-2.0
108 Group:   Security/Development
109
110 %description engine-devel
111 Content Screening and Reputation framework engine development files like headers and
112 pkgconfigs
113
114 %package test
115 Summary: CSR framework (test program)
116 License: Apache-2.0 and BSL-1.0
117 Group:   Security/Testing
118 BuildRequires: boost-devel
119 BuildRequires: pkgconfig(pkgmgr-info)
120 BuildRequires: pkgconfig(glib-2.0)
121 BuildRequires: pkgconfig(storage)
122 Requires:      boost-test
123 Requires:      %{name} = %{version}
124
125 %description test
126 Content Screening and Reputation framework (test program)
127
128 %if 0%{?gcov:1}
129 %package gcov
130 Summary: CSR framework (gcov)
131 Group:   Security/Testing
132 BuildRequires: lcov
133
134 %description gcov
135 Content Screening and Reputation framework (gcov)
136 %endif
137
138 %prep
139 %setup -q
140
141 %build
142
143 # define build architecture
144 %ifarch %{ix86}
145 %define test_target emulator
146 %else
147 %define test_target target
148 %endif
149
150 %if 0%{?gcov:1}
151 export CFLAGS+=" -fprofile-arcs -ftest-coverage"
152 export CXXFLAGS+=" -fprofile-arcs -ftest-coverage"
153 export FFLAGS+=" -fprofile-arcs -ftest-coverage"
154 export LDFLAGS+=" -lgcov"
155 %endif
156
157 %cmake . \
158     -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}%{!?build_type:RELEASE} \
159     -DCMAKE_VERBOSE_MAKEFILE=ON \
160     -DCMAKE_INSTALL_PREFIX=%{_prefix} \
161     -DSERVICE_USER=%{service_user} \
162     -DSERVICE_GROUP=%{service_group} \
163     -DSMACK_DOMAIN_NAME=%{smack_domain_name} \
164     -DPOPUP_SERVICE_ENV_FILE_PATH:PATH=%{popup_service_env_file_path} \
165     -DSERVICE_NAME=%{service_name} \
166     -DVERSION=%{version} \
167     -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
168     -DBIN_DIR:PATH=%{bin_dir} \
169     -DSYSTEMD_UNIT_DIR=%{_unitdir} \
170     -DPOPUP_SYSTEMD_UNIT_DIR=%{popup_unitdir} \
171     -DRO_DBSPACE:PATH=%{ro_db_dir} \
172     -DRW_DBSPACE:PATH=%{rw_db_dir} \
173     -DRO_RES_DIR:PATH=%{ro_res_dir} \
174     -DRO_DATA_DIR:PATH=%{ro_data_dir} \
175     -DSERVICE_IDLE_TIMEOUT_TIME=%{service_idle_timeout_time} \
176     -DPOPUP_SERVICE_IDLE_TIMEOUT_TIME=%{popup_service_idle_timeout_time} \
177     -DENGINE_RW_WORKING_DIR:PATH=%{engine_rw_working_dir} \
178     -DENGINE_DIR:PATH=%{engine_dir} \
179     -DTEST_TARGET=%{test_target} \
180     -DTEST_DIR:PATH=%{test_dir} \
181     -DTEST_RES_DIR:PATH=%{test_res_dir} \
182 %if 0%{?with_detailed_base_url}
183     -DDETAILED_URL_BASE:STRING=%{detailed_base_url} \
184 %endif
185 %if 0%{?with_sample_engine}
186     -DWITH_SAMPLE_ENGINE:BOOL=ON \
187 %else
188     -DWITH_SAMPLE_ENGINE:BOOL=OFF \
189 %endif
190     -DTZ_SYS_STORAGE=%TZ_SYS_STORAGE \
191     -DTZ_SYS_RW_APP=%TZ_SYS_RW_APP \
192     -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
193     -DBUILD_GCOV=%{?gcov:1}%{!?gcov:0}
194
195 make %{?jobs:-j%jobs}
196
197 %install
198 %make_install
199 %install_service sockets.target.wants %{service_name}-cs.socket
200 %install_service sockets.target.wants %{service_name}-wp.socket
201 %install_service sockets.target.wants %{service_name}-admin.socket
202 %install_service ../user/sockets.target.wants %{service_name}-popup.socket
203
204 mkdir -p %{buildroot}%{rw_db_dir}
205 mkdir -p %{buildroot}%{ro_db_dir}
206 cp data/scripts/*.sql %{buildroot}%{ro_db_dir}
207
208 mkdir -p %{buildroot}%{engine_dir}
209 mkdir -p %{buildroot}%{engine_rw_working_dir}
210
211 %find_lang %{service_name}
212
213 %if 0%{?gcov:1}
214 builddir=$(basename $PWD)
215 gcno_obj_dir=%{buildroot}%{_datadir}/gcov/obj/%{name}/"$builddir"
216 mkdir -p "$gcno_obj_dir"
217 find . -name '*.gcno' -exec cp --parents '{}' "$gcno_obj_dir" ';'
218 %endif
219
220 %post
221 rm -f %{rw_db_dir}/.%{service_name}.db*
222
223 systemctl daemon-reload
224 if [ $1 = 1 ]; then
225     systemctl start %{service_name}-cs.socket
226     systemctl start %{service_name}-wp.socket
227     systemctl start %{service_name}-admin.socket
228     systemctl start %{service_name}.service
229
230     systemctl --user start %{service_name}-popup.socket
231     systemctl --user start %{service_name}-popup.service
232 elif [ $1 = 2 ]; then
233     systemctl stop %{service_name}-cs.socket
234     systemctl stop %{service_name}-wp.socket
235     systemctl stop %{service_name}-admin.socket
236     systemctl restart %{service_name}.service
237
238     systemctl --user stop %{service_name}-popup.socket
239     systemctl --user restart %{service_name}-popup.service
240 fi
241
242 %preun
243 if [ $1 = 0 ]; then
244     systemctl stop %{service_name}-cs.socket
245     systemctl stop %{service_name}-wp.socket
246     systemctl stop %{service_name}-admin.socket
247     systemctl stop %{service_name}.service
248
249     systemctl --user stop %{service_name}-popup.socket
250     systemctl --user stop %{service_name}-popup.service
251 fi
252
253 %postun
254 if [ $1 = 0 ]; then
255     systemctl daemon-reload
256 fi
257
258 %post -n lib%{name}-common -p %{sbin_dir}/ldconfig
259 %post -n lib%{name}-client -p %{sbin_dir}/ldconfig
260 %postun -n lib%{name}-common -p %{sbin_dir}/ldconfig
261 %postun -n lib%{name}-client -p %{sbin_dir}/ldconfig
262
263 %post -n %{name}-test
264 chsmack -a "_" %{test_dir}/test_dir/dir1
265 %if 0%{?with_sample_engine}
266 systemctl stop %{service_name}-cs.socket
267 systemctl stop %{service_name}-wp.socket
268 systemctl stop %{service_name}-admin.socket
269 systemctl restart %{service_name}.service
270
271 touch %{engine_rw_working_dir}/csret_cs_virus_signatures
272 touch %{engine_rw_working_dir}/csret_wp_risky_urls
273 %endif
274
275 %if 0%{?gcov:1}
276 chmod 777 -R /tmp/home/abuild/rpmbuild/BUILD/csr-framework-*
277 su - owner -c %{bin_dir}/%{service_name}-test
278 %{bin_dir}/%{service_name}-internal-test
279 %{bin_dir}/%{service_name}-threadpool-test
280 %endif
281
282 %files -f %{service_name}.lang
283 %defattr(-,root,root,-)
284 %manifest %{service_name}.manifest
285 %license LICENSE
286 %license LICENSE.BSL-1.0
287 %{bin_dir}/%{service_name}-server
288 %{bin_dir}/%{service_name}-popup
289 %{_unitdir}/%{service_name}.service
290 %{_unitdir}/sockets.target.wants/%{service_name}-cs.socket
291 %{_unitdir}/sockets.target.wants/%{service_name}-wp.socket
292 %{_unitdir}/sockets.target.wants/%{service_name}-admin.socket
293 %{_unitdir}/%{service_name}-cs.socket
294 %{_unitdir}/%{service_name}-wp.socket
295 %{_unitdir}/%{service_name}-admin.socket
296 %{popup_unitdir}/%{service_name}-popup.socket
297 %{popup_unitdir}/sockets.target.wants/%{service_name}-popup.socket
298 %{popup_unitdir}/%{service_name}-popup.service
299 %{ro_res_dir}/default-icon.png
300
301 %dir %{ro_data_dir}/%{service_name}
302 %dir %attr(-, %{service_user}, %{service_group}) %{rw_data_dir}/%{service_name}
303 %dir %{ro_db_dir}
304 %dir %attr(-, %{service_user}, %{service_group}) %{rw_db_dir}
305 %attr(444, %{service_user}, %{service_group}) %{ro_db_dir}/*.sql
306
307 %dir %{engine_dir}
308 %dir %attr(775, %{service_user}, %{service_group}) %{engine_rw_working_dir}
309
310 %files -n lib%{name}-common
311 %defattr(-,root,root,-)
312 %manifest %{service_name}-common.manifest
313 %license LICENSE
314 %{_libdir}/lib%{service_name}-common.so.*
315
316 %files -n lib%{name}-client
317 %defattr(-,root,root,-)
318 %manifest %{service_name}-client.manifest
319 %license LICENSE
320 %{_libdir}/lib%{service_name}-client.so.*
321
322 %files devel
323 %defattr(-,root,root,-)
324 %{_includedir}/csr/csr-content-screening.h
325 %{_includedir}/csr/csr-content-screening-types.h
326 %{_includedir}/csr/csr-web-protection.h
327 %{_includedir}/csr/csr-web-protection-types.h
328 %{_includedir}/csr/csr-error.h
329 %{_includedir}/csr/csr-engine-manager.h
330 %{_libdir}/pkgconfig/%{service_name}.pc
331 %{_libdir}/lib%{service_name}-client.so
332 %{_libdir}/lib%{service_name}-common.so
333
334 %files engine-devel
335 %defattr(-,root,root,-)
336 %{_includedir}/csre/csre-content-screening-engine-info.h
337 %{_includedir}/csre/csre-content-screening.h
338 %{_includedir}/csre/csre-content-screening-types.h
339 %{_includedir}/csre/csre-error.h
340 %{_includedir}/csre/csre-web-protection-engine-info.h
341 %{_includedir}/csre/csre-web-protection.h
342 %{_includedir}/csre/csre-web-protection-types.h
343 %{_libdir}/pkgconfig/%{service_name}-engine.pc
344
345 %files test
346 %defattr(-,root,root,-)
347 %manifest %{service_name}-test.manifest
348 %license LICENSE
349 %license LICENSE.BSL-1.0
350 %{_libdir}/lib%{service_name}-test-common.so
351 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-test
352 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-internal-test
353 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-popup-test
354 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-threadpool-test
355
356 # test resources
357 %dir %attr(-, %{test_user}, %{service_group}) %{test_dir}
358 %attr(-, %{test_user}, %{service_group}) %{test_dir}/*
359
360 %dir %attr(-, %{test_user}, %{service_group}) %{test_res_dir}
361 %attr(-, %{test_user}, %{service_group}) %{test_res_dir}/*
362
363 # sample engine related files
364 %if 0%{?with_sample_engine}
365 %{engine_dir}/lib%{service_name}-cs-engine.so
366 %{engine_dir}/lib%{service_name}-wp-engine.so
367 %attr(-, %{service_user}, %{service_group}) %{engine_rw_working_dir}/*
368 %endif
369
370 %if 0%{?gcov:1}
371 %files gcov
372 %{_datadir}/gcov/obj/*
373 %endif