provide /bin/touch to satisfy old specs
[platform/upstream/coreutils.git] / packaging / coreutils.spec
1 Name:           coreutils
2 Summary:        GNU Core Utilities
3 License:        GPL-3.0+
4 Group:          System/Base
5 BuildRequires:  automake
6 BuildRequires:  gmp-devel
7 BuildRequires:  help2man
8 BuildRequires:  libacl-devel
9 BuildRequires:  libcap-devel
10 BuildRequires:  pam-devel
11 BuildRequires:  xz
12 BuildRequires:  gettext-tools
13 Url:            http://www.gnu.org/software/coreutils/
14 Version:        8.20
15 Release:        0
16 Provides:       fileutils = %{version}
17 Provides:       mktemp = %{version}
18 Provides:       sh-utils = %{version}
19 Provides:       stat = %version}
20 Provides:       textutils = %{version}
21 Obsoletes:      fileutils < %{version}
22 Obsoletes:      mktemp < %{version}
23 Obsoletes:      sh-utils < %{version}
24 Obsoletes:      stat < %version}
25 Obsoletes:      textutils < %{version}
26 Requires:       pam >= 1.1.1.90
27 Source:         coreutils-%{version}.tar.xz
28 Source3:        baselibs.conf
29 Provides:       /bin/chmod, /bin/chown, /bin/ls, /bin/touch, /bin/mkdir
30
31 %description
32 Basic file, shell, and text manipulation utilities.  The package
33 contains the following programs:
34
35 [ arch base64 basename cat chcon chgrp chmod chown chroot cksum comm cp
36 csplit cut date dd df dir dircolors dirname du echo env expand expr
37 factor false fmt fold groups head id install join kill link ln logname
38 ls md5sum mkdir mkfifo mknod mktemp mv nice nl nohup od paste pathchk
39 pinky pr printenv printf ptx pwd readlink rm rmdir runcon seq sha1sum
40 sha224sum sha256sum sha384sum sha512sum shred shuf sleep sort split
41 stat stty sum sync tac tail tee test timeout touch tr true tsort tty
42 uname unexpand uniq unlink uptime users vdir wc who whoami yes
43
44 %lang_package
45
46 %prep
47 %setup -q
48
49 %build
50 AUTOPOINT=true autoreconf -fi
51 export CFLAGS="%optflags -Wall"
52 %configure --libexecdir=%{_libdir} --without-included-regex \
53             --enable-install-program=arch \
54             gl_cv_func_printf_directive_n=yes \
55             gl_cv_func_isnanl_works=yes \
56             DEFAULT_POSIX2_VERSION=199209
57
58 make -C po update-po
59 make %{?_smp_mflags} V=1
60
61 %install
62 %make_install pkglibexecdir=%{_libdir}/%{name}
63 echo '.so man1/test.1' > %{buildroot}/%{_mandir}/man1/\[.1
64
65 %find_lang %name
66
67 %post
68 %install_info --info-dir=%{_infodir} %{_infodir}/coreutils.info.gz
69
70 %postun
71 %install_info_delete --info-dir=%{_infodir} %{_infodir}/coreutils.info.gz
72
73
74 %files
75 %defattr(-,root,root)
76 %doc README NEWS
77 %{_bindir}/*
78 %{_libdir}/%{name}
79 %doc %{_infodir}/coreutils.info*.gz
80 %dir %{_prefix}/share/locale/*/LC_TIME
81
82 %docs_package
83
84
85 %changelog