resetting manifest requested domain to floor
[platform/upstream/ccache.git] / packaging / ccache.spec
1 #
2 # spec file for package ccache
3 #
4 # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
16 #
17
18 # norootforbuild
19
20
21 Name:           ccache
22 Version:        3.1.6
23 Release:        1
24 Summary:        A Fast C/C++ Compiler Cache
25
26 License:        GPLv3+
27 Url:            http://ccache.samba.org/
28 Group:          Development/Languages/C and C++
29 Source0:        http://samba.org/ftp/ccache/%{name}-%{version}.tar.bz2
30 Source1001:     ccache.manifest
31 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
32
33 BuildRequires:  zlib-devel
34 Provides:       distcc:/usr/bin/ccache
35
36 %description
37 ccache is a compiler cache. It speeds up recompilation by caching the result of
38 previous compilations and detecting when the same compilation is being done
39 again. Supported languages are C, C++, Objective-C and Objective-C++.
40
41 %prep
42 %setup -q
43 cp %{SOURCE1001} .
44
45 %build
46 %configure
47 make %{?_smp_mflags}
48
49 %install
50 make install DESTDIR=%{buildroot}
51
52 %clean
53 rm -rf %{buildroot}
54
55 %files
56 %manifest %{name}.manifest
57 %defattr(-,root,root,-)
58 %doc AUTHORS.* GPL-3.0.txt INSTALL.* LICENSE.* MANUAL.* NEWS.* README.*
59 %doc %{_mandir}/man1/ccache.1%{ext_man}
60 %{_bindir}/ccache
61
62 %changelog