Tizen 2.1 base
[platform/upstream/ccache.git] / packaging / ccache.spec
1 #
2 # spec file for package ccache
3 #
4 # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
16 #
17
18 # norootforbuild
19
20
21 Name:           ccache
22 Version:        3.1.6
23 Release:        1
24 Summary:        A Fast C/C++ Compiler Cache
25
26 License:        GPLv3+
27 Url:            http://ccache.samba.org/
28 Group:          Development/Languages/C and C++
29 Source0:        http://samba.org/ftp/ccache/%{name}-%{version}.tar.bz2
30 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
31
32 BuildRequires:  zlib-devel
33 Provides:       distcc:/usr/bin/ccache
34
35 %description
36 ccache is a compiler cache. It speeds up recompilation by caching the result of
37 previous compilations and detecting when the same compilation is being done
38 again. Supported languages are C, C++, Objective-C and Objective-C++.
39
40 %prep
41 %setup -q
42
43 %build
44 %configure
45 make %{?_smp_mflags}
46
47 %install
48 make install DESTDIR=%{buildroot}
49
50 %clean
51 rm -rf %{buildroot}
52
53 %files
54 %defattr(-,root,root,-)
55 %doc AUTHORS.* GPL-3.0.txt INSTALL.* LICENSE.* MANUAL.* NEWS.* README.*
56 %doc %{_mandir}/man1/ccache.1%{ext_man}
57 %{_bindir}/ccache
58
59 %changelog