Bump to version 1.22.1
[platform/upstream/busybox.git] / packaging / busybox.spec
1 Name:           busybox
2 Version:        1.22.1
3 Release:        0
4 License:        GPL-2.0+
5 Summary:        The Swiss Army Knife of Embedded Linux
6 Url:            http://www.busybox.net/
7 Group:          System/Utilities
8 Source:         http://busybox.net/downloads/%{name}-%{version}.tar.bz2
9 Source2:        busybox.tizen.config
10 Source1001:     busybox.manifest
11
12 %description
13 BusyBox combines tiny versions of many common UNIX utilities into a
14 small single executable. It provides minimalist replacements for most
15 of the utilities usually found in fileutils, shellutils, findutils,
16 textutils, grep, gzip, tar, and more. BusyBox provides a fairly
17 complete POSIX environment for any small or embedded system. The
18 utilities in BusyBox generally have fewer options than their
19 full-featured GNU cousins. The options that are included provide the
20 expected functionality and behave very much like their GNU
21 counterparts.
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26 cp -a %{SOURCE2} .config
27
28 %build
29 export VERBOSE=-v
30 export BUILD_VERBOSE=2
31 export CFLAGS="%{optflags} -fno-strict-aliasing"
32 export CC="gcc"
33 export HOSTCC=gcc
34 %__make -e oldconfig
35 %__make -e %{?_smp_mflags}
36 %__make -e doc busybox.links %{?_smp_mflags}
37
38 %install
39 install -d %{buildroot}%{_prefix}/bin
40 install -d %{buildroot}%{_datadir}/busybox
41 install busybox.links %{buildroot}%{_datadir}/busybox
42 install applets/install.sh %{buildroot}%{_bindir}/busybox.install
43 install busybox %{buildroot}%{_prefix}/bin
44
45 %files
46 %manifest %{name}.manifest
47 %defattr(-,root,root)
48 %license LICENSE
49 %{_bindir}/busybox
50 %{_bindir}/busybox.install
51 %config %{_datadir}/busybox/busybox.links