Imported Upstream version 1.51.0
[platform/upstream/boost.git] / tools / build / src / engine / boost-jam.spec
1 Name: boost-jam
2 Version: 3.1.19
3 Summary: Build tool
4 Release: 1
5 Source: %{name}-%{version}.tgz
6
7 License: Boost Software License, Version 1.0
8 Group: Development/Tools
9 URL: http://www.boost.org
10 Packager: Rene Rivera <grafik@redshift-software.com>
11 BuildRoot: /var/tmp/%{name}-%{version}.root
12
13 %description
14 Boost Jam is a build tool based on FTJam, which in turn is based on
15 Perforce Jam. It contains significant improvements made to facilitate
16 its use in the Boost Build System, but should be backward compatible
17 with Perforce Jam.
18
19 Authors:
20     Perforce Jam : Cristopher Seiwald
21     FT Jam : David Turner
22     Boost Jam : David Abrahams
23
24 Copyright:
25     /+\
26     +\  Copyright 1993-2002 Christopher Seiwald and Perforce Software, Inc.
27     \+/
28     License is hereby granted to use this software and distribute it
29     freely, as long as this copyright notice is retained and modifications
30     are clearly marked.
31     ALL WARRANTIES ARE HEREBY DISCLAIMED.
32
33 Also:
34     Copyright 2001-2006 David Abrahams.
35     Copyright 2002-2006 Rene Rivera.
36     Copyright 2003-2006 Vladimir Prus.
37
38     Distributed under the Boost Software License, Version 1.0.
39     (See accompanying file LICENSE_1_0.txt or http://www.boost.org/LICENSE_1_0.txt)
40
41 %prep
42 %setup -n %{name}-%{version}
43
44 %build
45 LOCATE_TARGET=bin ./build.sh $BOOST_JAM_TOOLSET
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 mkdir -p $RPM_BUILD_ROOT%{_bindir}
50 mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
51 install -m 755 bin/bjam $RPM_BUILD_ROOT%{_bindir}/bjam-%{version}
52 ln -sf bjam-%{version} $RPM_BUILD_ROOT%{_bindir}/bjam
53 cp -R *.html *.png *.css LICENSE*.txt images jam $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
54
55 find $RPM_BUILD_ROOT -name CVS -type d -exec rm -r {} \;
56
57 %files
58 %defattr(-,root,root)
59 %attr(755,root,root) /usr/bin/*
60 %doc %{_docdir}/%{name}-%{version}
61
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT