inital packaging commit
[platform/upstream/atk.git] / packaging / atk.spec
1 Name:           atk
2 Summary:        An Accessibility ToolKit
3 License:        LGPL-2.1+
4 Group:          System/Libraries
5 Version:        2.6.0
6 Release:        2.1
7 Url:            http://www.gtk.org/
8 Source:         http://download.gnome.org/sources/atk/2.6/%{name}-%{version}.tar.xz
9 Source98:       baselibs.conf
10 BuildRequires:  fdupes
11 BuildRequires:  gcc-c++
12 BuildRequires:  glib2-devel >= 2.31.2
13 BuildRequires:  gobject-introspection-devel
14 BuildRequires:  translation-update-upstream
15 %if 0%{?BUILD_FROM_VCS}
16 BuildRequires:  gnome-common
17 BuildRequires:  gtk-doc
18 %endif
19 Requires:       %{name}-lang = %{version}
20 Requires:       libatk
21 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
22
23 %description
24 The ATK library provides a set of accessibility interfaces. By
25 supporting the ATK interfaces, an application or toolkit can be used
26 with screen readers, magnifiers, and alternate input devices.
27
28 %package -n libatk
29 Summary:        An Accessibility ToolKit
30 Group:          System/Libraries
31 Provides:       %{name} = %{version}
32 Obsoletes:      %{name} < %{version}
33
34 %description -n libatk
35 The ATK library provides a set of accessibility interfaces. By
36 supporting the ATK interfaces, an application or toolkit can be used
37 with screen readers, magnifiers, and alternate input devices.
38
39 %package -n typelib-Atk
40 Summary:        An Accessibility ToolKit -- Introspection bindings
41 Group:          System/Libraries
42
43 %description -n typelib-Atk
44 The ATK library provides a set of accessibility interfaces. By
45 supporting the ATK interfaces, an application or toolkit can be used
46 with screen readers, magnifiers, and alternate input devices.
47
48 This package provides the GObject Introspection bindings for ATK.
49
50 %package devel
51 Summary:        Include Files and Libraries mandatory for Development
52 Group:          Development/Libraries/GNOME
53 Requires:       libatk = %{version}
54 Requires:       typelib-Atk = %{version}
55
56 %description devel
57 This package contains all necessary include files and libraries needed
58 to develop applications that require these.
59
60 %package doc
61 Summary:        Additional Package Documentation for atk
62 Group:          System/Libraries
63 Requires:       libatk = %{version}
64 BuildArch:      noarch
65
66 %description doc
67 This package contains additional documentation for the ATK Library.
68
69 %prep
70 %setup -q
71
72 %if 0%{?BUILD_FROM_VCS}
73 [ -x ./autogen.sh ] && NOCONFIGURE=1 ./autogen.sh
74 %endif
75
76 %build
77 %configure \
78 %if 0%{?BUILD_FROM_VCS}
79   --enable-gtk-doc \
80 %endif
81   --disable-static
82 make %{?_smp_mflags}
83
84 %install
85 %make_install
86 %fdupes $RPM_BUILD_ROOT
87
88 %post -n libatk -p /sbin/ldconfig
89
90 %postun -n libatk -p /sbin/ldconfig
91
92 %files -n libatk
93 %defattr(-, root, root)
94 %doc AUTHORS COPYING ChangeLog NEWS README
95 %{_libdir}/lib*.so.*
96
97 %files -n typelib-Atk
98 %defattr(-, root, root)
99 %{_libdir}/girepository-1.0/Atk-1.0.typelib
100
101 %files devel
102 %defattr(-, root, root)
103 %{_includedir}/atk-1.0
104 %{_libdir}/lib*.so
105 %{_libdir}/pkgconfig/*.pc
106 %{_datadir}/gir-1.0/*.gir
107
108 %files doc
109 %defattr(-, root, root)
110 %dir %{_datadir}/gtk-doc
111 %dir %{_datadir}/gtk-doc/html
112 %{_datadir}/gtk-doc/html/atk