3271fc2f55f10184bfacc9d1a588ef9ef1d9d765
[platform/upstream/atk.git] / packaging / atk.spec
1 %define baseline 2.16
2 Name:           atk
3 Version:        2.30.0
4 Release:        0
5 License:        LGPL-2.0+
6 Summary:        An Accessibility ToolKit
7 Url:            http://www.gtk.org/
8 Group:          System/Libraries
9 Source:         http://download.gnome.org/sources/%{name}/%{baseline}/%{name}-%{version}.tar.xz
10 Source98:       baselibs.conf
11 Source1001:     %{name}.manifest
12
13 BuildRequires:  fdupes
14 BuildRequires:  gcc-c++
15 BuildRequires:  meson >= 0.46.0
16 BuildRequires:  glib2-devel >= 2.35.2
17 BuildRequires:  intltool
18 BuildRequires:  which
19 BuildRequires:  gobject-introspection
20 BuildRequires:  gobject-introspection-devel
21 %if %{with introspection}
22 BuildRequires:  gobject-introspection-devel
23 %endif
24 Requires:       libatk
25
26 %description
27 The ATK library provides a set of accessibility interfaces. By
28 supporting the ATK interfaces, an application or toolkit can be used
29 with screen readers, magnifiers, and alternate input devices.
30
31 %package -n libatk
32 Summary:        An Accessibility ToolKit
33 Group:          System/Libraries
34 Provides:       %{name} = %{version}
35 Obsoletes:      %{name} < %{version}
36
37 %description -n libatk
38 The ATK library provides a set of accessibility interfaces. By
39 supporting the ATK interfaces, an application or toolkit can be used
40 with screen readers, magnifiers, and alternate input devices.
41
42 %package -n typelib-Atk
43 Summary:        An Accessibility ToolKit -- Introspection bindings
44 Group:          System/Libraries
45
46 %description -n typelib-Atk
47 The ATK library provides a set of accessibility interfaces. By
48 supporting the ATK interfaces, an application or toolkit can be used
49 with screen readers, magnifiers, and alternate input devices.
50
51 This package provides the GObject Introspection bindings for ATK.
52
53 %package devel
54 Summary:        Include Files and Libraries mandatory for Development
55 Group:          Development/Libraries/GNOME
56 Requires:       libatk = %{version}
57
58 %description devel
59 This package contains all necessary include files and libraries needed
60 to develop applications that require these.
61
62 %prep
63 %setup -q
64 cp %{SOURCE1001} .
65
66 %build
67 meson --prefix /usr --libdir %{_libdir} build
68 ninja -C build all
69
70 %install
71
72 export DESTDIR=%{buildroot}
73 ninja -C build install
74
75 %fdupes %{buildroot}
76
77 %post -n libatk -p /sbin/ldconfig
78
79 %postun -n libatk -p /sbin/ldconfig
80
81 %files -n libatk
82 %manifest %{name}.manifest
83 %defattr(-, root, root)
84 %doc COPYING
85 %license COPYING
86 %{_libdir}/libatk*.so.*
87 %{_datadir}/locale/
88 %{_libdir}/girepository*/Atk*.typelib
89 %{_datadir}/gir*/Atk*.gir
90
91 %files devel
92 %manifest %{name}.manifest
93 %defattr(-, root, root)
94 %{_includedir}/atk-1.0
95 %{_libdir}/libatk*.so
96 %{_libdir}/pkgconfig/*.pc
97